1.8 won't stay running - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 08-19-2011, 12:09 AM   #1
Newb
Thread Starter
 
Join Date: Nov 2010
Posts: 36
Total Cats: 0
Default 1.8 won't stay running

I've posted this on the other forum but can't get my 92 to stay running after my motor swap. I've checked and it's getting both fuel and spark.
VicksburgMiata is offline   Reply With Quote
Old 08-19-2011, 12:43 AM   #2
Elite Member
 
Join Date: Feb 2008
Location: Victoria, BC
Posts: 2,322
Total Cats: 12
Default

Non-detailed post is non-detailed. So what did you do to put it in the car? What ECU are you running? How long does it run for? Are you ground hooked up right? Was the motor working before you put it in?
dustinb is offline   Reply With Quote
Old 08-19-2011, 01:35 AM   #3
Newb
Thread Starter
 
Join Date: Nov 2010
Posts: 36
Total Cats: 0
Default

I've checked the grounds on it. Its a 92 with the motor out of my 94. The 1.8 was running when it came out. I did a lot of reading before doing the upgrade and the ecu is still stock.
VicksburgMiata is offline   Reply With Quote
Old 08-19-2011, 02:16 AM   #4
Elite Member
 
Join Date: Feb 2008
Location: Victoria, BC
Posts: 2,322
Total Cats: 12
Default

Quote:
Originally Posted by VicksburgMiata View Post
I've checked the grounds on it. Its a 92 with the motor out of my 94. The 1.8 was running when it came out. I did a lot of reading before doing the upgrade and the ecu is still stock.
How did you do the swap? What throttle body & coil packs are you using? How long does it stay running for? What does it do?
dustinb is offline   Reply With Quote
Old 08-19-2011, 02:29 AM   #5
Newb
Thread Starter
 
Join Date: Nov 2010
Posts: 36
Total Cats: 0
Default

It was pretty straight forward on pull the 1.6 and putting in the 1.8 using the throttle body, coils and all sensors from the 1.6. It will crank and run for less than two seconds then die. I'm beginning to think the injectors are sticking. I had two complete cars when I did the swap. My 92 had a bad motor but good body and the 94 was just the opposite.
VicksburgMiata is offline   Reply With Quote
Old 08-19-2011, 03:18 AM   #6
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Ground FP to GND in the diagnostic connector and see if that keeps it running.
Reverant is offline   Reply With Quote
Old 08-19-2011, 02:14 PM   #7
Newb
Thread Starter
 
Join Date: Nov 2010
Posts: 36
Total Cats: 0
Default

I turned the fuel pump on it still won't stay running. Gonna recheck the timing to make sure it's all where it belongs.
VicksburgMiata is offline   Reply With Quote
Old 08-20-2011, 10:28 PM   #8
Newb
Thread Starter
 
Join Date: Nov 2010
Posts: 36
Total Cats: 0
Default

Got it running. Thanks for all the help.
VicksburgMiata is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
15x10 - 15x11 6UL @ 949 Racing emilio700 Wheels and Tires 151 06-02-2017 03:36 PM
01-05 Fab9 PNP COPs (used) FrankB Miata parts for sale/trade 6 09-30-2015 12:48 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:21 AM.