1100rpm idle even when warm - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 03-05-2012, 09:13 PM   #1
Senior Member
Thread Starter
 
Join Date: Nov 2010
Location: Pittsburgh PA
Posts: 1,196
Total Cats: 12
Default 1100rpm idle even when warm

I've been noticing my 99 idling at 1100, even once the car is warmed up. I used a torch to blow propane at all the vacuum lines I could find, and didn't hear the idle spike. I adjusted the throttle cable, and the small screw in front of the throttle body, hoping to drop the idle. No dice. I also lubricated the throttle body return spring, and insured the throttle moved, and returned properly.

The car is an 99, BP4W, with a stock ECU. It's a 49 state car, with a racing beat header (stock EGR tube retained), and an enthuza cat back. The car received a new cat about 3000mi ago (thanks PA state inspection ).

The car has a CEL, but I believe it is due to the EGR valve being block off previously. The car also threw a code (EGR related) when I installed my POS OBX header with an EGR block off (had to bend the tube to fit another day). I had to wait a day after the racing beat install for my new EGR tube. I'll be checking the code tomorrow at work, but assuming the code is the EGR, what else should I do to fix this problem?

Thanks.
2ndGearRubber is offline   Reply With Quote
Old 03-06-2012, 02:51 PM   #2
Elite Member
iTrader: (24)
 
Join Date: Jun 2007
Location: Sherman Oaks, CA
Posts: 4,480
Total Cats: 3
Default

TPS perhaps?
UrbanSoot is offline   Reply With Quote
Old 03-06-2012, 09:55 PM   #3
Senior Member
Thread Starter
 
Join Date: Nov 2010
Location: Pittsburgh PA
Posts: 1,196
Total Cats: 12
Default

Ahhh, hadn't thought of that. I'll figure out a way to test it.

Thanks
2ndGearRubber is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM
mslabs MS2 - Idle control issue ndragun MEGAsquirt 0 09-20-2015 11:28 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:01 PM.