1999 Charging Issue...light is on - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 11-10-2008, 04:11 PM   #1
Junior Member
Thread Starter
iTrader: (6)
 
Join Date: Oct 2007
Location: So Cal
Posts: 331
Total Cats: 0
Default 1999 Charging Issue...light is on

Hi Everyone, I know this topic has been covered multiple times ( I read them this morning), but I am having a charging issue and I am @ work so I want help to diagnose it, possible, JIC my car doesn't start when I go home.

I drove to work this morning and half way here my charging light came on and my idle was higher @ stop signs/lights along with my voltage reading approximately 11.2-11.6 (scanguage II).

When I got to work I checked my AIT and MAF just to make sure (I have previously heard those can cause the issue) along with the tension on the serpentine belt and all was good. I drove it for lunch and the same issue was occuring but when I got to approximately 4,700 RPM the light went off for about 30 seconds then returned.

Any help is appricated seeing that this is making all my electronics act differently (voodoo box/ AFR readings? etc.)
Also I removed my cluster yesterday to remove some old colored guage faces could it be possible that something up there was dissconnected? I attached the only three pigtails up there so...IDK. Thanks for the help, and I will try to check this thread reguarly, but again, I am @ work right now

PS i posted this on m.net so it will be interesting to see what the responses are.
99NBMia is offline   Reply With Quote
Old 11-10-2008, 07:25 PM   #2
Junior Member
Thread Starter
iTrader: (6)
 
Join Date: Oct 2007
Location: So Cal
Posts: 331
Total Cats: 0
Default

99NBMia is offline   Reply With Quote
Old 11-10-2008, 08:30 PM   #3
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Can't tell you what you fucked up messing with the gauge cluster. But I can tell you that the stock AIT sensor has to be working properly for the alternator to charge. Unplug it or short it, and the alternator stops charging and the light comes on.
patsmx5 is offline   Reply With Quote
Old 11-11-2008, 12:20 AM   #4
Senior Member
iTrader: (8)
 
Join Date: Oct 2005
Posts: 764
Total Cats: 0
Default

NB alternators are shitty...they tend to flake....like many other items on NBs.
Mine recently was charging low and light was coming on...a new "used" alternator solved the issue.
miatanutz is offline   Reply With Quote
Old 11-11-2008, 04:27 PM   #5
Junior Member
Thread Starter
iTrader: (6)
 
Join Date: Oct 2007
Location: So Cal
Posts: 331
Total Cats: 0
Default

Quote:
Originally Posted by patsmx5 View Post
Can't tell you what you fucked up messing with the gauge cluster. But I can tell you that the stock AIT sensor has to be working properly for the alternator to charge. Unplug it or short it, and the alternator stops charging and the light comes on.
Yep did all of this, I just got pissed so I removed the alternator and took it along with an old one I bought off CL, (that was from a NB that was in a fire for 15 dollars) to autozone. They checked both and the one off my car was dead and the one from the fire was good...LOL I bought it like 3 months ago and heard people I know bitch for me buying useless crap. HAHAHAHA saved me like 150+ dollars
99NBMia is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 58 12-13-2017 10:04 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
VR6 to Miata Swap ScrapinMX5 Meet and Greet 8 09-28-2015 02:04 PM
Another Alternator thread ihiryu General Miata Chat 9 09-28-2015 11:22 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:11 PM.