Baffling misfire. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 07-18-2014, 08:27 AM   #1
Newb
Thread Starter
 
Join Date: Nov 2010
Location: Yorkshire, UK
Posts: 36
Total Cats: 12
Default Baffling misfire.

I'm totally stuck now, hope you can help.

1993 1.6 UK car, greddy turbo with emanage (I know I know, it's going MS but only once its roadworthy)

Off the road, not been started for 6 months.

Charged battery, starts first turn but missing on cylinder 2 and cylinder 4.

Changed plugs round, no change.
Changed leads for spares, no change.
Tried plugs out the head, big blue spark on each, aching fingers to prove.
Tested coil, 13k ohm each side. Tried spare coil, no change.
Plugs in the nonfiring cylinders are soaking and lots of fuel out the exhaust - definitely injecting plenty.
Compression tested - 195 185 190 190 so very good.
Cleaned all earth's, wiggled wires etc, no change.

Also looped out the emanage/fpr just in case and no change (so it's effectively a stock car with an inefficient exhaust!)

It starts on the button on two cylinders, it's very very regimented. Strict won't fire on 2 and 4. It will sit and run happily chugging along on two cylinders seemingly indefinitely.

It 'feels' electrical, but I've checked everything. And the cylinders it's not firing doesn't tie with the shared coils or anything.

Gets to the point there's so much fuel pooling in the exhaust it's a bit worrying.

Run out of ideas now, does anyone have any suggestions?
snotrag is offline   Reply With Quote
Old 07-18-2014, 09:47 AM   #2
Senior Member
iTrader: (1)
 
Join Date: Apr 2011
Location: Columbia, SC
Posts: 1,342
Total Cats: 78
Default

Does emanage use speed density?
Schuyler is offline   Reply With Quote
Old 07-18-2014, 04:26 PM   #3
Newb
Thread Starter
 
Join Date: Nov 2010
Location: Yorkshire, UK
Posts: 36
Total Cats: 12
Default

It uses a map sensor, however for the purpose of this problem we are talking about a stock setup really (albeit with an inefficient exhaust system!). Have tried the emanage looped out and no change.

Eta since posting have also changed injectors, CAS, ecu.... No change.
snotrag is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Garrett Turbo, 1.8 Oil Pan, & Misc. Stuff nbdooey Miata parts for sale/trade 9 08-30-2017 10:50 PM
Built 1.6l Engine, 1,820 miles Baxgordum Miata parts for sale/trade 19 09-05-2015 12:42 AM
Mahura oil pan baffle Boost Joose Race Prep 13 11-12-2014 08:59 PM
Dwell observations on the Toyota COP. Joe Perez MEGAsquirt 44 08-03-2012 02:14 PM
CLT going bonkers akaryrye MEGAsquirt 5 11-15-2006 01:51 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:21 PM.