Car wont stay on... - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 10-27-2006, 01:13 AM   #1
Elite Member
Thread Starter
iTrader: (2)
 
Newbsauce's Avatar
 
Join Date: Jul 2006
Location: NoVA
Posts: 2,304
Total Cats: 2
Default Car wont stay on...

Well my idle has been lumpy, its been glugging on the start, and the car seems to stall out when I turn on the lights. Well tonight LUCKILY just as I pulled into my neighborhood as I was coasting in, boom.. the engine died. Now the interesting part is.. the batt "charge" light came on.. the lights stayed on.. and when I parked it.. I checked to see if it could crank..and it could, but it died in like 5 seconds. Alternator? Bad ground? Battery? Feedback please.
Newbsauce is offline   Reply With Quote
Old 10-27-2006, 07:55 AM   #2
Senior Member
iTrader: (14)
 
brgracer's Avatar
 
Join Date: Nov 2004
Location: Ambler, PA
Posts: 1,275
Total Cats: 1
Default

I was wondering how long it'd be before something on your car broke.

My vote is for that damn vpc.

Seriously, sounds like the alternator. Get a voltmeter to check the battery voltage and you could also disconnect the negative side and check the current between the negative battery cable to ground to check for a dark current draw.
brgracer is offline   Reply With Quote
Old 10-27-2006, 09:06 AM   #3
Elite Member
iTrader: (3)
 
Mach929's Avatar
 
Join Date: Oct 2004
Location: lansdale PA
Posts: 2,500
Total Cats: 0
Default

i hate alt/battery problems. i always just replace both just to be done with it. I'm on my 3rd alternator on the miata btw
Mach929 is offline   Reply With Quote
Old 10-27-2006, 09:36 AM   #4
Elite Member
Thread Starter
iTrader: (2)
 
Newbsauce's Avatar
 
Join Date: Jul 2006
Location: NoVA
Posts: 2,304
Total Cats: 2
Default

Quote:
Originally Posted by brgracer View Post
I was wondering how long it'd be before something on your car broke.

My vote is for that damn vpc.
You are a firm believer in the anti-vpcism. You wait til I post my MAF'less numbers damnit!
Newbsauce is offline   Reply With Quote
Old 10-27-2006, 09:44 AM   #5
Elite Member
iTrader: (5)
 
m2cupcar's Avatar
 
Join Date: Jan 2005
Location: Atlanta
Posts: 7,244
Total Cats: 291
Default

You can get a $20 meter that will measure current per brgracer's suggestion. My Miata showed 4.5 milliamps, but others have seen as much as 20. Check your ground that runs from the neg batt terminal down to the ppf near the fuel filter.
m2cupcar is offline   Reply With Quote
Old 10-27-2006, 10:59 AM   #6
Elite Member
Thread Starter
iTrader: (2)
 
Newbsauce's Avatar
 
Join Date: Jul 2006
Location: NoVA
Posts: 2,304
Total Cats: 2
Default

Thanks for the input guys.. I will be sure to test it today.. for some reason I have a feeling I have a bad ground
Newbsauce is offline   Reply With Quote
Old 10-27-2006, 11:28 AM   #7
Elite Member
iTrader: (5)
 
m2cupcar's Avatar
 
Join Date: Jan 2005
Location: Atlanta
Posts: 7,244
Total Cats: 291
Default

bad grounds have been the source my electrical problems more the once
m2cupcar is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
MS PNP requires reading and following directions??? satisfied MEGAsquirt 141 10-06-2015 11:44 AM
MS3 Basic Connection Issues EErockMiata MEGAsquirt 6 09-24-2015 10:49 AM
Megasquirt 2 or 3 ? TheNomad Engine Performance 3 09-21-2015 11:20 PM
1997 Miata Misty_Miata pineda92 Meet and Greet 4 09-20-2015 10:22 PM
Stripped clutch slave bell housing threads. EricJ Suspension, Brakes, Drivetrain 6 09-13-2015 10:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:23 AM.