cold start woes! - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 05-01-2008, 10:18 PM   #1
Newb
Thread Starter
 
Join Date: Jan 2008
Posts: 2
Total Cats: 0
Default cold start woes!

Hey guys,

My 94 miata has been having this problem for a while now. Upon a cold start, the car will start up and idle very rough until it starts to warm up were it gradually starts to idle fine. Once its completely warm, the car idles like it should.

In the first minute of the startup, the car has misses randomly and smells a bit like a 2 stroke. I've changed the coil pack, plug wires, temperature sensor and injectors and the engine is still acting up.

Once the car has warmed up the engine will run fine. I can start it 45 minutes later and the car will run fine however if i wait for the car to completely cool, it'll start missing upon startup.

I honestly out of ideas now, waht do you guys recon it could be? What should i check...

Thanks for the help...
mx5jmcb is offline   Reply With Quote
Old 05-01-2008, 10:43 PM   #2
Elite Member
iTrader: (24)
 
kotomile's Avatar
 
Join Date: Oct 2006
Location: Monterey, CA
Posts: 7,578
Total Cats: 40
Default

setup, ecu mods?
kotomile is offline   Reply With Quote
Old 05-01-2008, 11:04 PM   #3
Newb
Thread Starter
 
Join Date: Jan 2008
Posts: 2
Total Cats: 0
Default

Quote:
Originally Posted by kotomile View Post
setup, ecu mods?
car is running stock ecu, its not ecu or map related, that i am sure!
mx5jmcb is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:04 AM.