cruise control with boost - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 04-16-2010, 06:08 PM   #1
Senior Member
Thread Starter
iTrader: (22)
 
Join Date: Oct 2007
Location: bay area, ca
Posts: 551
Total Cats: 19
Default cruise control with boost

I have a problem with cruise control on my begi-s + gt2554r setup. As soon as I set speed the car speeds up, boost gets generated, cruise stops accelerating, the car slows down, etc. This is on level ground at highway speeds (55-65mph). It then repeats this with a period of 4-5s. Some searching shows that lots of people have cruise working with turbos and that this problem is usually due to a vacuum leak or allowing the cruise control to see greater than atmosphere pressure. I tried putting a check valve in the line and that didn't change anything. Below is an older pic of my car showing the cruise MAP line plumbing. Maybe the problem is plumbing it directly after the TB or in parallel with the bosch bypass valve? Any ideas?

Maybe I should try a different check valve.

orion4096 is offline   Reply With Quote
Old 04-16-2010, 06:18 PM   #2
Elite Member
iTrader: (46)
 
Stein's Avatar
 
Join Date: Dec 2007
Location: Nebraska
Posts: 4,812
Total Cats: 138
Default

FWIW, I ran my line off a dedicated port on the IM to the cruise. Worked perfectly and no check valve needed. I'd pull it off of the BOV line for sure.
Stein is offline   Reply With Quote
Old 04-18-2010, 01:53 PM   #3
Senior Member
Thread Starter
iTrader: (22)
 
Join Date: Oct 2007
Location: bay area, ca
Posts: 551
Total Cats: 19
Default

Moved the BOV to the rear of the intake and gave cruise it's own port at the front. Same problem.
Disconnected the BOV. Same problem.

I'm going to try a new check valve and if that doesn't work the cruise control is being pulled.
orion4096 is offline   Reply With Quote
Old 04-18-2010, 01:58 PM   #4
Elite Member
iTrader: (2)
 
Mobius's Avatar
 
Join Date: May 2008
Location: Portland, Oregon
Posts: 3,178
Total Cats: 267
Default

I haven't had any issues with my cruise since installing the Rotrex. When the cruise accelerates, it adds throttle until 0 vacuum/0 boost is reached, and maintains that. No surging or other issues.
Mobius is offline   Reply With Quote
Old 04-18-2010, 02:06 PM   #5
Elite Member
iTrader: (4)
 
Pen2_the_penguin's Avatar
 
Join Date: Dec 2009
Location: Reno, NV
Posts: 3,690
Total Cats: 97
Default

I installed a check valve. I dontz allow boostz to affect my cruise.
Pen2_the_penguin is offline   Reply With Quote
Old 04-19-2010, 09:59 AM   #6
Elite Member
iTrader: (2)
 
fooger03's Avatar
 
Join Date: Jan 2009
Location: Columbus, OH
Posts: 4,133
Total Cats: 188
Default

Check valve + vacuum accumulator? the car shouldn't actually go into boost while your cruise control is holding a steady speed unless you start going up an incline.
fooger03 is offline   Reply With Quote
Old 04-19-2010, 12:43 PM   #7
Moderator
iTrader: (11)
 
sixshooter's Avatar
 
Join Date: Nov 2008
Location: Tampa, Florida
Posts: 15,684
Total Cats: 1,562
Default

I hadn't read anything about it but I was always under the assumption that I would lose my cruise control when I changed to MS as a standalone. I was hating the thought of a six or seven hour drive in the Miata anyway. Without cruise it would be even worse.

So I get to keep it? Yay!
sixshooter is online now   Reply With Quote
Old 04-19-2010, 01:22 PM   #8
Senior Member
Thread Starter
iTrader: (22)
 
Join Date: Oct 2007
Location: bay area, ca
Posts: 551
Total Cats: 19
Default

Tried a new check valve and that didn't do anything. I also tried at slower speeds and it still cutout before it even hit boost. This makes me think it's not turbo related. The FM clutch override is installed and maybe that's causing it to cutout. I'll try pulling it tonight.
orion4096 is offline   Reply With Quote
Old 04-19-2010, 10:59 PM   #9
Former Vendor
 
Join Date: Jun 2006
Location: Bell Tuning & Performance
Posts: 1,338
Total Cats: -78
Default

I remember this thread on m.net from a few months ago. Would it help?
http://forum.miata.net/vb/showthread...urbo+Miatas%3F
Stephanie
Stephanie Turner is offline   Reply With Quote
Old 04-19-2010, 11:36 PM   #10
Senior Member
Thread Starter
iTrader: (22)
 
Join Date: Oct 2007
Location: bay area, ca
Posts: 551
Total Cats: 19
Default

I didn't see much in that thread other than:
- it should work.
- try a check valve.

Mine actually doesn't cut out completely (as in disables cruise), rather, it continues to accelerate then cutout then accelerate then cutout (repeat infinitely every 4-5s oscillating around target speed) without any input from me. I was hoping it was still functional so I could sell it, but it might be toast.

Pulling the clutch override didn't change anything which isn't much of a surprise.
orion4096 is offline   Reply With Quote
Old 04-20-2010, 12:33 AM   #11
Elite Member
iTrader: (2)
 
fooger03's Avatar
 
Join Date: Jan 2009
Location: Columbus, OH
Posts: 4,133
Total Cats: 188
Default

sounds like a bad cruise control brain. was a common problem with early '99s (my current DD included) where they would slowly accel 6 or 7 mph, then let off throttle completely until they hit target speed, then slowly accel again.

call FM salvage or planet miata and get one cheap
fooger03 is offline   Reply With Quote
Old 04-20-2010, 11:13 AM   #12
Junior Member
 
Join Date: Apr 2007
Location: Melboure australia
Posts: 171
Total Cats: 0
Default

this may or may not help,

i had a simular problem with my b2600, i found that it accelerated hard when the vehicle lost speed, so i restricted the vac line to the diaphram (brain) this slowed the vac to brain & made it less harsh, (less aggressive)

if you take some vac out (restrict it) somewhat the diaphram will not have the power to move around so much therfore wont try adjust to the speed as much, which in theory should settle the car quicker. The way i think of it is as a sea saw, the more weight you put on one end the faster the other end goes up, & visa versa... im not sure how well i have explained my theory but try restricting the vac line & see if it helps....
sprx3 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
1991 special edition with hard top full part out JC, NJ russian Miata parts for sale/trade 6 10-08-2015 04:01 PM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:16 AM.