Fixed the fuel pump, now the fuel gauge doesn't work... - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 12-20-2008, 12:38 AM   #1
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Omaha, NE
Posts: 619
Total Cats: 0
Default Fixed the fuel pump, now the fuel gauge doesn't work...

Any ideas what I could check? At first I thought the fuel float got stuck on something in the fuel tank. Took the assembly out again... it seemed to be working fine. Problem is my fuel gauge says it is just under 1/2 tank ALL the time. Everything else works. What did I do?
posidon42 is offline   Reply With Quote
Old 12-20-2008, 04:12 PM   #2
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,107
Total Cats: 518
Default

check for cracked wires that might have a partial ground to the chassis, also check that you plugged it back in properly, if I remember correctly the gauge won't return to empty if you unplug it, it'll just stay where it was when it was unplugged.
curly is offline   Reply With Quote
Old 12-20-2008, 06:30 PM   #3
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Omaha, NE
Posts: 619
Total Cats: 0
Default

That might be what is happening. I just noticed that it is starting to drop a little bit after some spirited driving I will keep driving it over the next couple of days and see how it goes. Hopefully it returns to normal when I refill the tank. It didn't do it the other day.
posidon42 is offline   Reply With Quote
Old 12-23-2008, 07:10 PM   #4
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Omaha, NE
Posts: 619
Total Cats: 0
Default

Ok, so the gauge still works, it just seems like the 'full' mark has been reset to below half tank. I am going to try just disconnecting the battery and seeing if this will reset it. Otherwise I have no idea why it is doing this.
posidon42 is offline   Reply With Quote
Old 12-23-2008, 07:42 PM   #5
Junior Member
iTrader: (1)
 
Join Date: Mar 2007
Location: South Florida
Posts: 491
Total Cats: -1
Default

Quote:
Originally Posted by posidon42 View Post
Ok, so the gauge still works, it just seems like the 'full' mark has been reset to below half tank. I am going to try just disconnecting the battery and seeing if this will reset it. Otherwise I have no idea why it is doing this.
Disconnecting the battery is not going to do anything.

If all the readings are offset one way it means that rod for the sending unit bent during installation. If the gauge doesn't move then the sending unit is hanging on something.

Tony
mrtonyg is offline   Reply With Quote
Old 12-24-2008, 01:59 AM   #6
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Omaha, NE
Posts: 619
Total Cats: 0
Default

Hrm... Time to take that fuel cover off again... I originally thought it was hung on something too, but it DOES get lower once the car is truly at half tank. I don't think the rod is bent as it showed empty the other day and I put in the normal amount of fuel for an empty tank. Then the gauge only showed a little less than 1/2 tank again. I don't have time to mess with it tonight. I get off work early tomorrow and might have a chance to continue the diagnosis.
posidon42 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 58 12-13-2017 10:04 PM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:51 PM.