Fluctuating oil pressure after oil change with Rotella Syn. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 06-14-2009, 02:52 AM   #1
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: May 2009
Location: Athens GA
Posts: 434
Total Cats: 3
Default Fluctuating oil pressure after oil change with Rotella Syn.

I just did a oil change on my miata a few days back. Its a 91 with a 1.8 swap and a turbo. I used Rotella syn. 5w40 oil and a Purolator PL14610 filter (just a little longer than the PL14612). Today I was driving the car at ~60mph and I noticed that the oil pressure was fluctuating a little (~5psi) at constant rpm. Some where I read that the rotella has more dtergents and will clean the engine on first use. Could this be the reason its fluctuating, with all the crap floating around? I just bought the car and the previous owner said he used Mobile 1.

I am worried and wondering if I am damaging the engine. Any pointers?

Thanks.
-Raj
redrider706 is offline   Reply With Quote
Old 06-14-2009, 04:06 AM   #2
Junior Member
iTrader: (5)
 
Join Date: Aug 2008
Location: Northbrook IL
Posts: 105
Total Cats: 0
Default

I have a 1.8l and mine fluctuates +- 5psi but only at idle, i use mobile 1.
dima88 is offline   Reply With Quote
Old 06-14-2009, 10:30 AM   #3
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

how is your oil pressure sensor mounted? If its not pointing "down" then you could have air in the sensor.
hustler is offline   Reply With Quote
Old 06-14-2009, 06:55 PM   #4
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: May 2009
Location: Athens GA
Posts: 434
Total Cats: 3
Default

It is mounted horizontally. I will check the connections tomorrow.


Thanks guys.
-Raj
redrider706 is offline   Reply With Quote
Old 06-14-2009, 07:34 PM   #5
Junior Member
 
Join Date: Mar 2008
Location: Charleston, S.C.
Posts: 159
Total Cats: 0
Default

Are you using the OEM OPG and sender?? If so a few things could be happening. First if you have knock the OEM sensor reacts to it as varying readings. The second thing is if the connector on the sender is dirty it causes strange readings. I've fixed many a "I have an oil pressure issue" by cleaning the tab on the sender with some emery cloth and spraying some tuner cleaner into the connector on the wire.
04 Miata is offline   Reply With Quote
Old 06-14-2009, 09:06 PM   #6
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: May 2009
Location: Athens GA
Posts: 434
Total Cats: 3
Default

Quote:
Originally Posted by 04 Miata View Post
Are you using the OEM OPG and sender?? If so a few things could be happening. First if you have knock the OEM sensor reacts to it as varying readings. The second thing is if the connector on the sender is dirty it causes strange readings. I've fixed many a "I have an oil pressure issue" by cleaning the tab on the sender with some emery cloth and spraying some tuner cleaner into the connector on the wire.
Yes, I am using the OEM OPG and sender. I have been driving the car for a few weeks now at about the same condition and did not notice any fluctuation before the oil change. I did try to remove the connector to the sender unit to move it out of the way when trying to remove the oil filter. I couldn't get it off, but I might have loosened it a bit. I will check it tomorrow.

Thanks.
redrider706 is offline   Reply With Quote
Old 06-15-2009, 04:27 AM   #7
I'm Miserable!
iTrader: (16)
 
Join Date: Dec 2008
Location: where most people are Utarded
Posts: 1,323
Total Cats: 0
Default

Yeah, check the connector as been said. Also, how many miles since the oil change? I started using the Rotella in my Jeep a few months ago and changed only the filter after about 1500 miles because of the gunk that cleaned out of the engine and stuck in the filter. I'll do a complete oil change in it after another 2k miles or so. I also plan to start using Rotella in the Miata as well with the next oil change.
zoomin is offline   Reply With Quote
Old 06-15-2009, 12:54 PM   #8
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: May 2009
Location: Athens GA
Posts: 434
Total Cats: 3
Default

I have only driven about 100 miles since the oil change. Will check/clean the connector this evening.

Thanks.
redrider706 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Moroso Air Oil Separator Catch Can Aroundcorner Miata parts for sale/trade 2 10-01-2015 04:20 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:51 PM.