Fuel pump doesn't like to prime when hot - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 04-12-2014, 03:00 PM   #1
Senior Member
Thread Starter
 
Join Date: Sep 2013
Posts: 903
Total Cats: 59
Default Fuel pump doesn't like to prime when hot

Chassis is a 94 with 210k on it
Motor is an 02
ECU is an AEM EMS-4

When it's kind of hot outside, the car doesn't want to prime the fuel pump when putting the key into the on position (before bumping the starter). My guess is either main relay, fuel pump relay, or the fuel pump finally kicking the bucket.

I don't want to throw parts at it before narrowing it down a little bit further.

Anybody have similar issues?
Dunning Kruger Affect is offline   Reply With Quote
Old 04-14-2014, 05:49 PM   #2
Elite Member
iTrader: (1)
 
Leafy's Avatar
 
Join Date: Jun 2012
Location: NH
Posts: 9,091
Total Cats: 90
Default

what firmware is on the EMS4, do you have a password on the ems4? When it fails to prime the pump will it still start and/or connect to the laptop?
Leafy is offline   Reply With Quote
Old 04-14-2014, 07:03 PM   #3
Senior Member
Thread Starter
 
Join Date: Sep 2013
Posts: 903
Total Cats: 59
Default

It isn't the firmware. It's probably 1.21 and I put a password on it forever ago; I'm aware of the issue.

I can click on/off the ignition usually a handful of times and the fuel pump will prime, sometimes it'll take a few dozen attempts.
Dunning Kruger Affect is offline   Reply With Quote
Old 04-14-2014, 07:08 PM   #4
Elite Member
iTrader: (1)
 
Leafy's Avatar
 
Join Date: Jun 2012
Location: NH
Posts: 9,091
Total Cats: 90
Default

If it has this issue will the fuel pump run with FP jumpered to ground?
Leafy is offline   Reply With Quote
Old 04-15-2014, 10:40 PM   #5
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,355
Total Cats: 1,322
Default

Quote:
Originally Posted by Leafy View Post
If it has this issue will the fuel pump run with FP jumpered to ground?
+1. Sounds like a FP relay. Replicate the issue, leave the key on, then try to jump the FP in the diagnostic box. On the '94, jumping FP to GND just trips the relay.
Savington is offline   Reply With Quote
Old 04-16-2014, 12:47 AM   #6
Elite Member
iTrader: (1)
 
Leafy's Avatar
 
Join Date: Jun 2012
Location: NH
Posts: 9,091
Total Cats: 90
Default

You can also use the FP to ground connection with the ohm meter to check and see if the EMS4 is actually pulling it to ground.

But it sounds like a relay issue to me, I know mine melted the actual relay socket and the relay got dodgy and there was no ******* way I was spending like $200 for a relay so I just wired it for a $15 universal 40amp one.
Leafy is offline   Reply With Quote
Old 04-16-2014, 09:57 AM   #7
Senior Member
Thread Starter
 
Join Date: Sep 2013
Posts: 903
Total Cats: 59
Default

I'll remember to keep a jumper wire with me next time I drive the car.
Dunning Kruger Affect is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:18 PM.