I lost............ - Page 2 - Miata Turbo Forum - Boost cars, acquire cats.

General Miata Chat A place to talk about anything Miata

I lost............

Old 09-17-2007, 03:22 AM
  #21  
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,824
Total Cats: 268
Default

Originally Posted by zoom2zoom View Post
I hit a 2.2 60' a few weeks ago on 185's and managed a 16.2 1/4 on only 4psi. Not bad for 4psi at elevation. A vert Mustang GT ran a 16.4, so I felt good.
Explain to me how you launched and got a 2.2 60' PLEASE
patsmx5 is offline  
Old 09-17-2007, 03:22 AM
  #22  
Senior Member
iTrader: (1)
 
Join Date: Aug 2006
Location: Illinois
Posts: 1,011
Total Cats: 7
Default

Originally Posted by magnamx-5 View Post
Well "yeah" alot of us DIY people run 250+whp at 12+psi. So we should pull WS6's
Diy 14psi
lazzer408 is offline  
Old 09-17-2007, 03:24 AM
  #23  
I'm Miserable!
iTrader: (5)
 
Join Date: Sep 2005
Location: SLC, Utah
Posts: 1,589
Total Cats: 0
Default

Originally Posted by patsmx5 View Post
Explain to me how you launched and got a 2.2 60' PLEASE
drive turbo Miatas for 5+ years and you will figure it out.
zoom2zoom is offline  
Old 09-17-2007, 03:48 AM
  #24  
I'm Miserable!
Thread Starter
 
Join Date: Aug 2007
Posts: 45
Total Cats: 0
Default

Originally Posted by lazzer408 View Post
Diy 14psi
I tried to do 14 psi myself but I just turned blue. Never tell me to do that again.
yeah_its_boosted is offline  


Thread Tools
Search this Thread

Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.