Misfire at idle and light throttle - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 07-24-2012, 07:27 PM   #1
Junior Member
Thread Starter
 
Join Date: Oct 2009
Location: Anderson, SC
Posts: 321
Total Cats: -2
Default Misfire at idle and light throttle

Hey guys so I consistently have a misfire at idle (had to make idle super rich 11-12 just to keep it from dying) and also at light throttle. I changed out the plugs and it still does it. Wires are ngk blues with around ~10k miles. Should I change out the coils? Car has 78k miles.. Oh and my tach has been going crazy for forever. It drops out and back in inconsistently but I have been unsuccessful locating its ground. Any advice appreciated

Last edited by cowboys647; 07-24-2012 at 07:32 PM. Reason: Tach
cowboys647 is offline   Reply With Quote
Old 07-25-2012, 04:38 AM   #2
Newb
 
Join Date: Jun 2012
Location: Helsinki, Finland
Posts: 30
Total Cats: 3
Default

Could it be an injector that's leaking fuel? When the pulse width goes short, one cylinder runs rich and the other ones lean. Increasing the load would even it to the point where the difference between cylinders is smaller. Did the sparks look roughly the same? Don't know about the tacho though..
[Ode] is offline   Reply With Quote
Old 07-25-2012, 02:59 PM   #3
Junior Member
Thread Starter
 
Join Date: Oct 2009
Location: Anderson, SC
Posts: 321
Total Cats: -2
Default

Yea I guess anything is possible but I haven't noticed any leaks. Seems to spark good but I'll check all the wires with a timing light soon to make sure their sparking.
cowboys647 is offline   Reply With Quote
Old 08-16-2012, 10:19 PM   #4
Senior Member
iTrader: (8)
 
paNX2K&SE-R's Avatar
 
Join Date: Dec 2007
Location: Mocksville, NC
Posts: 676
Total Cats: 11
Default

Any updates to this issue cowboys?
paNX2K&SE-R is offline   Reply With Quote
Old 08-17-2012, 12:08 AM   #5
Junior Member
Thread Starter
 
Join Date: Oct 2009
Location: Anderson, SC
Posts: 321
Total Cats: -2
Default

Did a compression test and cylinder 4 was really low so did a leakdown and 60% was leaking from that cylinder. Our guess was the rings because it sounded like it was leaking through the crankcase. Have all the parts for a built engine on the way.
cowboys647 is offline   Reply With Quote
Old 08-17-2012, 11:16 PM   #6
Senior Member
iTrader: (8)
 
paNX2K&SE-R's Avatar
 
Join Date: Dec 2007
Location: Mocksville, NC
Posts: 676
Total Cats: 11
Default

That sucks. Oh well its a good opportunity to build a nice stout bottom end now at least.
paNX2K&SE-R is offline   Reply With Quote
Old 08-18-2012, 07:44 PM   #7
Newb
 
Join Date: Jun 2012
Posts: 20
Total Cats: -1
Default

Out with the old and in with the fun in some ways I envy you. I'm at 255,000 and counting.
hatecity24 is offline   Reply With Quote
Old 08-19-2012, 04:04 PM   #8
Junior Member
Thread Starter
 
Join Date: Oct 2009
Location: Anderson, SC
Posts: 321
Total Cats: -2
Default

Yeah I'm not sure if it's a blessing or a curse but luckily I had the money and since the engine is out I might as well go all out with my measly budget.
cowboys647 is offline   Reply With Quote
Old 10-10-2012, 07:17 PM   #9
Junior Member
Thread Starter
 
Join Date: Oct 2009
Location: Anderson, SC
Posts: 321
Total Cats: -2
Default

Hey guys, so after building my engine I still have this same miss. The only thing I didn't mess with was the head. I did a compression check last night and the compression is good and consistent. I'm going to try and borrow my brother's cam and crank sensors and see if those make a difference. Any other ideas?
cowboys647 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:09 PM.