No dash lights after heater core install . . . - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 09-27-2007, 05:42 PM   #1
Junior Member
Thread Starter
 
Join Date: Nov 2005
Posts: 87
Total Cats: 0
Default No dash lights after heater core install . . .

Got my new heater core in (did it the hard way by taking out the whole dash and it's every bit as horrible as I'd been led to believe) and everything works except my dash illumination. I have all three electrical connectors hooked into the instrument cluster and the gauges all work but when the lights are off the hardtop defroster light is dimly illuminated and when the parking or headlights are on the light goes completely off and none of the dash lights come on. The only thing that wasn't reinstalled exactly as it was before is a single ground that was connected originally near the driver side eyeball vent that I relocated to piece of the dash structure near the hood release. Could this be related? Any other ideas? Thanks in advance.
tylerdurden is offline   Reply With Quote
Old 09-28-2007, 12:16 AM   #2
Elite Member
iTrader: (12)
 
Join Date: Sep 2007
Location: Charlotte, NC
Posts: 6,868
Total Cats: 66
Default

na or nb??
Doppelgänger is offline   Reply With Quote
Old 09-28-2007, 12:20 AM   #3
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Lexington, SC
Posts: 2,084
Total Cats: 0
Default

if it was on the chassis and u moved the ground to the dash structure it could not be as good, but i oon't know i hate electricity
mazda/nissan is offline   Reply With Quote
Old 09-28-2007, 12:45 AM   #4
Senior Member
iTrader: (3)
 
Join Date: Apr 2007
Location: Odenton, MD
Posts: 713
Total Cats: 0
Default

never move grounds...
Dow.tom is offline   Reply With Quote
Old 09-28-2007, 10:24 PM   #5
Junior Member
Thread Starter
 
Join Date: Nov 2005
Posts: 87
Total Cats: 0
Default

The ground was originally on the dash as well, just in a really stupid point to access so I moved it. I got the illumination working by bypassing the dimmer switch though.
tylerdurden is offline   Reply With Quote
Old 09-28-2007, 10:35 PM   #6
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

The dimmer switch varies the ground to working most likely when you moved the ground you disconnected it with the dimmer switch it is essential they all share the same ground.
magnamx-5 is offline   Reply With Quote
Old 10-11-2007, 08:40 PM   #7
Junior Member
Thread Starter
 
Join Date: Nov 2005
Posts: 87
Total Cats: 0
Default

Well, I did the jumpering and got the lights to work in the parking lights position of the switch but when I flip the headlights on the dash lights go out. Very odd and frustrating. Worse than the lights though is the fact that my hardtop defroster no longer works which compromises visibility at times.

So, before I go ahead and rip out the god-forsaken dash again which I'd really like to avoid as it's rather unpleasant (not to mention, why would moving the ground from one part of the dash structure to another matter), I was doing some research on the forum and one person said he had two clips that fit the dimmer switch and one worked for the lights and one didn't. Is this true? As I read the descriptions of how to jumper the dimmer switch connector the wire colors don't match what I'm looking at on mine and the connector has six wires whereas the dimmer switch itself only has three prongs. Would this indicate that the connector is for something else? Is it common to have "dummy" wires in the connector coming off the harness?

Sorry for the length, but I'd appreciate any help you guys might have as I'm totally dumb about electrical work.
tylerdurden is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:31 PM.