General Miata Chat A place to talk about anything Miata

No Power Please help

 
Old 03-05-2019, 02:51 PM
  #1  
Newb
Thread Starter
 
Join Date: Aug 2018
Posts: 9
Total Cats: 0
Default No Power Please help

Hey guys quick question! One of my co-workers put a new battery in my car while i wasnt there ended up put the terminals backwards and popped something. when you turn the ket no power anywhere, the fuel pump doesnt tunr on nothing. no lights on dash no radio its just dead. battery is perfect just saying. But i can turn the headlights on when the key is on the accesorsies position.. i already replaced the main relay in the engine bay but i need help! Also ECU is Megasquirt Plug and play 2 if that makes any difference
Conner Merchant is offline  
Old 03-05-2019, 03:02 PM
  #2  
Junior Member
 
Join Date: Dec 2012
Location: Charlotte, NC
Posts: 317
Total Cats: 25
Default

Big 80 amp main fuse intact?
Supe is offline  
Old 03-05-2019, 03:41 PM
  #3  
Newb
Thread Starter
 
Join Date: Aug 2018
Posts: 9
Total Cats: 0
Default

Could you possibly tell me where that fuse is?? Iíve looked for it but can never find it

car is a 1993 1.6l
Conner Merchant is offline  
Old 03-05-2019, 04:07 PM
  #4  
Junior Member
 
Join Date: Nov 2018
Posts: 52
Total Cats: -6
Default

Follow the red wireeeeee

Idk either sorry, or try google
Ramonn is offline  
Reply
Leave a poscat -1 Leave a negcat
Old 03-05-2019, 04:10 PM
  #5  
Junior Member
 
Join Date: Nov 2018
Posts: 52
Total Cats: -6
Default

Just read your post again... It can't be the main fuse if headlights still turn on, right?

Makes me feel bad, I wouldn't know where to start
Ramonn is offline  
Old 03-05-2019, 05:25 PM
  #6  
Junior Member
 
90LowNSlo's Avatar
 
Join Date: Mar 2018
Location: Calloway County Kentucky
Posts: 267
Total Cats: 11
Default

The NA6 has a main fuse (80a) under the hood by (I think) the relay box. It has two 10mm nuts holding it in. I couldn't find it searching but if you cant find it I can snap a picture when I get home.

EDIT - I was in the neighborhood. I stole this pic from another thread. The fuse is in the relay box it seems





The op in that thread was apparently having issues getting to the nuts...
90LowNSlo is offline  
Old 03-05-2019, 05:45 PM
  #7  
Senior Member
 
Join Date: May 2007
Location: Atlanta
Posts: 608
Total Cats: 92
Default

It's probably not the main fuse if the headlights still work. But still worth a look at all those underhood fuses.

If I recall, when you put the battery in backwards, megasquirt lets some magic smoke out to protect itself. Pull the case off, inspect for damage.
gooflophaze is offline  
Old 03-06-2019, 06:52 AM
  #8  
Junior Member
 
Join Date: Dec 2012
Location: Charlotte, NC
Posts: 317
Total Cats: 25
Default

Originally Posted by Ramonn View Post
Just read your post again... It can't be the main fuse if headlights still turn on, right?

Makes me feel bad, I wouldn't know where to start
Headlamps have their own 30 amp circuit. Not that your MS3 ISN'T damaged, but I don't think it would stop everything on the interior from powering on, which leads me to indicate the problem is further upstream. It's pretty common to blow a main fuse and fry an alternator when a battery is hooked up backwards.
Supe is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jvaz8367
General Miata Chat
1
07-07-2017 04:14 AM
ericsbestshot
DIY Turbo Discussion
30
07-01-2014 10:04 AM
Delboy
MSPNP
6
04-22-2011 03:47 PM
dgmorr
Race Prep
34
03-30-2011 11:09 AM
jbrown7815
General Miata Chat
4
12-13-2010 11:48 PM


Thread Tools
Search this Thread
Quick Reply: No Power Please help


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.