Oil pressure gauge not registering - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 08-12-2013, 05:01 PM   #1
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Nov 2007
Location: Saint Paul, MN
Posts: 1,296
Total Cats: 22
Default Oil pressure gauge not registering

Hey guys, I got an issue with my Oil Pressure Gauge. The gauge sits at 0psi and when I ground out the connector the gauge doesn't move. I swapped senders as a test and it's not working; is there any way to test the gauge itself? I'm thinking mine has gone bad..

I have a working 93 sender and gauge, not the fake 95+ hardware.
Der_Idiot is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Moroso Air Oil Separator Catch Can Aroundcorner Miata parts for sale/trade 2 10-01-2015 04:20 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:15 PM.