Slight Hesitation until about 3100rpms...? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 04-14-2008, 02:19 AM   #1
Newb
Thread Starter
 
Join Date: Jan 2008
Posts: 17
Total Cats: 0
Default Slight Hesitation until about 3100rpms...?

99 , 114k, All stock.

Replaced plugs and wires with NGK's / copper plugs.
Didnt change anything... What else is typical for this problem?
Swags04 is offline   Reply With Quote
Old 04-14-2008, 08:00 AM   #2
Junior Member
 
Join Date: Mar 2008
Location: Charleston, S.C.
Posts: 159
Total Cats: 0
Default

Fuel injectors??

My 1991 stock developed a feeling like it was dragging a safe until 3k-4k and then it felt like it had an extra cylinder as it flew. Ran some SL1 injector cleaner through the fuel system along with a long highway drive and it went away.
04 Miata is offline   Reply With Quote
Old 04-14-2008, 06:47 PM   #3
Newb
Thread Starter
 
Join Date: Jan 2008
Posts: 17
Total Cats: 0
Default

the problem goes away once the car is fully warm...

still think its the injectors?
Swags04 is offline   Reply With Quote
Old 04-14-2008, 06:50 PM   #4
Junior Member
 
Join Date: Mar 2008
Location: Charleston, S.C.
Posts: 159
Total Cats: 0
Default

Not sure about it going away when it's warm but a bottle of injector cleaner wouldn't hurt. I guess it could also be a O2 sensor acting up. With a 99 a coil is also always suspect but since it stops when warmed up and your not getting codes the coil is unlikely.
04 Miata is offline   Reply With Quote
Old 04-14-2008, 07:12 PM   #5
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,793
Total Cats: 247
Default

Maintenance. Pull the MAF sensor out and clean it with MAF sensor cleaner. Clean Throttle Body (TB) with TB cleaner. Remove intake manifold and clean it out (they get really dirty, so just do it). I'm assuming you put the correct plugs in and gapped them correctly. I think running premium fuel is a better injector cleaner than most products out there. (I also highly doubt that's where your problem is coming from). Can also clean your 02 sensor.
patsmx5 is offline   Reply With Quote
Old 04-14-2008, 07:23 PM   #6
Elite Member
iTrader: (14)
 
Join Date: Mar 2006
Location: Edmonton, AB
Posts: 4,921
Total Cats: 0
Default

Quote:
he problem goes away once the car is fully warm...
Let the car warm up before driving.

For the cost of one, I'd throw a new O2 sensor in the car. Does it smell like it is running REALLY rich when it is warming up?
jayc72 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Road Atlanta: November 21-22, 2015 Feffman Local Meets, Events and Tech Days 1 10-07-2015 09:06 AM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
In what world... curly MEGAsquirt 11 09-22-2015 12:54 PM
Mystery Engine Trouble. Halp, mt.net! vehicular General Miata Chat 12 09-14-2015 04:17 PM
VE values too low? compuw22c MEGAsquirt 4 09-12-2015 08:42 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:23 AM.