some more little problems - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 03-17-2008, 08:42 AM   #1
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Guam (U.S Terr.)
Posts: 786
Total Cats: -2
Default some more little problems

I have a few more questions on my 90 miata

1.How do i fix my gas gauge. i changed my gauge cluster and i thought that the gas gauge would set it self but turns out that NO it doesnt.

2.That battery light or the alternator light on the gauge cluster doenst go on when the ignition is on what does that mean? Well the car starts so the alternator must be working right?

keep in mind that this is the first car i ever built from the ground up so this whole thing is a learning process for me.
mike_671 is offline   Reply With Quote
Old 03-17-2008, 10:18 AM   #2
Elite Member
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

1. Fill up your tank and manually re-set the needle in the full position.
Saml01 is offline   Reply With Quote
Old 03-17-2008, 12:05 PM   #3
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,438
Total Cats: 84
Default

If the gauge is in the same position all the time, check the float in the tank and the connector at the tank.
olderguy is offline   Reply With Quote
Old 03-17-2008, 12:56 PM   #4
Elite Member
iTrader: (39)
 
Zabac's Avatar
 
Join Date: Sep 2007
Location: High Point NC
Posts: 4,854
Total Cats: 8
Default

your alternator has nothing to do with starting your car...if the light does not come on, you may need a new bulb, or you have to hunt down a bigger problem...
Zabac is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM
Annoying little leaks AlwaysBroken Engine Performance 5 09-06-2015 01:53 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:41 PM.