turbo squeeching sound? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 12-27-2008, 12:52 AM   #1
Junior Member
Thread Starter
 
Join Date: Jan 2008
Location: monterey park,ca
Posts: 67
Total Cats: 0
Default turbo squeeching sound?

i recently noticed a loud squeeching sound when the car start to take off from a stop. It doesn't happen when i was at higher speed but just taking off from a stop. My turbo seems to be boosting fine all the way to 5 psi. Maybe my 6 puck ebay clutch is going out, but sometimes when i just put it in neutral and free rev the car i can hear that sound also. Does that mean my turbo is on its way out? Anybody have experienced this? Any advice would be greatly appreciated. Thank you
skyline397 is offline   Reply With Quote
Old 12-27-2008, 01:10 AM   #2
Junior Member
iTrader: (1)
 
Join Date: Apr 2008
Location: Springfield Oregon
Posts: 174
Total Cats: 0
Default

Wow.......have you tried to tighten your accessory belt?
miatamoxie is offline   Reply With Quote
Old 12-27-2008, 01:47 AM   #3
Junior Member
Thread Starter
 
Join Date: Jan 2008
Location: monterey park,ca
Posts: 67
Total Cats: 0
Default

yes
skyline397 is offline   Reply With Quote
Old 12-27-2008, 02:06 AM   #4
Elite Member
iTrader: (5)
 
akaryrye's Avatar
 
Join Date: Jul 2006
Location: Central California
Posts: 2,526
Total Cats: 0
Default

damnit, this is the sort of crap that we have been talking about. A super dumb question, does not look like there was much searching done. A little searching on the forum and google could have ruled out some of the problems he thinks may be going on.
akaryrye is offline   Reply With Quote
Old 12-27-2008, 02:29 AM   #5
I'm Miserable!
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

turbo and clutch are both going out.

taking off is the clutch and reving in nuetral is the turbo. replace both, have a shop do it so its done right, then report back. and get a NEW turbo, not a used one.
bryantaylor is offline   Reply With Quote
Old 12-27-2008, 02:38 AM   #6
Elite Member
iTrader: (5)
 
akaryrye's Avatar
 
Join Date: Jul 2006
Location: Central California
Posts: 2,526
Total Cats: 0
Default

Pretty sure Brian is right
akaryrye is offline   Reply With Quote
Old 12-27-2008, 02:53 AM   #7
I'm Miserable!
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

also, a lot of the time a new turbo wont seal right on the old turbo mani because they basically "warp" together. i would start looking for a new turbo mani too.
bryantaylor is offline   Reply With Quote
Old 12-27-2008, 03:01 AM   #8
Senior Member
iTrader: (8)
 
turbobluemiata's Avatar
 
Join Date: Aug 2006
Location: Springfield, IL
Posts: 1,019
Total Cats: 0
Default

+1 on all that was said
turbobluemiata is offline   Reply With Quote
Old 12-27-2008, 03:28 AM   #9
Senior Member
iTrader: (2)
 
Join Date: Apr 2008
Location: Tallahassee, FL
Posts: 1,378
Total Cats: 0
Default

Prob also be a problem with low compression on cyl 4. I'd recommend a rebuild while the shop has the turbo off. New Apex seals are needed.
naarleven is offline   Reply With Quote
Old 12-27-2008, 04:14 AM   #10
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,192
Total Cats: 2,583
Default

happened to me too...its definitely your headlights
18psi is offline   Reply With Quote
Old 12-27-2008, 04:25 AM   #11
I'm Miserable!
iTrader: (16)
 
Join Date: Dec 2008
Location: where most people are Utarded
Posts: 1,323
Total Cats: 0
Default

Quote:
Originally Posted by 18psi View Post
happened to me too...its definitely your headlights
that dang low headlight fluid....
zoomin is offline   Reply With Quote
Old 12-27-2008, 05:49 AM   #12
Trackspeed Engineering
iTrader: (9)
 
Join Date: Jan 2008
Location: Bay Area, California
Posts: 937
Total Cats: 10
Default

I dono, last time this happened to me it was my muffler bearings.
crashnscar is offline   Reply With Quote
Old 12-27-2008, 09:17 AM   #13
Junior Member
iTrader: (2)
 
Join Date: Dec 2007
Location: Québec, Canada
Posts: 407
Total Cats: -1
Default

...
Dark Wanderer is offline   Reply With Quote
Old 12-27-2008, 10:33 AM   #14
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

I had the same problem with my kaneuter valve. I replaced it with 2 JDM versions overnighted from Japan. That and the motec exhausts made the car blow-off so loud that everyone looks at me now when I'm rolling around town. I think he should check out the Apex seals too and get roller rockers done while he's in there.
hustler is offline   Reply With Quote
Old 12-27-2008, 12:19 PM   #15
Senior Member
iTrader: (5)
 
Join Date: Dec 2007
Location: worcester ma
Posts: 1,124
Total Cats: 0
Default

Quote:
Originally Posted by hustler View Post
I had the same problem with my kaneuter valve. I replaced it with 2 JDM versions overnighted from Japan. That and the motec exhausts made the car blow-off so loud that everyone looks at me now when I'm rolling around town. I think he should check out the Apex seals too and get roller rockers done while he's in there.
you forgot to tell him to make sure his waste gate is shot peened
urgaynknowit is offline   Reply With Quote
Old 12-27-2008, 12:23 PM   #16
Senior Member
iTrader: (7)
 
nicacus's Avatar
 
Join Date: Jul 2006
Location: SLC UT
Posts: 1,133
Total Cats: 0
Default

It might be a unicorn in the muffler. They get in there and poke holes and ****.
nicacus is offline   Reply With Quote
Old 12-27-2008, 02:28 PM   #17
I'm Miserable!
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

Quote:
Originally Posted by nicacus View Post
It might be a unicorn in the muffler. They get in there and poke holes and ****.
i LOLed
bryantaylor is offline   Reply With Quote
Old 12-27-2008, 03:01 PM   #18
Elite Member
iTrader: (10)
 
rccote's Avatar
 
Join Date: Jan 2008
Location: Buffalo NY
Posts: 1,595
Total Cats: 17
Default

All of it.
rccote is offline   Reply With Quote
Old 12-27-2008, 04:58 PM   #19
Senior Member
iTrader: (4)
 
Join Date: Jan 2008
Location: Falls Church, VA
Posts: 1,367
Total Cats: 16
Default

Quote:
Originally Posted by nicacus View Post
It might be a unicorn in the muffler. They get in there and poke holes and ****.
Either that or Bub Rub sneaked a whistle tip in there while you weren't paying attention. You're supposed to be up cookin breakfast anyway, it's like an alarm clock, wooo woooo.
ScottFW is offline   Reply With Quote
Old 12-27-2008, 05:03 PM   #20
meatbag
iTrader: (50)
 
gospeed81's Avatar
 
Join Date: Nov 2008
Location: Houston, TX
Posts: 7,357
Total Cats: 26
Default

Quote:
Originally Posted by nicacus View Post
It might be a unicorn in the muffler. They get in there and poke holes and ****.
ok, now my wife thinks there is something really wrong with me
gospeed81 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 58 12-13-2017 10:04 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
ISO 1.6 turbo cast iron manifold cale saurage DIY Turbo Discussion 16 10-01-2015 12:25 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:17 AM.