Various miata pics, new suspension - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 02-24-2008, 06:03 PM   #1
I'm Miserable!
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Niagara Falls, On, CANADA
Posts: 979
Total Cats: 0
Default Various miata pics, new suspension

interior
Name:  006-4.jpg
Views: 1
Size:  136.7 KB
its the po-po
Name:  005-3.jpg
Views: 1
Size:  177.2 KB
its a bit sloppy, but almost done
Name:  004-2.jpg
Views: 1
Size:  187.7 KB
new gauges with the DDM radio surround panel, was a perfect fit
Name:  003-4.jpg
Views: 1
Size:  160.2 KB
car was getting dusty, sitting in garage to long, new suspension not a jacked 4x4 anymore, and lower when i sit in it
Name:  002-4.jpg
Views: 1
Size:  167.2 KB


car still isnt running, getting my buddies to come over tm. Put all the new suspension on, ahah wouldn't believe me i took off the back left shock and spring without taking the tire off because its still stuck there but i still got it done . Got volt and oil gauges hooked up, waiting for the temp sender because the lines are to cold dont want to crack the rubber. Talkin to neighbour said he might sell his miata because he has a motorcycle now

il take any kind of comments or advice lol
miataz is offline   Reply With Quote
Old 02-24-2008, 06:12 PM   #2
Hittin' Boost & Cones
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

boost guage on an NA motor???
240_to_miata is offline   Reply With Quote
Old 02-24-2008, 06:15 PM   #3
I'm Miserable!
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Niagara Falls, On, CANADA
Posts: 979
Total Cats: 0
Default

Yup, lol well i did have a turbo the cheap 1000 ebay one but i found out it was junk, so i sold it but still have the boost gauge, but i will be getting a turbo soon so i just leave it in there.
miataz is offline   Reply With Quote
Old 02-24-2008, 06:16 PM   #4
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Quote:
Originally Posted by 240_to_miata_OWNER View Post
Vacuum leak guage on an NA motor???
Corrected for accuracy.

My guess is he's planing to turbo it.
patsmx5 is offline   Reply With Quote
Old 02-24-2008, 06:18 PM   #5
Elite Member
iTrader: (5)
 
Join Date: Oct 2007
Location: Canton, Ga
Posts: 1,707
Total Cats: 19
Default

dont forget to connect the intake to the throttle body all the way.
Stealth97 is offline   Reply With Quote
Old 02-24-2008, 06:20 PM   #6
Senior Member
 
Join Date: Nov 2005
Location: Baltimore Maryland
Posts: 1,010
Total Cats: 8
Default

take the red interior neon out of the car....... and step away from the pep boy's.....
airbrush1 is offline   Reply With Quote
Old 02-24-2008, 06:33 PM   #7
I'm Miserable!
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Niagara Falls, On, CANADA
Posts: 979
Total Cats: 0
Default

Ya i seen that. I sort of like the red neon gives me light at night but is kinda ricey, what do you mean by pep boys?
miataz is offline   Reply With Quote
Old 02-24-2008, 06:40 PM   #8
Elite Member
 
Join Date: Jan 2005
Location: vancouver canada
Posts: 1,618
Total Cats: 0
Default

When are you gonna lower that 4X4 eh?
spike is offline   Reply With Quote
Old 02-24-2008, 06:43 PM   #9
I'm Miserable!
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Niagara Falls, On, CANADA
Posts: 979
Total Cats: 0
Default

Name:  002-4.jpg
Views: 1
Size:  167.2 KB

Name:  n677175592_212860_2605.jpg
Views: 1
Size:  53.6 KB

its a 1.25" drop, itl be maybe .5" with my fat *** in it
miataz is offline   Reply With Quote
Old 02-24-2008, 06:44 PM   #10
Senior Member
iTrader: (5)
 
Join Date: Dec 2007
Location: worcester ma
Posts: 1,124
Total Cats: 0
Default

put ur spark plug wires in a nice neat row, its bothering me lol

and from the picture it looks like the intake is not completely hooked up at the throttle body

ide change the wheels if it was me,, im more into smaller wheels, like say 15's
urgaynknowit is offline   Reply With Quote
Old 02-24-2008, 07:02 PM   #11
Elite Member
iTrader: (15)
 
Join Date: Sep 2007
Location: Incline Village, NV
Posts: 2,073
Total Cats: 5
Default

Still 4x4, IMO anything higher than 12.75 hub to fender is to high.

Im not a fan of:
The wheels
Seat covers
Shift boot
Rice Lights
E-break cover
And not haveing any vents for air, that would just suck.
thesnowboarder is offline   Reply With Quote
Old 02-24-2008, 07:26 PM   #12
I'm Miserable!
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Niagara Falls, On, CANADA
Posts: 979
Total Cats: 0
Default

Quote:
Originally Posted by urgaynknowit View Post
put ur spark plug wires in a nice neat row, its bothering me lol

and from the picture it looks like the intake is not completely hooked up at the throttle body

ide change the wheels if it was me,, im more into smaller wheels, like say 15's
cant put in row to long ahha, and yes i know the intake isnt hooked up i have to fix that, i was looking into 15s or 16s i have to sell these first i dont like them to heavy.
miataz is offline   Reply With Quote
Old 02-24-2008, 07:28 PM   #13
I'm Miserable!
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Niagara Falls, On, CANADA
Posts: 979
Total Cats: 0
Default

Quote:
Originally Posted by thesnowboarder View Post
Still 4x4, IMO anything higher than 12.75 hub to fender is to high.

Im not a fan of:
The wheels
Seat covers
Shift boot
Rice Lights
E-break cover
And not haveing any vents for air, that would just suck.
getting new wheels soon hopefully, seat covers are temporary until i get some money for new seats, bought red shift boot to lighten things up, lights mite go, e-brake cover i dont like how it fits or looks, but it came with the shift cover. And i got the two side vents for air ahah its a convertible
miataz is offline   Reply With Quote
Old 02-24-2008, 07:38 PM   #14
Senior Member
iTrader: (10)
 
Join Date: Feb 2007
Location: South Eastern Wisconsin
Posts: 1,282
Total Cats: 0
Default

Why did you put the breather on the chrome crossover thing? Just seems to make more sense to take that whole thing off and put it on the valve cover.
ApexOnYou is offline   Reply With Quote
Old 02-24-2008, 07:39 PM   #15
Elite Member
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

Why are you spark plugs paired as 13 and 24?
Saml01 is offline   Reply With Quote
Old 02-24-2008, 07:42 PM   #16
I'm Miserable!
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Niagara Falls, On, CANADA
Posts: 979
Total Cats: 0
Default

Quote:
Originally Posted by ApexOnYou View Post
Why did you put the breather on the chrome crossover thing? Just seems to make more sense to take that whole thing off and put it on the valve cover.
i like the chrome lol
miataz is offline   Reply With Quote
Old 02-24-2008, 07:43 PM   #17
I'm Miserable!
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Niagara Falls, On, CANADA
Posts: 979
Total Cats: 0
Default

Quote:
Originally Posted by Saml01 View Post
Why are you spark plugs paired as 13 and 24?
what are you talking about im clueless??
miataz is offline   Reply With Quote
Old 02-24-2008, 07:55 PM   #18
Senior Member
iTrader: (4)
 
Join Date: May 2007
Location: Ontario
Posts: 790
Total Cats: 0
Default

Why did you go with those gauges?

Narrowband is worthless.
Water temp and oil pressure you already have in the stock cluster.
Volt gauge? :\

Your upper radiator hose looks like it is going to blow off soon.
reddroptop is offline   Reply With Quote
Old 02-24-2008, 08:22 PM   #19
Senior Member
iTrader: (5)
 
Join Date: Dec 2007
Location: worcester ma
Posts: 1,124
Total Cats: 0
Default

Quote:
Originally Posted by thesnowboarder View Post
And not haveing any vents for air, that would just suck.
in all honesty, i blocked my vents out with gauges, and there no problem
the air flow still comes from the feet, and the top, and sides,
so its fine, i mostly use the feet and windshield anyway
urgaynknowit is offline   Reply With Quote
Old 02-24-2008, 08:30 PM   #20
Elite Member
iTrader: (6)
 
Loki047's Avatar
 
Join Date: Sep 2005
Location: Chicago
Posts: 4,145
Total Cats: 0
Default

nice pedals
Loki047 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need help - Stock Balancer and Fastforward overlay pulleys Frank_and_Beans Supercharger Discussion 13 09-12-2016 09:17 PM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
First Miata Rhidell Meet and Greet 1 09-27-2015 10:42 AM
Koni 1150 Coilover Kit drumman83 Suspension, Brakes, Drivetrain 2 09-25-2015 08:03 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:04 PM.