Pictures of your messed-up shit. - Page 3 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Insert BS here A place to discuss anything you want

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 11-04-2007, 03:36 PM   #41
Newb
iTrader: (1)
 
Join Date: Oct 2007
Posts: 28
Total Cats: 0
Default

Quote:
Originally Posted by paul View Post
thank god your roommate doesn't let you use the garage.
Holy... what he said..
WhiteNA6 is offline   Reply With Quote
Old 11-04-2007, 10:23 PM   #42
Junior Member
iTrader: (1)
 
Join Date: Mar 2007
Location: illinoisssss
Posts: 123
Total Cats: 0
Default

i used it, my car just happened to not be there at the time. luckily his insurance was nice enough to compensate for most of the mods that were on the car. we're now using a different garage, this time with non-ghetto wiring
marty_uiuc is offline   Reply With Quote
Old 11-04-2007, 11:48 PM   #43
Elite Member
iTrader: (11)
 
Trent's Avatar
 
Join Date: Feb 2006
Location: Louisiana
Posts: 1,625
Total Cats: 5
Default

Quote:
Originally Posted by bryantaylor View Post
i know you, im white94pgt on mx6.com
oh, cool. small world isn't it?
Trent is offline   Reply With Quote
Old 11-07-2007, 08:12 PM   #44
Elite Member
iTrader: (9)
 
TurboTim's Avatar
 
Join Date: Jun 2006
Location: Chesterfield, NJ
Posts: 6,485
Total Cats: 248
Default

Sorry for the fuzzy shots, the macro on my dad's camera is screwy. I'll post clearer pics soon.





Amazing what 15 miles will do.
TurboTim is offline   Reply With Quote
Old 11-07-2007, 08:18 PM   #45
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Poor turbo. Was your oil pressure too high or your oil drain too slow? Or was the "seal" just blown?
cjernigan is offline   Reply With Quote
Old 11-07-2007, 08:43 PM   #46
Elite Member
iTrader: (9)
 
TurboTim's Avatar
 
Join Date: Jun 2006
Location: Chesterfield, NJ
Posts: 6,485
Total Cats: 248
Default

Pics are supposed to show the large sharp chunks missing from the inside edge of the turbine blades. This area was *clean* and dry before the install. There is significant radial play in both ends of the shaft, about 1/4 inch. I believe some object attempted to go thru the turbine, chewed up the blades, F'ed up the bearings and the oil rings. If I plug the oil drain fitting with my finger and blow on the pressure hose, I can easily blow thru both ends of the turbo.
TurboTim is offline   Reply With Quote
Old 11-07-2007, 08:53 PM   #47
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Ohhh i see it now. There was soo much oil i couldn't really tell from glancing at it. Almost looks as bad that as mazdaspeed miata that detonated it's turbo into a bunch of pieces.
cjernigan is offline   Reply With Quote
Old 11-07-2007, 10:44 PM   #48
Supporting Vendor
Thread Starter
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,370
Total Cats: 1,332
Default

My buddy's old '02 WRX turbo. Forced Performance Evo3 16G. Our best guess is that extreme oil temps cooked the bearings and bent the shaft a tiny bit, and the rest is history. There was not a lot of shaft play, but the shaft was easily .100 out. It was messy.

Name:  nicksFPevo3-16G.jpg
Views: 1
Size:  16.0 KB
Savington is offline   Reply With Quote
Old 11-07-2007, 10:48 PM   #49
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Lexington, SC
Posts: 2,084
Total Cats: 0
Default

if this thread is still open in a few months, you all are likely to see my oil soaked post-turbo ka24e motor in this thread, if i finish the miata by then
mazda/nissan is offline   Reply With Quote
Old 11-07-2007, 11:31 PM   #50
Elite Member
iTrader: (21)
 
paul's Avatar
 
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2
Default

Quote:
Originally Posted by TurboTim View Post
Sorry for the fuzzy shots, the macro on my dad's camera is screwy. I'll post clearer pics soon.

Amazing what 15 miles will do.

what's amazing is that the mystery piece(s) of metal in question that damaged the turbo did no real damage to my motor after bouncing around in cylinders 3&4 for the initial 15 miles or the following 70 miles to Bruce's house to disassemble it all. some ping marks in the top of pistons 3&4 where it would have sandwiched it against the head where it's flat at the 2 sides. turns out i used a faulty compression gauge and when we got a good one of there the results were 179-185psi across all four cylinders when the motor was cold. we couldn't start it as no electronics or fluid lines were running to the motor.

paul is offline   Reply With Quote
Old 11-08-2007, 09:35 AM   #51
Elite Member
iTrader: (9)
 
TurboTim's Avatar
 
Join Date: Jun 2006
Location: Chesterfield, NJ
Posts: 6,485
Total Cats: 248
Default

Quote:
Originally Posted by paul View Post
...turns out i used a faulty compression gauge...
So the initial measurements of ~120 front two ~90 back two with the damaged cylinder head are inaccurate? Did you try the accurate gauge on the damaged head before removing it? Or the inaccurate gauge on the new cylinder head? (if the bad gauge says 120 across the engine with the new head then maybe the old head isn't as bad as it may be)

I'm afraid to ask, but what sort of chunck of metal are in the front side of your cat?
TurboTim is offline   Reply With Quote
Old 11-08-2007, 12:53 PM   #52
Senior Member
iTrader: (14)
 
brgracer's Avatar
 
Join Date: Nov 2004
Location: Ambler, PA
Posts: 1,275
Total Cats: 1
Default

Dead 1.6 diff split up front by the pinion ring.

Attached Thumbnails
Pictures of your messed-up shit.-dsc02096.jpg  
brgracer is offline   Reply With Quote
Old 11-08-2007, 01:23 PM   #53
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Lexington, SC
Posts: 2,084
Total Cats: 0
Default

no img brgracer, red X of doooom
mazda/nissan is offline   Reply With Quote
Old 11-08-2007, 01:35 PM   #54
Elite Member
iTrader: (24)
 
Join Date: Jul 2007
Location: Cypress, TX
Posts: 3,778
Total Cats: 35
Default

Quote:
no img brgracer, red X of doooom
I see a red square, green circle and blue triangle

Not exactly doooom, but no image. hehe
Bryce is offline   Reply With Quote
Old 11-08-2007, 02:56 PM   #55
Newb
 
Join Date: Nov 2007
Posts: 4
Total Cats: 0
Default

oh that poor diff, the things he must've gone through...
sulimanister is offline   Reply With Quote
Old 11-08-2007, 03:04 PM   #56
Junior Member
 
Join Date: Oct 2006
Location: Edmond, OK
Posts: 473
Total Cats: 0
Default



the restaurant i used to work at:




Rage_Kage is offline   Reply With Quote
Old 11-08-2007, 05:15 PM   #57
Elite Member
iTrader: (3)
 
Join Date: May 2006
Location: Houston, TX
Posts: 2,900
Total Cats: 0
Default

you ran into a building? stay the **** away from me dude.
Arkmage is offline   Reply With Quote
Old 11-08-2007, 05:38 PM   #58
Junior Member
 
Join Date: Oct 2006
Location: Edmond, OK
Posts: 473
Total Cats: 0
Default

no, the first is just an accident i had. the other one was someone pulled into a parking space and "hit the wrong pedal"
Rage_Kage is offline   Reply With Quote
Old 11-08-2007, 06:22 PM   #59
Elite Member
iTrader: (24)
 
Join Date: Jul 2007
Location: Cypress, TX
Posts: 3,778
Total Cats: 35
Default

^ LOL

Name:  DSC_0311.jpg
Views: 1
Size:  112.2 KB
I hate F-150s. That's the second one to back into my car.
Bryce is offline   Reply With Quote
Old 11-08-2007, 07:31 PM   #60
Senior Member
iTrader: (10)
 
Join Date: Feb 2007
Location: South Eastern Wisconsin
Posts: 1,282
Total Cats: 0
Default

Torsen

As seen here

Attached Thumbnails
Pictures of your messed-up shit.-pic-0327.jpg  
ApexOnYou is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
15x10 - 15x11 6UL @ 949 Racing emilio700 Wheels and Tires 151 06-02-2017 03:36 PM
1991 special edition with hard top full part out JC, NJ russian Miata parts for sale/trade 6 10-08-2015 04:01 PM
Is my swirl pot design okay? FrankB Race Prep 10 10-02-2015 10:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:34 PM.