Video with 2 pulls from GT35R miata - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Media Got any pics or vids to share?

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 09-27-2008, 02:59 PM   #1
Ajb
Junior Member
Thread Starter
 
Join Date: Dec 2007
Location: United Kingdom
Posts: 103
Total Cats: 0
Default Video with 2 pulls from GT35R miata

Good video overall but at 7.08 there is 380whp miata which makes it even better.

http://videos.streetfire.net/video/R...TIs_187046.htm
Ajb is offline   Reply With Quote
Old 09-27-2008, 03:22 PM   #2
Elite Member
iTrader: (12)
 
Join Date: May 2007
Location: Austin, TX
Posts: 1,923
Total Cats: 0
Default

That miata looked pretty weak for having 380whp.
JayL is offline   Reply With Quote
Old 09-27-2008, 04:09 PM   #3
Elite Member
iTrader: (7)
 
samnavy's Avatar
 
Join Date: Apr 2006
Location: VIRGINIA BEACH, VA
Posts: 6,020
Total Cats: 175
Default

^Agreed... that much power and can't pull away from a bolt-on Camaro?
samnavy is offline   Reply With Quote
Old 09-27-2008, 04:17 PM   #4
Elite Member
iTrader: (12)
 
Join Date: May 2007
Location: Austin, TX
Posts: 1,923
Total Cats: 0
Default

Maybe he meant to say the 380 was GJHP.
JayL is offline   Reply With Quote
Old 09-27-2008, 05:40 PM   #5
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,165
Total Cats: 2,573
Default

maybe he had traction problems the first run
18psi is offline   Reply With Quote
Old 09-27-2008, 09:00 PM   #6
Senior Member
iTrader: (2)
 
Join Date: Jun 2007
Location: Shalimar, FL
Posts: 965
Total Cats: 7
Default

I think the coolest car out of all of those was the built up Z31. You don't see a lot of those running around.
messiahx is offline   Reply With Quote
Old 09-27-2008, 10:58 PM   #7
I'm Miserable!
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

i highly doubt that miata had 380 wheel.
bryantaylor is offline   Reply With Quote
Old 09-28-2008, 12:57 PM   #8
Senior Member
iTrader: (10)
 
Join Date: Nov 2006
Location: Raleigh,NC
Posts: 912
Total Cats: 0
Default

Driver can't shift?
supra441979 is offline   Reply With Quote
Old 09-28-2008, 06:15 PM   #9
Senior Member
iTrader: (4)
 
Join Date: Oct 2006
Location: Tampa
Posts: 780
Total Cats: 0
Default

I am digging the old school 85-87 300Z in the beginning of the vid. I had an 86 and they were pretty quick.
96rdstr is offline   Reply With Quote
Old 10-02-2008, 09:46 AM   #10
Junior Member
iTrader: (3)
 
Join Date: Sep 2005
Location: las vegas
Posts: 203
Total Cats: 0
Default

yeah but it had a supra motor 2jzge non turbo then turbo'ed
blue turbo mx5 is offline   Reply With Quote
Old 10-03-2008, 10:54 PM   #11
Junior Member
iTrader: (7)
 
Join Date: Apr 2007
Location: South of Houston, Texas
Posts: 329
Total Cats: 0
Default

I would pwn him
mikef85 is offline   Reply With Quote
Old 10-04-2008, 03:36 PM   #12
Elite Member
iTrader: (24)
 
kotomile's Avatar
 
Join Date: Oct 2006
Location: Monterey, CA
Posts: 7,578
Total Cats: 40
Default

Quote:
Originally Posted by samnavy View Post
^Agreed... that much power and can't pull away from a bolt-on Camaro?
Looked to me like he put at least a length on him, also remember the Camaro was bolt-ons and 150 shot..

Great editing, anyone who syncs up a car trying to rip itself free of a dyno with Static-X is a friend of mine.
kotomile is offline   Reply With Quote
Old 10-04-2008, 09:34 PM   #13
Senior Member
iTrader: (10)
 
Join Date: Oct 2005
Posts: 718
Total Cats: 5
Default

I think the Miata had a poor proformance. Didnt look like 380 whp to me.

The old Zwas bad ***..
TURNS101 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
VR6 to Miata Swap ScrapinMX5 Meet and Greet 8 09-28-2015 02:04 PM
Another Alternator thread ihiryu General Miata Chat 9 09-28-2015 11:22 AM
Koni 1150 Coilover Kit drumman83 Suspension, Brakes, Drivetrain 2 09-25-2015 08:03 PM
starting issue Johnny Tater Engine Performance 3 09-23-2015 07:10 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:34 AM.