Hello, been around, now saying "HI" ..sorry. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Meet and Greet Say Hi. De-noob yourself.

Reply
 
 
 
LinkBack Thread Tools
Old 08-09-2011, 07:16 AM   #1
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2010
Location: Originally from Germany. Now live in SoCal
Posts: 196
Total Cats: -5
Default Hello, been around, now saying "HI" ..sorry.

Hey, everyone. Ive been actively rummaging through the forums to try and get some info and forced induction set ups and the pros and cons of owning such set ups. Also to source some nice pieces in the for sale section. Sorry it took me so long to say "HI" to all you guys but i felt like i shouldn't until i had a turbo hahah.

I stole my 1992 1.6l miata in summer 2010 with 101k original miles for $1800. I got it off a guy from San Diego that seemed to rarely drive the car (7 year old Kumho Ecsta 280TW tires with 40% tread left). The car ran good and had no electrical issues of any kind. It is the model with a viscous dif and power windows and abs and what not.

Since then i have done lots of work on the car (seems like a lot to me) radiator, timing belt, water pump, crank seal, Bilstein GC 550/350, FCM Tophats and bumpstops, 15x8 6ul's with Donlup Z1 Star specs.
This work was done either to prevent any failures or simply to improve the car not because they broke. The only thing that kept giving me problems was a low rpm range Bog that wouldnt go away. Changed the O2 sensor, nothing. Checked the cat, nothing. Cleaned the AFM, broke it, fixed it, nothing. Changed the intake to a cone filter and the bog slightly improved. Changed the stock header for a used riceland header and the bog disappeared YAY!! turns out that the OEM header was cracked/leaking before the O2 sensor. NOW, the raceland header doesnt have a heatshield and neither does my DIY intake *facepalm* After a few weeks i decied to drop the stock airbox back into place only to find that the bottum/side of the cone filter had holes scortched into it...i wrapped my header and dropped the airbox back in and ever since i get an occasional Check engine light. Usually i get it after driving for 10-15 miles but sometimes i get it withing 5 min of star up. Other than that the car runs great. (Able to keep up with a 370z on downhill canyon runs)

I recently went to Fontana AutoClub Speedway to see what my car would do in a 1/4 mile. First time on a Drag strip in my life (im 19).

1st run 18.2 with a passenger
2nd run 19.4 with wheel spin, missed 3rd gear, no passenger
3rd run 18.5 Boged off the line, no passenger
4th run 17.9 decent launch, no passenger

I want a turbo now hahah Thats my story.

Oh and im also really into photography. I just got a Cannon T2i so im very new to the SLR group but still, hit me up if you want me to shoot your car!! All i want is a ride in it haha

Here are some pics of my car(Brothers 350z, Friends E36 M3). THANKS!!!! and HELLO AGAIN!!

With Iphone


With T2i (Dirty car, just ran the canyon)


With T2i


With Iphone
Attached Thumbnails
Hello, been around, now saying "HI" ..sorry.-dariusiphone034.jpg   Hello, been around, now saying "HI" ..sorry.-dpp_0016.jpg   Hello, been around, now saying "HI" ..sorry.-dpp_0013-1.jpg   Hello, been around, now saying "HI" ..sorry.-dpp_0035.jpg  
MR.M!474 is offline   Reply With Quote
Old 08-10-2011, 12:58 AM   #2
"Quality" is my first name.
iTrader: (3)
 
Quality Control Bot's Avatar
 
Join Date: Dec 2007
Posts: 2,611
Total Cats: 69
Default

Welcome to the site MR.M!474

Check out my signature for some help on navigating the site.

Enjoy the stay!
Quality Control Bot is offline   Reply With Quote
Old 08-10-2011, 01:14 AM   #3
Elite Member
iTrader: (1)
 
Join Date: Dec 2010
Location: SoCal
Posts: 4,165
Total Cats: 19
Default

Quote:
Originally Posted by Rick View Post
Welcome to the site MR.M!474

Check out my signature for some help on navigating the site.

Enjoy the stay!
Maybe your changing your sig, but it is not visible to me right now, although I think it was earlier in the day.
gearhead_318 is offline   Reply With Quote
Old 08-10-2011, 01:41 AM   #4
"Quality" is my first name.
iTrader: (3)
 
Quality Control Bot's Avatar
 
Join Date: Dec 2007
Posts: 2,611
Total Cats: 69
Default

I was trying to be sneaky
Quality Control Bot is offline   Reply With Quote
Old 08-10-2011, 02:52 AM   #5
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2010
Location: Originally from Germany. Now live in SoCal
Posts: 196
Total Cats: -5
Default

Quote:
Originally Posted by Rick View Post
Welcome to the site MR.M!474

Check out my signature for some help on navigating the site.

Enjoy the stay!
Thank you!

I edited my signature and saved it but it doesn't appear to be showing up...does it take a while to show up?
MR.M!474 is offline   Reply With Quote
Old 08-10-2011, 02:54 AM   #6
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2010
Location: Originally from Germany. Now live in SoCal
Posts: 196
Total Cats: -5
Default

OH!! there it is. Only new posts show updated signature?
MR.M!474 is offline   Reply With Quote
 
 
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:32 PM.