96 w/ megasquirt - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 01-31-2006, 09:22 AM   #1
Senior Member
Thread Starter
iTrader: (7)
 
Join Date: Mar 2005
Location: VT
Posts: 939
Total Cats: 0
Default 96 w/ megasquirt

Plan:
MSnS-E, MS I v. 3.0
Parallel install (including FP operation)
Stock ECU for A/C and AIC, blah, blah, blah...
OBDII return codes (required in my state) [Thought about trying maf will be electrically connected and zip tied in the engine compartment, but out of the intake tract)

There is a ton of info on the msefi board and it is overwhelming to try and sort through what is needed for a paticular vehicle. There has been so many 'updates' that you can read for hours on a 'fix' only to discover its been 'fixed' in the software....There is also hardware, software and firmware, and then versions of each....

Luckily the miata trail has all ready been blazed @ least 90-95 non OBD II ones...

I started with the MS I 3.0 complete kit ~$190.00.
Discovered 'complete kit' doesn't include a $5.00 cable (took a second order)

There is also two GM sensors required CLT and AIT, both can be purchased together for ~40.00 on line. Since I have some time I'm going to try and use the factory CLT as Al did, just need to calculate the bias resistance @ 27 C. I will need the AIT because its in the MAF and the goal is to eliminate that POS

Not sure if I'll need the stimulator or not, I'll probably just check for V and resistance...

The assembly instructions are very procedural and methodical. They are that way for a reason, but next time I'm going to just to solder the resistors first, diodes , caps, and then the chips--basically start w/ the low lying pieces first, MS starts with the high stuff first. If you've ever done any assembly work you'll know what I mean. (but I need to build one 1st to see what is needed and not needed)

Because of time restraints(Kids) I'm only up to step 25. Each step has to be followed, so you can modify the board for your application.
Jefe is offline   Reply With Quote
Old 01-31-2006, 02:04 PM   #2
Senior Member
 
Join Date: Oct 2005
Location: Knoxville
Posts: 1,168
Total Cats: 0
Default

Cool, another one joins the fray. Have fun building it! I imagine it would be more satisfying that way, but I hate delicate work like soldering. And I'm lazy.
Al Hounos is offline   Reply With Quote
Old 01-31-2006, 02:14 PM   #3
Senior Member
 
Join Date: Oct 2005
Location: Knoxville
Posts: 1,168
Total Cats: 0
Default

oh yeah and you may want to keep these instructions in mind when you are building.

http://www.diyautotune.com/tech_arti...alon_laser.htm
Al Hounos is offline   Reply With Quote
Old 01-31-2006, 02:28 PM   #4
Senior Member
Thread Starter
iTrader: (7)
 
Join Date: Mar 2005
Location: VT
Posts: 939
Total Cats: 0
Default

Thanks, I have it bookmarked
Jefe is offline   Reply With Quote
Old 01-31-2006, 02:30 PM   #5
Senior Member
Thread Starter
iTrader: (7)
 
Join Date: Mar 2005
Location: VT
Posts: 939
Total Cats: 0
Default

Quote:
Originally Posted by Al Hounos
Cool, another one joins the fray. Have fun building it! I imagine it would be more satisfying that way, but I hate delicate work like soldering. And I'm lazy.
Can't drive the car for a few more months anyway....
Jefe is offline   Reply With Quote
Old 02-03-2006, 09:10 AM   #6
Senior Member
Thread Starter
iTrader: (7)
 
Join Date: Mar 2005
Location: VT
Posts: 939
Total Cats: 0
Default

Note to self:
R4 - AIT Sensor
R7 - Coolant Sensor
Jefe is offline   Reply With Quote
Old 02-04-2006, 08:28 AM   #7
Senior Member
Thread Starter
iTrader: (7)
 
Join Date: Mar 2005
Location: VT
Posts: 939
Total Cats: 0
Default

For 96-97 only! Pinouts Stock ECU to MS, may be changes in the works.
Attached Files
File Type: doc 96pinout.doc (36.5 KB, 141 views)
Jefe is offline   Reply With Quote
Old 02-21-2006, 03:07 PM   #8
Senior Member
Thread Starter
iTrader: (7)
 
Join Date: Mar 2005
Location: VT
Posts: 939
Total Cats: 0
Default

Project on hold until I get my WBO2 fixed...RRRRRRRRRRRR
Jefe is offline   Reply With Quote
Old 03-03-2006, 02:21 PM   #9
Junior Member
 
Join Date: Nov 2005
Location: Quebec, Canada
Posts: 47
Total Cats: 0
Default

Iím doing the install on my í96 Miata tomorrow.
MS1 V3 with MSíníSpark.
Iíll let you know how everything goes.

Your pin schema was usefull. But I modified it a bit to make it easier to connect.

Thanks
MiataMath is offline   Reply With Quote
Old 03-07-2006, 11:09 PM   #10
Junior Member
 
Join Date: Nov 2005
Location: Quebec, Canada
Posts: 47
Total Cats: 0
Default

I have installed my MS in mine. But it's controlling nothing at the moment.

I have yet to install the GM coolant sensor has I had no luck in using the stock Miata one. Even using Easytherm and the data found on msefi.com for the Mazda coolant sensor.

As soon as the sensor is installed, I'll take control of the injector and see how well this ECU is behaving.

But as far as the rest of the reading goes.. everything seems fine: rpm. o2. tps (I have a 96 so TPS is a 0-5v one, unlike 1.6L) IAT (using GM sensor wrapped to air filter), MAP.. etc.
Attached Thumbnails
96 w/ megasquirt-megasquirt-after.jpg  
MiataMath is offline   Reply With Quote
Old 03-08-2006, 03:48 PM   #11
Senior Member
 
Join Date: Oct 2005
Location: Knoxville
Posts: 1,168
Total Cats: 0
Default

^ So start your own thread. Join the club.

Last edited by Al Hounos; 03-10-2006 at 11:17 PM.
Al Hounos is offline   Reply With Quote
Old 03-10-2006, 11:16 PM   #12
Senior Member
 
Join Date: Oct 2005
Location: Knoxville
Posts: 1,168
Total Cats: 0
Default

Yo jefe have you hooked yers up yet? Because your pinout has some typos... o2 and outer cas both say pin 24. o2 goes to pin 23. and the inner cas goes to pin 25 if you are using the IAC1A like the DSM instructions say.
Al Hounos is offline   Reply With Quote
Old 03-20-2006, 10:21 PM   #13
Senior Member
Thread Starter
iTrader: (7)
 
Join Date: Mar 2005
Location: VT
Posts: 939
Total Cats: 0
Default

Al,
Thanks!!! I updated it to reflect, I kinda feel bad about starting it but then it ended up complete, just sitting on the work bench. (Damn WBO2)

Good news, while away on vacation my WBO2 returned all fixed, N/C and it was past the warrantee period! Thanks ZT-2!!!

I'll attempt to wire it in this week or next, I'm kind of waiting for the snow to leave...

Miatamath-
"Your pin schema was usefull. But I modified it a bit to make it easier to connect."

What else needs to changed?
Attached Files
File Type: doc 96pinout.doc (36.5 KB, 105 views)
Jefe is offline   Reply With Quote
Old 03-20-2006, 10:32 PM   #14
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,438
Total Cats: 84
Default

Quote:
Originally Posted by Jefe
Project on hold until I get my WBO2 fixed...RRRRRRRRRRRR
What was wrong with it???
olderguy is offline   Reply With Quote
Old 03-20-2006, 11:13 PM   #15
Junior Member
 
Join Date: Nov 2005
Location: Quebec, Canada
Posts: 47
Total Cats: 0
Default

Hello Jefe,

Since you have an 96.. I'm pretty sure you could use my doc.

Here it is.

Take note that the actual V3 external wiring diagram is only for a guide and the pinout are not representative to miata Mod.
Attached Files
File Type: doc Mazda Miata 96 MS pinout.doc (214.5 KB, 112 views)
MiataMath is offline   Reply With Quote
Old 03-21-2006, 12:11 AM   #16
Senior Member
Thread Starter
iTrader: (7)
 
Join Date: Mar 2005
Location: VT
Posts: 939
Total Cats: 0
Default

Quote:
Originally Posted by olderguy
What was wrong with it???
Funny thing, one day it just stopped giving a reading on the lap top (I plugged it in to double check my boost) no reading- So I went through all the basics checked grounds, 12V.
I emailed Zeitronix and thay had me check a few pin readings w/ my DVM. still didn't see anything wrong. I pulled the entire harness and checked every wire for continouity(sp) everything was OK. I reported my finds via email and admitted to opening up the case of the ZT-2 (this is where I got the ESD lecture--anywho I explained I have a ground strap @ my work bench and ESD shoes) They wouldn'nt send me a schematic but asked for me to send everything to them. I sent it as requested. They returned it to me, w/o a letter of explaination or anything, I plugged it in and it worked(the harness connector I kept installed the car). I think they replaced the card, I should have marked my old one(as the case, o2 sensor and o2 harness were the same)
I think the 5V regulator went bad (7805) it is not heat sunk in the case, I have a bunch here and was tempted to just replace it but I was more curious how ZT-2 would handle the situation... Now that I think of it I may add a heat sink to this ZT-2 (I doubt they would re-extend a warrantee anyway).
(Also the 7805 they use may not be rated for -30 below)

I had already fine tuned my EM maps to +-5% for my Autotune (really I think it was just to compensate for temp at that point)
Jefe is offline   Reply With Quote
Old 03-26-2006, 08:38 PM   #17
Senior Member
Thread Starter
iTrader: (7)
 
Join Date: Mar 2005
Location: VT
Posts: 939
Total Cats: 0
Default

Squirted
Jefe is offline   Reply With Quote
Old 03-26-2006, 11:32 PM   #18
Junior Member
 
Join Date: Nov 2005
Location: Quebec, Canada
Posts: 47
Total Cats: 0
Default

Gratz!!! We want details
MiataMath is offline   Reply With Quote
Old 03-27-2006, 07:48 AM   #19
Senior Member
Thread Starter
iTrader: (7)
 
Join Date: Mar 2005
Location: VT
Posts: 939
Total Cats: 0
Default

Right know stocK CLT (w/ 2.2K ohm resistor @ R7) and GM AIT.
I was planning on spark today, ---to leave or remove the transistors Q6 & Q8???
Jefe is offline   Reply With Quote
Old 03-27-2006, 12:30 PM   #20
Senior Member
Thread Starter
iTrader: (7)
 
Join Date: Mar 2005
Location: VT
Posts: 939
Total Cats: 0
Default

The software setup that supports this isn't ideal. None of my screens look like yours or Aussies...I'd post a pic but I'm outa time for today....These versions are driving my crazy!!!
Jefe is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Any pnp megasquirt for 2001 Big_gumby WTB 0 09-30-2015 04:34 PM
1996 Turbo Build Goldwar DIY Turbo Discussion 2 09-29-2015 10:20 AM
First gen (white) megasquirt pnp 90-93 Miata firmware reflash Johnny Tater MSPNP 1 09-27-2015 01:38 AM
Megasquirt died mid operation psyber_0ptix MEGAsquirt 4 09-22-2015 10:35 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:44 AM.