How smooth is your idle? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 03-23-2008, 12:47 AM   #1
Elite Member
Thread Starter
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default How smooth is your idle?

Is your idle dead smooth or some what lumpy?

My car is doing this weird thing where it would "puff puff" every 10 seconds or so, and the idle gets rough. Then it clears up and its the same "puff puff". I hear this sound come out of the exhaust with the windows down. I dont know how to get it to be smoother.

I was thinking of tweaking the idle screw just a little bit, it seems to run a bit smoother if I keep my foot very lightly on the gas.

Your thoughts?
Saml01 is offline   Reply With Quote
Old 03-23-2008, 12:58 AM   #2
Elite Member
iTrader: (9)
 
TurboTim's Avatar
 
Join Date: Jun 2006
Location: Chesterfield, NJ
Posts: 6,485
Total Cats: 248
Default

What's your AFRs doing? Mine does this rarely when the closed loop fueling isn't correct...it'd get a little too lean and misfire...puffpuff.
TurboTim is offline   Reply With Quote
Old 03-23-2008, 12:59 AM   #3
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

What RPM are you idling at?
Cleaning your EGR and IAC might clear things up.

What Tim says goes as well. If i lean my VE table out by one point for idle it goes ape **** and makes an irregular misfire sound. Add that one point back in and it's golden.
cjernigan is offline   Reply With Quote
Old 03-23-2008, 01:01 AM   #4
Elite Member
Thread Starter
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

Quote:
Originally Posted by cjernigan View Post
What RPM are you idling at?
Cleaning your EGR and IAC might clear things up.

What Tim says goes as well. If i lean my VE table out by one point for idle it goes ape **** and makes an irregular misfire sound. Add that one point back in and it's golden.
800 - 850

How do I clean EGR? IAC I have an idea.

Quote:
Originally Posted by TurboTim View Post
What's your AFRs doing? Mine does this rarely when the closed loop fueling isn't correct...it'd get a little too lean and misfire...puffpuff.
13.1 idle. I guess ur right about the leaness part.

What do you mean if closed loop fueling is incorrect? You mean fueling at idle, if I understand correctly?
Saml01 is offline   Reply With Quote
Old 03-23-2008, 01:02 AM   #5
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Mine purs at 11:1. Don't know why, but it loves it. (plugs probably don't though)
patsmx5 is offline   Reply With Quote
Old 03-23-2008, 01:07 AM   #6
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

I idle 550s at 60 psi of fuel pressure at 13:1 just fine. You're not too lean by any means, especially not with hi-res code.
cjernigan is offline   Reply With Quote
Old 03-23-2008, 01:17 AM   #7
Elite Member
iTrader: (9)
 
TurboTim's Avatar
 
Join Date: Jun 2006
Location: Chesterfield, NJ
Posts: 6,485
Total Cats: 248
Default

Quote:
Originally Posted by Saml01 View Post
13.1 idle. I guess ur right about the leaness part.

What do you mean if closed loop fueling is incorrect? You mean fueling at idle, if I understand correctly?
With my AEM EMS i run closed loop fueling control at idle to maintain 15.5:1 AFR. The base map (if I turn off closed loop fueling) is around 13:1. Smooooth but smelly/dirty bumper and noticable difference in mileage. Closed loop fueling uses a feedback loop from the oxygen sensor to maintain a set AFR. I use it at idle mostly. Most others (Link, etc) use it during cruise.

If your setup is at 13.3 at idle then you should be fine. Maybe it's too rich? Are the plugs old/fouled? How old are the wires?

If my setup gets around 16.5:1 at idle it'll stumble and puffpuff a little. On a side note I can get around 16.8-17.1 on the highway before it misfires. I normally keep it around 16.1 though.

**I don't want to hear about NOx levels**
TurboTim is offline   Reply With Quote
Old 03-23-2008, 01:27 AM   #8
Elite Member
Thread Starter
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

^ Plugs, are new and im running COP's.

I think ill try richening it up and installing hi res code as well. See what happens after.
Saml01 is offline   Reply With Quote
Old 03-23-2008, 01:53 AM   #9
Senior Member
iTrader: (1)
 
Join Date: Sep 2007
Location: Trenton, NJ
Posts: 1,125
Total Cats: 0
Default

im having a problem with my idle too. but im already running HiRes. paul and i did the high hires mod today and did some tuning too, but the idling problem didnt go away. itll idle at about 15.1 afr. but it jumps/spikes to about 18.0 + afr all the time. im thinking it might be my plugs and wires? maybe a problem with my injectors? anyone have any insite to this?
ArtieParty is offline   Reply With Quote
Old 03-23-2008, 11:08 AM   #10
Senior Member
 
Join Date: Dec 2004
Location: Brisbane, Australia
Posts: 1,272
Total Cats: 32
Default

My idle is awesome, pretty much just like stock. Except when I have air con on, then it goes to **** and almost stalls when the compressor kicks in. It also stalls if you put the clutch in and let the engine revs drop without load.

Just takes more tuning of the IAC I guess.
timk is offline   Reply With Quote
Old 03-23-2008, 11:11 AM   #11
I'm Miserable!
iTrader: (1)
 
Join Date: Oct 2007
Location: Niagara Falls, On, CANADA
Posts: 979
Total Cats: 0
Default

When its cold it goes from 1000-2000rpm, and when its warm it idles around 1000-1200rpm, how do i get it lower, i adjusted the idle screw and thats as low as it will go, do i tune my ve fuel table?
miataz is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:58 PM.