IGN-1A Ignition coils, Diypnp '92 1.6 spark help - Miata Turbo Forum - Boost cars, acquire cats.

Go Back  Miata Turbo Forum - Boost cars, acquire cats. > Performance & Tuning > ECUs and Tuning > MEGAsquirt
Reload this Page >

IGN-1A Ignition coils, Diypnp '92 1.6 spark help

MEGAsquirt A place to collectively sort out this megasquirt gizmo
Sponsored by:
Sponsored by:

IGN-1A Ignition coils, Diypnp '92 1.6 spark help

Old 05-05-2014, 02:28 PM
  #1  
Newb
Thread Starter
 
Join Date: Mar 2009
Location: Birmingham,England
Posts: 43
Total Cats: 0
Default IGN-1A Ignition coils, Diypnp '92 1.6 spark help

I have just changed the coils on my 1.6 '92 mx5 from the stock one to 4 IGN-1A coils set up to run coil on plug. The original mx5 ignitor has been unplugged.

I have wired them up to use the IGN1, IGN2 WLED and ALED spark outputs. When cranking tunerstudio sees 1rpm and the rev counter doesn't move but i dont seem to get a spark.

Do i need to alter the tach input/output settings for the new coils? If so, could someone point me in the direction of what i need to alter?

Thanks
Mike
Attached Files
File Type: msq
IGN.msq (106.2 KB, 60 views)
File Type: msl
IGN.msl (39.5 KB, 36 views)

Last edited by Valentinik; 05-05-2014 at 03:15 PM.
Valentinik is offline  
Old 05-06-2014, 09:58 AM
  #2  
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,329
Total Cats: 62
Default

The first thing that jumped out at me is that you said it was a DIYPNP, but it's running regular MS2 firmware. Try reloading the firmware and be sure to select MicroSquirt Module and not MS2.
__________________
Matt Cramer
www.diyautotune.com
Matt Cramer is offline  
Old 05-06-2014, 10:01 AM
  #3  
Newb
Thread Starter
 
Join Date: Mar 2009
Location: Birmingham,England
Posts: 43
Total Cats: 0
Default

Matt. Thanks for that. I spotted that error last night. I now see about 200rpm while cranking. I got a huge backfire out of the exhaust which I presume was the unburnt fuel being ignited. So it seems its sparking but it was late so I'll try again tonight.

Thanks
Mike
Valentinik is offline  
Old 05-06-2014, 04:08 PM
  #4  
Newb
Thread Starter
 
Join Date: Mar 2009
Location: Birmingham,England
Posts: 43
Total Cats: 0
Default

just to update this further, i have used the spark test mode and i get spark from coil A - cylinder 1 and coil B - cylinder 3. I don’t get spark from C or D (Wled & Aled)

Could anyone confirm, all i needed to add was 2 100k resistors on aled and wled to 5v and that it should run with only the 1.6 cas?

I have all 4 outputs running through connecter 3. (3A, 3C 3E 3G)

I have attached 2 pictures of the board. Is there something i have missed?

Many Thanks
Mike
Attached Thumbnails IGN-1A Ignition coils, Diypnp '92 1.6 spark help-img_20140506_195108.jpg   IGN-1A Ignition coils, Diypnp '92 1.6 spark help-img_20140506_195128.jpg  
Valentinik is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Trent
WTB
2
10-01-2015 01:15 PM
The Gleas
MEGAsquirt
3
10-01-2015 10:30 AM
FrankB
Miata parts for sale/trade
6
09-30-2015 12:48 PM


Thread Tools
Search this Thread
Quick Reply: IGN-1A Ignition coils, Diypnp '92 1.6 spark help


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.