LC-1 with MS? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 02-04-2009, 10:19 PM   #1
Junior Member
Thread Starter
 
Join Date: Jan 2009
Location: Ashe County NC
Posts: 217
Total Cats: -1
Default LC-1 with MS?

Ok, question for everybody. Which analog output do I need to hook up to the megasquirt? There's the simulated narrowband signal, then the wideband... also, how do I tell which is pin 10 to hook it into? Thanks a lot!
adamhershner is offline   Reply With Quote
Old 02-04-2009, 10:24 PM   #2
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,793
Total Cats: 247
Default

Search a lot. Read the instructions that came with the LC-1. They will outline how to properly wire it up and calibrate its' outputs if needed. Also, welcome to the forum. Put your location in your profile, and put the year of your car and mods in your signature. See my sig. for an example. Also, check out the meet & greet section and start a thread there introducing yourself.
patsmx5 is offline   Reply With Quote
Old 02-04-2009, 10:49 PM   #3
Junior Member
iTrader: (2)
 
Join Date: Sep 2008
Location: Sandy, Utah
Posts: 175
Total Cats: 0
Default

http://www.innovatemotorsports.com/s...C-1_Manual.pdf

This is a link to the LC-1 manual. If you have the 7 wire version, the brown wire is the 0-5v WB signal.
Cpt_Slow is offline   Reply With Quote
Old 02-05-2009, 03:44 PM   #4
Senior Member
iTrader: (4)
 
Join Date: Jan 2008
Location: Falls Church, VA
Posts: 1,367
Total Cats: 16
Default

Quote:
Originally Posted by adamhershner View Post
Which analog output do I need to hook up to the megasquirt?
Neither output is configured for MS out of the box, so it doesn't much matter which one you use since reprogramming will be required either way. One of the outputs (2, brown wire) comes factory set for use with Innovate's gauge. Since I have the DB gauge, I just wired that up to output 2 and reprogrammed output 1 (yellow) for MS.

It cannot be mere coincidence that they made #1 yellow and #2 brown. Maybe they figured toilet lingo makes them easier to remember.
ScottFW is offline   Reply With Quote
Old 02-05-2009, 04:00 PM   #5
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Chicago (Over two miles from Wrigley Field. Fuck the Cubs. Fuck them in their smarmy goat-hole.)
Posts: 26,315
Total Cats: 1,913
Default

Actually, Scott, the brown #2 output is configured correctly for use with MS in out of the box. In MTConfig, the tenth selection under "LAMBDA_SENSOR" (in Car1 -> settings.ini) is "INNOVATE_LC1_DEFAULT 0-5v = 0.5-1.5 lambda", which is precisely what the brown wire puts out in the default configuration. Just connect the brown wire to the MS's WBO2 input, set this selection in MTConfig, and you will have the proper calibration.
Joe Perez is offline   Reply With Quote
Old 02-05-2009, 04:29 PM   #6
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by ScottFW View Post
It cannot be mere coincidence that they made #1 yellow and #2 brown. Maybe they figured toilet lingo makes them easier to remember.
I laughed about this when I read the instructions the first time. lol
hustler is offline   Reply With Quote
Old 02-05-2009, 04:44 PM   #7
Antisaint
iTrader: (17)
 
Vashthestampede's Avatar
 
Join Date: Feb 2007
Location: Danbury, CT
Posts: 4,659
Total Cats: 54
Default

Mmmmmmm....now I need to check my **** and ****. I cant recall if I did that right....lol.

Vash-
Vashthestampede is offline   Reply With Quote
Old 02-05-2009, 05:48 PM   #8
Junior Member
Thread Starter
 
Join Date: Jan 2009
Location: Ashe County NC
Posts: 217
Total Cats: -1
Default

Ok, thanks for all the help guys! I would go and get this done right now, but the car is at the muffler shop getting a 3 inch downpipe and full exhaust made
adamhershner is offline   Reply With Quote
Old 02-05-2009, 07:11 PM   #9
Senior Member
iTrader: (4)
 
Join Date: Jan 2008
Location: Falls Church, VA
Posts: 1,367
Total Cats: 16
Default

Quote:
Originally Posted by Joe Perez View Post
Actually, Scott, the brown #2 output is configured correctly for use with MS in out of the box. In MTConfig, the tenth selection under "LAMBDA_SENSOR" (in Car1 -> settings.ini) is "INNOVATE_LC1_DEFAULT 0-5v = 0.5-1.5 lambda", which is precisely what the brown wire puts out in the default configuration....
This is interesting, because what I recall reading at the time I set it up (June-ish, I forget) was that most people config'ed it for 0-5V = 10-20:1 AFR, which isn't the same as 0.5-1.5 lambda. It looks like if I switch them to 0.5-1.5 lambda I might be able to log more of the far rich or lean readings, between 7.x:1 and 10:1, and 20-23:1. Would switching MTconfig to the lambda option then force me to use an 8x8 lambda targets table in MT rather than leaving them expressed as AFRs (my brain comprehends AFRs better on the fly)?
ScottFW is offline   Reply With Quote
Old 02-05-2009, 10:35 PM   #10
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Chicago (Over two miles from Wrigley Field. Fuck the Cubs. Fuck them in their smarmy goat-hole.)
Posts: 26,315
Total Cats: 1,913
Default

Quote:
Originally Posted by ScottFW View Post
This is interesting, because what I recall reading at the time I set it up (June-ish, I forget) was that most people config'ed it for 0-5V = 10-20:1 AFR, which isn't the same as 0.5-1.5 lambda.
Yeah, you can change it to anything if you want, but out of the box it works just fine with MS's default LC-1 calibration.

Quote:
Would switching MTconfig to the lambda option then force me to use an 8x8 lambda targets table in MT rather than leaving them expressed as AFRs (my brain comprehends AFRs better on the fly)?
Of course not. The LC-1 just outputs an analog voltage. It doesn't matter if the LC1 setup software is describing it in terms of AFR, Lambda, or onša per shekel. It's just a voltage. The MS will capture that voltage, convert it into an ADC value, and then scale and display it in whatever units of measure please you. By default, MegaTune will display gasoline AFR on the dashboard gauge and in the AFR table when in LC-1 Default (0.5λ-1.5λ) mode.
Joe Perez is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
91 1.6l turbo complete part out. Tony the Tiger Miata parts for sale/trade 63 12-29-2016 03:23 AM
FS: JRSC w/ 62.5mm pulley, ITBs, MegaSquirt, LC-1 UrbanSoot Miata parts for sale/trade 20 09-12-2011 02:36 PM
Damaging an LC-1 sensor via heat? Savington MEGAsquirt 17 01-16-2008 06:24 PM
LC-1 question GTS Miata MEGAsquirt 6 09-30-2007 01:09 PM
LC-1 IN/OUT plugs KPLAFIN General Miata Chat 14 08-30-2007 12:29 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:40 AM.