Megatune isn't reading my wideband AFR correctly after hi res - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 09-01-2008, 07:44 PM   #1
Junior Member
Thread Starter
 
Join Date: Jan 2006
Location: Toronto
Posts: 182
Total Cats: 0
Default Megatune isn't reading my wideband AFR correctly after hi res

Before I went to hi-res (was running 29_ before) megatune showed the same AFR as my AEM gauge (it's an AEM linear). After upgrading to hi-res it's now reading ~ .3 AFR lower than the gauge. Anyone know why this might be?

Also, I looked into the equation in Megatune configurator and it looks funny:
AFR = 9.72 + egoADC * 0.038666

which is strange, according to AEM the end points are:
AFR 10.0 at 0V, AFR 19.98 at 5V

I thought the equation should be:
AFR = 10.0 + egoADC(V)*(1.996)

Is the equation in Megasquirt Configurator wrong???

Last edited by fluke; 09-01-2008 at 07:57 PM. Reason: I screwed up my math
fluke is offline   Reply With Quote
Old 09-01-2008, 07:46 PM   #2
Elite Member
iTrader: (21)
 
paul's Avatar
 
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2
Default

you might be on to something...

http://forums.plastikhosting.net/viewtopic.php?t=2221

of course the search feature might have yielded that as it's been discussed here a few times


9.48 seems to be the golden number for me
paul is offline   Reply With Quote
Old 09-01-2008, 08:04 PM   #3
Junior Member
Thread Starter
 
Join Date: Jan 2006
Location: Toronto
Posts: 182
Total Cats: 0
Default

I did search and couldn't find anything, thanks for your help!
fluke is offline   Reply With Quote
Old 09-01-2008, 08:43 PM   #4
Elite Member
iTrader: (21)
 
paul's Avatar
 
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2
Default

paul is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:48 PM.