MS1 random cut out while cruising - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 11-19-2013, 03:59 PM   #1
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: May 2011
Location: AL
Posts: 233
Total Cats: 10
Default MS1 random cut out while cruising

Afternoon folks, I've been having a bit of a problem that I believe is Megasquirt related. While cruising, it often has a misfire that jerks the car, which is incredibly annoying. It seems to be accompanied with a massive RPM spike and the wideband reads a lean spike, also. Here's the specs of the car:


'96 Miata
MS1 3.0 board
T25 running 8 PSI

I've wired in the .1uf capacitor, and think my CAS is good, but I've heard that the CAS can have interference with other high voltage wires? Also, either I'm paranoid or I notice it more often, but it seems to get worse when I have a passenger in the car (MS is behind the passenger seat) or when it rains.

The reason that I suspect it is the Megasquirt is because I've had these symptoms with two different engines.


I've attached a log file with a few of the events. The first time I hit the spacebar in the log I believe was a fluke, but the second two times were definitely misfires. The last one probably being the best representation.
Attached Files
File Type: xls MISFIRE.xls (615.9 KB, 42 views)
mellowout is offline   Reply With Quote
Old 11-19-2013, 04:09 PM   #2
Hittin' Boost & Cones
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

Subscribed. I have looked into this issue before with not real findings. It happens on highway cruise to me quite frequently. Does not happen on the stock ecu. I've played with plugs, coils , grounding , capacitor, etc with no luck. Finally just learned to live with it. I did buy another CAS to try next spring though.
240_to_miata is offline   Reply With Quote
Old 11-19-2013, 04:13 PM   #3
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: May 2011
Location: AL
Posts: 233
Total Cats: 10
Default

I think I know where you got that CAS.... lol

I'm pretty sure you got the one from my replacement motor, and I swapped my old one over, though.
mellowout is offline   Reply With Quote
Old 11-19-2013, 04:20 PM   #4
Hittin' Boost & Cones
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

Haha damn. So so did you try the CAS I have?
240_to_miata is offline   Reply With Quote
Old 11-19-2013, 04:23 PM   #5
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: May 2011
Location: AL
Posts: 233
Total Cats: 10
Default

Don't think so. I think I swapped it out because I thought it was bad (car wouldn't start), only to find out that I had another problem entirely. (I'm a dingus and had some wires backwards)
mellowout is offline   Reply With Quote
Old 11-21-2013, 06:34 PM   #6
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: May 2011
Location: AL
Posts: 233
Total Cats: 10
Default

bumping with cat pictures to please the miata gods

Attached Thumbnails
MS1 random cut out while cruising-657756269_w5nxt-l-1.jpg  
mellowout is offline   Reply With Quote
Old 11-28-2013, 09:28 PM   #7
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: May 2011
Location: AL
Posts: 233
Total Cats: 10
Default

Considering going to a crank trigger wheel setup. Looks like Joe Perez has used it to help get rid of his 'misfire' with good success.

https://www.miataturbo.net/megasquir...ss-last-20241/

I understand that I should need a trigger wheel : 2000 Mazda Protege Parts - Online Mazda Parts

and a crank angle sensor from an NB.


Still a bit unsure on what all is needed to take the cam angle sensor completely out of the equation, but still searching.
mellowout is offline   Reply With Quote
Old 12-10-2013, 12:57 PM   #8
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: May 2011
Location: AL
Posts: 233
Total Cats: 10
Default

240 are you using MS1? Would you mind posting your tune? Trying to find some common denominators
mellowout is offline   Reply With Quote
Old 12-10-2013, 04:12 PM   #9
Junior Member
iTrader: (1)
 
Join Date: Sep 2010
Location: Scranton PA
Posts: 266
Total Cats: 4
Default

You need to make another optoisolator circuit for the 2nd input on the cas. Info is in here:

https://www.miataturbo.net/megasquir...tor-ms2-71250/

I haven't had a single dropout in the past year since doing this mod.
duffbuster243 is offline   Reply With Quote
Old 12-10-2013, 04:33 PM   #10
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: May 2011
Location: AL
Posts: 233
Total Cats: 10
Default

Is this the diagram you used to wire yours?

https://www.miataturbo.net/attachmen...-dscf6117g-jpg

Also, with MS1, how would I know I'm getting sync loss?

Also, after looking at a few logs Ive noticed that the cut out is not always accompanied by an rpm spike or drop. Could this be sync loss?
mellowout is offline   Reply With Quote
Old 12-10-2013, 04:40 PM   #11
Junior Member
iTrader: (1)
 
Join Date: Sep 2010
Location: Scranton PA
Posts: 266
Total Cats: 4
Default

Quote:
Originally Posted by mellowout View Post
Is this the diagram you used to wire yours?

https://www.miataturbo.net/attachmen...-dscf6117g-jpg

Also, with MS1, how would I know I'm getting sync loss?

Also, after looking at a few logs Ive noticed that the cut out is not always accompanied by an rpm spike or drop. Could this be sync loss?
The diagram of the circuit I used is on page2 which I can't access for some reason. says something like prefetching is not allowed. Tried in another browser with no success.
duffbuster243 is offline   Reply With Quote
Old 12-10-2013, 04:43 PM   #12
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: May 2011
Location: AL
Posts: 233
Total Cats: 10
Default

This one?

MS2-Extra Miata 4g63 Manual

This would be different for a MS1 though, correct?
mellowout is offline   Reply With Quote
Old 12-10-2013, 04:56 PM   #13
Junior Member
iTrader: (1)
 
Join Date: Sep 2010
Location: Scranton PA
Posts: 266
Total Cats: 4
Default

Like this https://www.miataturbo.net/attachmen...dcas_input-gif But Pin 2 comes in from the IAC1A on the harness If you set your megasquirt up like 99% of the people on here. The output goes to JS10 on MS2 I Dont recall what pin it was on MS1 but its the pin the the .1uf capacitor goes to. EDIT: It appears to be JS8 on MS1.
duffbuster243 is offline   Reply With Quote
Old 12-10-2013, 05:37 PM   #14
Hittin' Boost & Cones
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

Quote:
Originally Posted by mellowout View Post
240 are you using MS1? Would you mind posting your tune? Trying to find some common denominators
Yeah MS1.
Ill try to remember to boot up my tuning laptop and grab the latest tonight.
240_to_miata is offline   Reply With Quote
Old 12-10-2013, 06:29 PM   #15
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: May 2011
Location: AL
Posts: 233
Total Cats: 10
Default

Quote:
Originally Posted by duffbuster243 View Post
Like this https://www.miataturbo.net/attachmen...dcas_input-gif But Pin 2 comes in from the IAC1A on the harness If you set your megasquirt up like 99% of the people on here. The output goes to JS10 on MS2 I Dont recall what pin it was on MS1 but its the pin the the .1uf capacitor goes to. EDIT: It appears to be JS8 on MS1.
I can understand most of that diagram, but the optoisolator part confuses me a bit (blue circle part) what are pins 1, 4, 2, and 5?
mellowout is offline   Reply With Quote
Old 12-10-2013, 06:44 PM   #16
Hittin' Boost & Cones
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

Proof I am a slacker...

https://www.miataturbo.net/megasquir...r-input-70794/

(I did actually try joes input at one point but the car didn't crank. I probably screwed up the circuit so I just said screw it and scrapped that idea)

I should build in the opto circuit this winter.
240_to_miata is offline   Reply With Quote
Old 12-10-2013, 06:53 PM   #17
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: May 2011
Location: AL
Posts: 233
Total Cats: 10
Default

Is this my answer?

Attached Thumbnails
MS1 random cut out while cruising-fairchild4n25_diagram.jpg  
mellowout is offline   Reply With Quote
Old 12-10-2013, 11:04 PM   #18
Junior Member
iTrader: (1)
 
Join Date: Sep 2010
Location: Scranton PA
Posts: 266
Total Cats: 4
Default

Quote:
Originally Posted by mellowout View Post
Is this my answer?

yea the 4n25 opto like This
duffbuster243 is offline   Reply With Quote
Old 12-10-2013, 11:26 PM   #19
Junior Member
 
Join Date: Dec 2012
Posts: 105
Total Cats: 8
Default

I, too, have the same issue.

MS1 v3 DIY built myself following the original thread.

I am getting dropouts around 3.5k RPM, so basically highway cruising.

I was able to follow the instructions pretty well to build the MS board as the picture tutorial was great. I tried to read the schematic but I am not 100% sure as I do not know symbols for everything. I used my mad MSPaint skills to add on to DIY's mod photo to show how I would solder in this 2nd opto circuit.

Can anyone confirm that this is correct?
Attached Thumbnails
MS1 random cut out while cruising-untitled.jpg  
kero is offline   Reply With Quote
Old 12-11-2013, 01:57 AM   #20
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: May 2011
Location: AL
Posts: 233
Total Cats: 10
Default

Quote:
Originally Posted by duffbuster243 View Post
yea the 4n25 opto like This
Gotcha. I ordered a few, and the other components you ordered in that thread from digikey.

Pro tip: apparently the dot on the top of the opto designates the #1 pin

Edit: kero that looks right to me, but my opinion is incredibly uninformed. Maybe someone with better knowledge than I can chime in

Last edited by mellowout; 12-11-2013 at 02:09 AM.
mellowout is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1991 special edition with hard top full part out JC, NJ russian Miata parts for sale/trade 6 10-08-2015 04:01 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 11:44 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:33 PM.