MS3BASIC output issues - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 12-26-2015, 05:56 PM   #1
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default MS3BASIC output issues

Hey guys,

I am having issues with my Datalog LED output.
The Output is @ INJ G , which comes out at the AC Fan output (pin 1a)

It is staying Solid no matter what. This used to work no problem, and I think it stopped working when I changed my INJ F output to VICS.

Here are my outputs:
Input- Water Low Level / Meth Failsafe*********MS3 Nitrousin- Pink- Pin 23 on DB37
input- datalog***********************************MS3 Datalog- AC Idle up input on stock harness
input- tableswitch*******************************MS3 Tableswitch- Grey- Pin 14 on DB37
output- boost************************************MS3 EBC Out- Dark Green- Pin 20 on DB37
Output- VICS************************************MS3 INJ F- AC Compresssor output on stock harness
Output- Meth Relay***************************** MS3 Nitrous 2- Orange- Pin 19 on DB37
Output- Meth Solenoid************************* MS3 FIdle- Blue- Pin 37 on DB37
Output- Warning LED**************************MS3 IAC1- Light Green- Pin 18 on DB37
Output- datalog LED **************************MS3 INJ G- AC Fan output on stock harness blu/grn pin1a

If I disconnect the output physically, the light goes off...so this is not a harness issue, its something within the megasquirt.

Any Ideas? Tune attached.
Attached Files
File Type: msq CurrentTune.msq (225.7 KB, 167 views)
240_to_miata is offline   Reply With Quote
Old 12-26-2015, 06:16 PM   #2
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,371
Total Cats: 1,332
Default

What did Dimitris say when you emailed him?
Savington is offline   Reply With Quote
Old 12-26-2015, 06:24 PM   #3
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

I haven't bugged him yet. I'll email him now.

Dimitris, FYI this is

MS3 Basic SN 12511
240_to_miata is offline   Reply With Quote
Old 12-26-2015, 06:35 PM   #4
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,441
Total Cats: 198
Default

InjF is connected internally to InjG with a diode, so that when InjF (A/C relay output) is triggered, the A/C fan output is also triggered.

In other words, if you disable VICS on InjF, you will get back the datalog LED on InjG.

Or you can remove diode D15, which is right behind the "FAN" 3-pin header.
Reverant is offline   Reply With Quote
Old 12-26-2015, 06:42 PM   #5
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

That was easy. I figured the two were together somehow due to it originally being setup for AC.

I will remove the diode tomorrow.

Thanks!
240_to_miata is offline   Reply With Quote
Old 12-27-2015, 03:27 PM   #6
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

Quote:
Originally Posted by Reverant View Post
InjF is connected internally to InjG with a diode, so that when InjF (A/C relay output) is triggered, the A/C fan output is also triggered.

In other words, if you disable VICS on InjF, you will get back the datalog LED on InjG.

Or you can remove diode D15, which is right behind the "FAN" 3-pin header.
I am blind and can't find d15. Can you point it out ??
240_to_miata is offline   Reply With Quote
Old 12-27-2015, 03:27 PM   #7
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,441
Total Cats: 198
Default

It's under the white MS3 daughterboard.
Reverant is offline   Reply With Quote
Old 12-27-2015, 03:41 PM   #8
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

Ok thanks. I'll remove the daughter board and try to carefully unsolder the diode. I'm a bit intimidated. It's Quite a nicer board than my ghetto old ms1 I hacked together.
240_to_miata is offline   Reply With Quote
Old 12-27-2015, 04:08 PM   #9
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

Done and done. Thank you again for your amazing customer support. I had an answer before I even walked out of the garage. Ms3 is back up and running with all I/o working great!
240_to_miata is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
GARAGE LIGHTING -- Output, EMF, etc 2manyhobyz Insert BS here 27 11-21-2016 09:58 PM
Can you split a wideband output? Grifbatenhorst ECUs and Tuning 2 12-12-2015 07:54 PM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 02:11 PM
Stock Radiator & Fans FS FastColt Miata parts for sale/trade 4 03-01-2010 11:27 PM
Issue with my stock 1.6 ECU and/or my TPS after removing Megasquirt clay ECUs and Tuning 2 07-17-2009 10:30 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:30 PM.