MEGAsquirt A place to collectively sort out this megasquirt gizmo
Sponsored by:
Sponsored by:

MS3PNP A/C Compressor inoperable

 
Old 08-21-2018, 09:27 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Apr 2018
Location: Charleston, SC
Posts: 113
Total Cats: 13
Default MS3PNP A/C Compressor inoperable

Just installed my new MS3PNP for my 1990 1.6. Everything seems to be working fine except the A/C. When I turn on the A/C it will kick the idle up and turn on the fan. It is not activating the compressor. If I splice the Output (L/B) wire with the Input (Lt G/B) wire the A/C compressor will come on and the MS kicks the idle up/turns fan on. A/C blowing cold, system is properly charged.

I know that the AC switch shoud have 0 volts when On because it is grounding the relay and 12 when Off cause the circuit is open. Used a test lamp to check for the MS system sending power to ground at the L/B output. Nothing. So I have two ideas of what's wrong, either the unit they made has an issue or my settings aren't right. Maybe it is just how it is supposed to be wired up for MS.

I'm fairly certain that it shouldn't operate like that. The idle is ok but it isn't properly controlling compressor delay meaning it will stall the car on some A/C initial operation. I called DIY and they werent really helpful. Explained everything and the guy didn't have much to say. If anyone can give me some info on why it
may possibly not be working it would be a big help. I'm attaching a screen shot of the current A/C idle settings in TS.




L337TurboZ is offline  
Old 08-21-2018, 09:46 PM
  #2  
Junior Member
 
Join Date: Mar 2015
Posts: 158
Total Cats: 14
Default

Oh look, something I can actually answer.

Inj J triggers the A/C compressor, Inj I triggers the condenser fan. You have to set the Idle-Up output to Inj J

This is how I'm triggering the condenser fan:


Note this is on an NA8 so may be different for you.
cpierr03 is offline  
Old 08-21-2018, 09:48 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Apr 2018
Location: Charleston, SC
Posts: 113
Total Cats: 13
Default

Awesome! I will change the settings in the morning and report back.
L337TurboZ is offline  
Old 08-23-2018, 05:50 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Apr 2018
Location: Charleston, SC
Posts: 113
Total Cats: 13
Default

Got everything squared away. Setting it to the correct output made a difference. Not sure if I had fat fingered it when using a touch screen or if that was how it was on the initial map they sent me
L337TurboZ is offline  
Old 08-23-2018, 06:03 PM
  #5  
Junior Member
 
Join Date: Mar 2015
Posts: 158
Total Cats: 14
Default

Mine was set incorrectly in my base map as well.

I spent an entire day troubleshooting every mechanical aspect of my A/C system before I starting pulsing outputs on Megasquirt to figure it out.
cpierr03 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
RobTracy
MEGAsquirt
2
11-01-2017 08:04 AM
Stranded
MEGAsquirt
13
10-25-2017 03:34 PM
Stranded
MEGAsquirt
0
10-21-2017 02:48 PM
Joe Perez
Prefabbed Turbo Kits
1
07-01-2006 11:26 PM


Thread Tools
Search this Thread
Quick Reply: MS3PNP A/C Compressor inoperable


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.