MSI Assembled Flashed & Tested - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 02-26-2007, 03:20 AM   #1
Elite Member
Thread Starter
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default MSI Assembled Flashed & Tested

Got my MS assembled, modded, usb adapted, and flashed with the new MSnSE firmware. Works good in megatune, everything but RPM but i'm aware there are a few things that can be changed to "maybe" get that to work. Anyway, getting closer and closer but man this was one hell of a learning curve putting all this together and whatnot. Not difficult, just time consuming, brain consuming and trialing. Let me tell you one thing though, if you have to have USB, take the easy route and get the external USB adapter. I'm happy with my "internal" one but the external piece is cheaper and supposedly works great.
Currently have it flashed with MSnSE 029 and running perfect in megatune.

Next step will be to build the harness/plug for it. Hopefully my switches come in tomorrow so i can wire it up for use with my stock ECU.
So i'm pretty stoked about what I have so far and what I have awaiting in my future. Hopefully i end up not having similar problems like that of Reverants.

Oh yeah, Thanks Adam for putting up with my questions along the way, helped out a bunch.

View of the Top w/ PWM idle mod.
Name:  06080001.jpg
Views: 0
Size:  111.7 KB
View of the Bottom w/ Miata Mods and USB socket mod.
Name:  06080006.jpg
Views: 0
Size:  93.8 KB
Assembled MS STIM (simulator)
Name:  06080005.jpg
Views: 0
Size:  63.0 KB
MSI and MS STIM pluged in for simulation
Name:  06080003.jpg
Views: 0
Size:  68.3 KB
End plate with hole cut for USB adapter.
Name:  06080008.jpg
Views: 0
Size:  67.3 KB

Last edited by cjernigan; 02-26-2007 at 05:25 AM. Reason: Add Pics
cjernigan is offline   Reply With Quote
Old 02-26-2007, 03:32 AM   #2
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

Sweet
magnamx-5 is offline   Reply With Quote
Old 02-26-2007, 05:27 AM   #3
Elite Member
Thread Starter
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Just in case. Does anyone see anything blatantly wrong with my board. I might have forgotten something even though it's working great in MSnSE Megatune simulation as it is right now. I'd hate to get it all together and find out i needed another jumper or something like that. I've doubled checked on my own already so it should be fine, never know.
cjernigan is offline   Reply With Quote
Old 02-26-2007, 11:31 AM   #4
Senior Member
iTrader: (2)
 
Join Date: Feb 2006
Location: Mesa, AZ
Posts: 999
Total Cats: 0
Default

looks good buddy, just had to make yours look better than mine didnt U!
adbradley is offline   Reply With Quote
Old 02-26-2007, 11:49 AM   #5
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,780
Total Cats: 1,106
Default

Well so far both you guys have better looking boards then mine. I will hopefully have mine up in a day or two.
shuiend is offline   Reply With Quote
Old 02-26-2007, 11:52 AM   #6
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

looks dont matter Adam function does i am sure yours will work better :gay: :P just kidding chad
magnamx-5 is offline   Reply With Quote
Old 02-26-2007, 11:54 AM   #7
Elite Member
iTrader: (5)
 
akaryrye's Avatar
 
Join Date: Jul 2006
Location: Central California
Posts: 2,526
Total Cats: 0
Default

Quote:
Originally Posted by shuiend View Post
Well so far both you guys have better looking boards then mine. I will hopefully have mine up in a day or two.
Makes sense, you are afterall doing your work in a ******* cave in Pakastan
akaryrye is offline   Reply With Quote
Old 02-26-2007, 12:17 PM   #8
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,780
Total Cats: 1,106
Default

Look I can make an LED Moonite hence I can surely make a Megasquirt.
shuiend is offline   Reply With Quote
Old 02-26-2007, 12:43 PM   #9
Senior Member
iTrader: (2)
 
Join Date: Feb 2006
Location: Mesa, AZ
Posts: 999
Total Cats: 0
Default

Quote:
Originally Posted by akaryrye View Post
Makes sense, you are afterall doing your work in a ******* cave in Pakastan
adbradley is offline   Reply With Quote
Old 02-26-2007, 12:59 PM   #10
Elite Member
Thread Starter
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Hahaha yeah if anyone can build a moonlite they can definitely build a MS for sure. If I can do it then most anyone should be able to.

You scrub your boards with alcohol yet Adam?
cjernigan is offline   Reply With Quote
Old 02-26-2007, 01:16 PM   #11
Senior Member
iTrader: (2)
 
Join Date: Feb 2006
Location: Mesa, AZ
Posts: 999
Total Cats: 0
Default

no was out of it last night, im gonna tonite.. i was freakin out when i send u those msn messages last night, but realized it was cus i was tryin to connect to my board that had ms1 firmware on it with the megatune configured to msns so now evetything is peechykeen
adbradley is offline   Reply With Quote
Old 02-26-2007, 01:21 PM   #12
Senior Member
 
Join Date: Oct 2005
Location: Knoxville
Posts: 1,168
Total Cats: 0
Default

looks good, but don't think you're done assembling. you'll pull that thing right back out and put in boost control as soon as you get it running.
Al Hounos is offline   Reply With Quote
Old 02-26-2007, 02:30 PM   #13
Elite Member
Thread Starter
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Quote:
Originally Posted by Al Hounos View Post
looks good, but don't think you're done assembling. you'll pull that thing right back out and put in boost control as soon as you get it running.
That's what i'm talking about. For the time being I have the Tullos to control boost though. Atleast I'll already have the GM solenoid in place for later.
cjernigan is offline   Reply With Quote
Old 02-26-2007, 02:32 PM   #14
Elite Member
Thread Starter
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Quote:
Originally Posted by adbradley View Post
no was out of it last night, im gonna tonite.. i was freakin out when i send u those msn messages last night, but realized it was cus i was tryin to connect to my board that had ms1 firmware on it with the megatune configured to msns so now evetything is peechykeen
I scrubbed mine down with isopropyl alcohol last night, the MS and Stim. I pulled the MS chip out before I did it just in case. The megamanual said scrub it all down and then rinse it in hot water, so I did just that and let it dry all night. Need to load up a .msq and get to tweaking it to my NB.
cjernigan is offline   Reply With Quote
Old 02-26-2007, 02:44 PM   #15
Senior Member
iTrader: (2)
 
Join Date: Feb 2006
Location: Mesa, AZ
Posts: 999
Total Cats: 0
Default

Quote:
Originally Posted by cjernigan View Post
I scrubbed mine down with isopropyl alcohol last night, the MS and Stim. I pulled the MS chip out before I did it just in case. The megamanual said scrub it all down and then rinse it in hot water, so I did just that and let it dry all night. Need to load up a .msq and get to tweaking it to my NB.
sweet
adbradley is offline   Reply With Quote
Old 02-26-2007, 02:45 PM   #16
Senior Member
iTrader: (2)
 
Join Date: Feb 2006
Location: Mesa, AZ
Posts: 999
Total Cats: 0
Default

Quote:
Originally Posted by Al Hounos View Post
looks good, but don't think you're done assembling. you'll pull that thing right back out and put in boost control as soon as you get it running.
do u have a good link that shows what mods need to be done for boost control?
adbradley is offline   Reply With Quote
Old 02-26-2007, 02:52 PM   #17
Elite Member
iTrader: (3)
 
Join Date: May 2006
Location: Houston, TX
Posts: 2,900
Total Cats: 0
Default

Quote:
Originally Posted by cjernigan View Post
Let me tell you one thing though, if you have to have USB, take the easy route and get the external USB adapter. I'm happy with my "internal" one but the external piece is cheaper and supposedly works great.
Could you give us a few more details on what made it so difficult? I'm currently using the external adapter but I put a socket on the board for the RS232 so I could add the internal once everything was tested (internal board is sitting in my tool box). I'd like to know what I can do to make the install less of a pain.
Arkmage is offline   Reply With Quote
Old 02-26-2007, 03:16 PM   #18
Elite Member
Thread Starter
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Quote:
Originally Posted by Arkmage View Post
Could you give us a few more details on what made it so difficult? I'm currently using the external adapter but I put a socket on the board for the RS232 so I could add the internal once everything was tested (internal board is sitting in my tool box). I'd like to know what I can do to make the install less of a pain.
Long as you socketed it then i see no problems because you can go back. I on the other hand had to cut the circuit board to get mine to work because i stupidly didn't go to radioshack and buy a damn socket. Anyway, when you cut that circuit you can't use the DB9 connector unless you rejumper it on the back side. Anyway, it's just stupid that you can't use both. If I was gonna do it again I would socket it just like you have and still use the USB adapter.

The actual wiring it up is easy though.
cjernigan is offline   Reply With Quote
Old 02-26-2007, 04:06 PM   #19
Junior Member
iTrader: (2)
 
Join Date: Nov 2005
Location: A2, MI
Posts: 475
Total Cats: 0
Default

Dhaark is offline   Reply With Quote
Old 02-26-2007, 04:19 PM   #20
Senior Member
iTrader: (2)
 
Join Date: Feb 2006
Location: Mesa, AZ
Posts: 999
Total Cats: 0
Default

Quote:
Originally Posted by Dhaark View Post
thanx
adbradley is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
In need of base map for stock 1997 brandonbkd MEGAsquirt 0 09-29-2015 12:52 AM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:03 AM.