Go Back  Miata Turbo Forum - Boost cars, acquire cats. > Performance & Tuning > ECUs and Tuning > MEGAsquirt
Reload this Page >

MSPNP - starting the car feels like someone kicking the starter

MEGAsquirt A place to collectively sort out this megasquirt gizmo
Sponsored by:
Sponsored by:

MSPNP - starting the car feels like someone kicking the starter

 
Old 12-04-2018, 02:59 AM
  #1  
Junior Member
Thread Starter
 
Join Date: May 2005
Location: Earth
Posts: 71
Total Cats: -5
Default MSPNP - starting the car feels like someone kicking the starter

Hey Iím running mspnp on my 2004 msm. When I start the car, it is a very harsh start. When the starter turns over, it makes a loud knock sound and takes my 4-5 turn over before the car starts.

Any idea why?

TIA!

Last edited by soospecmx5; 12-04-2018 at 04:12 PM. Reason: No replies
soospecmx5 is offline  
Old 12-06-2018, 07:29 AM
  #2  
Junior Member
 
Join Date: Dec 2010
Posts: 488
Total Cats: 10
Default

Check your Cranking Advance under Ignition Settings, Ignition Options/Wheel Decoder. Shouldn't be more than 6-8 degrees.
poormxdad is offline  
Old 12-07-2018, 12:49 PM
  #3  
Junior Member
 
Join Date: May 2011
Location: Miami
Posts: 183
Total Cats: 14
Default

Originally Posted by poormxdad View Post
Check your Cranking Advance under Ignition Settings, Ignition Options/Wheel Decoder. Shouldn't be more than 6-8 degrees.
There is conflicting information on that. I think Brain suggests 15 up to 18 degrees.
For what it is worth, I had a similar amount of bucking when I had it at around 4 to 7. I increased it to 15 and it cranked better.
andym is offline  
Old 12-07-2018, 01:42 PM
  #4  
Junior Member
 
Join Date: Dec 2010
Posts: 488
Total Cats: 10
Default

My starter would go whrrrrr, whrrrrr, whrrrrr, BANG... whrrrr, whrrrr, whrrrr, BANG a few times before she'd finally catch. I changed that value from 18 to 8 degrees and the problem disappeared.

BTW, you'll generally not get many answers here unless you post your tune and a log. Posting your tune might be helpful for this issue, and having your mods listed in your sig block is useful as well.
poormxdad is offline  
Old 12-07-2018, 01:56 PM
  #5  
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,763
Total Cats: 676
Default

I’ve messed around with this as well, I believe it has something to do with what your ignition values are at 100kpa and the lowest rpm cell. But I could be wrong. I’ve gone as low as -10 to keep it from backfiring.
curly is offline  
Old 12-11-2018, 09:00 PM
  #6  
Junior Member
Thread Starter
 
Join Date: May 2005
Location: Earth
Posts: 71
Total Cats: -5
Default

Thanks for the reply! My signature has been updated to see my supporting mods.

Attached is my ms file.

curly Please take a look at my file to see if everything is ok.

Another thing is that I can not get my wideband to see what megasquirt is seeing as air/fuel ratio.
Attached Files
File Type: msq
soo_spec_tune.msq (236.6 KB, 8 views)
soospecmx5 is offline  
Old 12-11-2018, 10:45 PM
  #7  
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,763
Total Cats: 676
Default

Looks fine. You're at 8 degrees cranking advance. Try 3, if that doesn't help, try -2. If you feel like 3 is better, -2 is worse, try 1 or 0. If none of these help, try 10 or 13.
curly is offline  
Old 12-14-2018, 10:59 PM
  #8  
Junior Member
Thread Starter
 
Join Date: May 2005
Location: Earth
Posts: 71
Total Cats: -5
Default

I compared my map with the base map provided.

The stock map had dwell set at 6 and my tuned map was set at 3.5, so I set it the same as the base map at 6 and advanced cranking is set at 15.

so far the crank feels a lot better, maybe 1 hard kick/buck then whirlllll then starts. No consistent kick/buck.

I also compared the cranking rpm. Base map is set at 400, my tune was at 225, I set it at 205. I played with this also as 400 still had the hard kick/buck start. At 205, it feels more smooth of a start.

Ill guess I’ll leave it at this.

Not sure if I’m doing the right thing but the start is much better.

Thanks everyone!



Last edited by soospecmx5; 12-17-2018 at 11:55 PM.
soospecmx5 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
irodd
MEGAsquirt
15
05-27-2017 09:41 PM
wkndracr
MEGAsquirt
5
03-10-2014 10:37 AM
speedf50
General Miata Chat
15
05-11-2008 12:38 AM
duhwun07
General Miata Chat
17
05-06-2008 06:05 PM


Thread Tools
Search this Thread
Quick Reply: MSPNP - starting the car feels like someone kicking the starter


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.