Rev built MS2 baro correction not working - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 08-13-2014, 07:30 PM   #1
Junior Member
Thread Starter
 
Join Date: Aug 2006
Location: Cedar City, UT
Posts: 228
Total Cats: 4
Default Rev built MS2 baro correction not working

I purchased this ECU and it had a single MAP sensor installed. I replaced the sensor with the dual mapdaddy sensor and ran the wire to JS5 which as far as was the only hardware modification I was required to make.

My understanding that the resistor that is mounted on the mapdaddy on some installs was not to be installed for the MS2+.

Right now I am running it with "initial MAP reading" which where I am located at 5600ft varies between 82-83 kPa and the car runs fine.

The problem is when I switch Baro Correction to "two independent sensors", it constantly reads outside air pressure at 100. I have tried changing upper limit, lower limit and default baro and there has been no changes whatsoever to what MS sees.

I know I fuxored some of the insulation of the surrounding wires, but I made sure to hit them with a dab of hot glue to make sure they would not short on anything, and they are completely free-floating.




Attached Thumbnails
Rev built MS2 baro correction not working-3.jpg   Rev built MS2 baro correction not working-1.jpg  
Dlaitini is offline   Reply With Quote
Old 08-13-2014, 10:59 PM   #2
Elite Member
 
Join Date: Oct 2013
Location: Cedar City, UT
Posts: 2,769
Total Cats: 948
Default

In for results as they affect me as well.
Jeffbucc is offline   Reply With Quote
Old 08-14-2014, 05:08 AM   #3
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

That's not going to work as both JS4 and JS5 are used internally. The expansion board inside the ECU (version 4.6+) has provision to solder a baro sensor on it.

The catch is that it must be a 1-bar sensor - the MPXH6115A6U.
Reverant is offline   Reply With Quote
Old 01-08-2015, 10:51 PM   #4
Junior Member
Thread Starter
 
Join Date: Aug 2006
Location: Cedar City, UT
Posts: 228
Total Cats: 4
Default

Alright, I just got one of those today.. will be contacting you shortly
Dlaitini is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Garrett Turbo, 1.8 Oil Pan, & Misc. Stuff nbdooey Miata parts for sale/trade 9 08-30-2017 10:50 PM
Need help - Stock Balancer and Fastforward overlay pulleys Frank_and_Beans Supercharger Discussion 13 09-12-2016 09:17 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Another Alternator thread ihiryu General Miata Chat 9 09-28-2015 11:22 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:36 AM.