Serious but random problem - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 11-22-2009, 01:31 AM   #1
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2006
Location: Springfield, NJ
Posts: 670
Total Cats: 0
Default Serious but random problem

Right now I'm incredibly frustrated with my car. There's an intermittent problem where it runs fine, then it runs incredibly bad.

When it goes bad, it happens suddenly, not gradually. The engine gets extremely rough, misfires galore, and the CEL blinks -- scary stuff!!!

When I had similar problems a year ago, it was a bad injector. But that time it wasn't intermittent -- it was constant.

Now, the car runs fine sometimes, and terrible other times. There's not even any warning that the problem is about to happen. It just happens. Sometimes it goes away just as quickly.

I assumed this was a symptom of my botched coil pack wiring. So, today I very carefully and very methodically re-wired the coil packs. Then I drove 45 minutes without and problems. I was so encouraged that tonight I decided to go datalog .... son of a bitch problem came back!!!!

Here's my datalog. It is quite obvious when/where the problem starts.
http://snarc.net/datalog200911220014.xls

What should I do??? I do not have another car to use so I'm really fucked until I can fix this.

BTW, I listened to all four injectors with a long screwdriver, and they sound normal.
evank is offline   Reply With Quote
Old 11-22-2009, 01:50 AM   #2
Elite Member
iTrader: (17)
 
Join Date: Apr 2009
Location: Atlanta, GA
Posts: 2,831
Total Cats: 0
Default

if its not your injectors. may be a problem with you ignition system, plug wires, coils, sparkplugs, ect ect! a good place to start trouble shooting!
WonTon is offline   Reply With Quote
Old 11-22-2009, 01:55 AM   #3
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2006
Location: Springfield, NJ
Posts: 670
Total Cats: 0
Default

The CEL is usually for random/multiple misfires, or misfires on cylinders 1/4. I have an extra coil pack so I swapped it for the 1/4 pack (2004 shares them.) No change -- problem still comes and goes.

But, I also had a non-blinking CEL for the same codes long before this new problem started. So it's very strange -- I have a blinking CEL when the problem happens, but there's no new code when I read them. WTF ?????

Meanwhile I ordered the Boundary/WeaponX COPS recently. They're supposedly shipping on Monday, which means they won't be here until Wednesday or Thursday at the soonest. And no offense meant to Boundary, but they're promised me once or twice already of shipping dates for this product that were missed.
evank is offline   Reply With Quote
Old 11-22-2009, 02:06 AM   #4
Elite Member
iTrader: (17)
 
Join Date: Apr 2009
Location: Atlanta, GA
Posts: 2,831
Total Cats: 0
Default

damn that sucks! i know there is a huge difference between honda and mazda. but a friend of mine had the same problem you were having and we couldn't figure it out for the longest time. turned out that one of his plug wire tubes was cracked and was grounding out somewhere causing his misfires and hesitations!
WonTon is offline   Reply With Quote
Old 11-22-2009, 08:10 PM   #5
y8s
2 Props,3 Dildos,& 1 Cat
iTrader: (8)
 
y8s's Avatar
 
Join Date: Jun 2005
Location: Fake Virginia
Posts: 19,038
Total Cats: 407
Default

pro tip: post a screen capture of the megalogviewer graph instead of the excel file... i'm too lazy to download some file and open it and analyze it myself.

could be a power or ground problem.
y8s is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
15x10 - 15x11 6UL @ 949 Racing emilio700 Wheels and Tires 151 06-02-2017 03:36 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:58 AM.