Toyota Cops MS Misfire problem - Miata Turbo Forum - Boost cars, acquire cats.

MEGAsquirt A place to collectively sort out this megasquirt gizmo

Toyota Cops MS Misfire problem

Old 07-01-2012, 11:00 AM
  #1  
Newb
Thread Starter
 
Join Date: Mar 2009
Location: Birmingham,England
Posts: 43
Total Cats: 0
Default Toyota Cops MS Misfire problem

Around 2 weeks ago i installed a set of toyota cops. They ran fine for around a week untill i touched the rev limiter one day.

After that point i've had a problem where under high load/in boost over 4500rpm i get a very bad misfire and backfire from the exhaust.

Flatshift/launch control is not enabled. This is a picture of the ignition settings im using:


Could it be a case of a bad cop, or is the a different ignition setting that may solve it?

Any ideas would be appreciated.
Mike
Valentinik is offline  
Old 07-01-2012, 12:12 PM
  #2  
Junior Member
 
Join Date: Sep 2010
Location: Denmark
Posts: 79
Total Cats: 1
Default

Eh, I don't see a picture.

- Tom
one-niner is offline  
Old 07-01-2012, 12:17 PM
  #3  
Newb
Thread Starter
 
Join Date: Mar 2009
Location: Birmingham,England
Posts: 43
Total Cats: 0
Default

I can see it fine?

here is a link to it anyway:
http://img.photobucket.com/albums/v2...c/ignition.jpg
Valentinik is offline  
Old 07-01-2012, 12:26 PM
  #4  
Junior Member
 
Join Date: Sep 2010
Location: Denmark
Posts: 79
Total Cats: 1
Default

Here's mine:



- Tom
Attached Thumbnails Toyota Cops MS Misfire problem-miozb.jpg  
one-niner is offline  
Old 07-01-2012, 01:05 PM
  #5  
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,535
Total Cats: 222
Default

Datalog please
__________________
Originally Posted by ninerwfo View Post
The “into to megasquirt thread” mentions that the MS3 basic has 5 inputs with built in pull up resistors - and I was just wondering why it would have so many, while the MS3Pro PnP has just 2 (with no pull ups?)
MS Labs: Plug and Play Megasquirt ECUs for ANY 90-05 Miata (NA, NB1, NB2 w/VVT, MSM), including basemaps to get you started ASAP. PM me or email or details.
For support on MS Labs ECUs: Please email, be sure to include the unit's serial number and include a datalog and your current map.
Reverant is offline  
Old 07-01-2012, 03:08 PM
  #6  
Newb
Thread Starter
 
Join Date: Mar 2009
Location: Birmingham,England
Posts: 43
Total Cats: 0
Default

Only a couple of short logs, but i the problem was pretty pronounced when i logged them.

Mike
Attached Files
File Type: msl
2012-07-01_18.59.42.msl (106.5 KB, 56 views)
File Type: msl
2012-07-01_18.57.31.msl (129.8 KB, 72 views)
Valentinik is offline  
Old 07-01-2012, 04:21 PM
  #7  
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,535
Total Cats: 222
Default

I'm only seeing a misfire in the first log, at partial throttle, while there is no misfire apparent during WOT?!?!
__________________
Originally Posted by ninerwfo View Post
The “into to megasquirt thread” mentions that the MS3 basic has 5 inputs with built in pull up resistors - and I was just wondering why it would have so many, while the MS3Pro PnP has just 2 (with no pull ups?)
MS Labs: Plug and Play Megasquirt ECUs for ANY 90-05 Miata (NA, NB1, NB2 w/VVT, MSM), including basemaps to get you started ASAP. PM me or email or details.
For support on MS Labs ECUs: Please email, be sure to include the unit's serial number and include a datalog and your current map.
Reverant is offline  
Old 07-01-2012, 04:27 PM
  #8  
Newb
Thread Starter
 
Join Date: Mar 2009
Location: Birmingham,England
Posts: 43
Total Cats: 0
Default

hmm, ok, il take another tomorrow. It seems to be during boost and i do get a slight misfire at very low revs in 5th gear.


Any indication of what it may be?

Thanks
Mike
Valentinik is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mx592
Suspension, Brakes, Drivetrain
1
10-01-2015 01:45 AM
FrankB
Miata parts for sale/trade
6
09-30-2015 12:48 PM
interestedofold
Suspension, Brakes, Drivetrain
5
09-29-2015 02:42 PM


Quick Reply: Toyota Cops MS Misfire problem


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.