Cold start idle drops right away for a second - Miata Turbo Forum - Boost cars, acquire cats.

Go Back  Miata Turbo Forum - Boost cars, acquire cats. > Performance & Tuning > ECUs and Tuning > MEGAsquirt > MSPNP
Reload this Page >

Cold start idle drops right away for a second

MSPNP MSPNP specific Megasquirt related discussion.
Sponsored by:
Sponsored by:

Cold start idle drops right away for a second

Old 01-06-2019, 11:03 PM
  #1  
Newb
Thread Starter
 
Join Date: Apr 2014
Posts: 36
Total Cats: 2
Default Cold start idle drops right away for a second

Hey guys, I'm having a bit of an issue with my cold start, it starts right up but the rpm drops right away but then goes back up to normal idle. I have been trying to change some settings with the afterstart and other stuff but I just can't seem to figure it out. I am really new to this and still haven't really grasp all the functions that would get this idle drop solved. I have attached my current tune and a datalog from this morning. Please let me know if you have any idea on what can solve this issue. Any help will be appreciated. Thank you!
Attached Files
File Type: msq
CurrentTune.msq (117.0 KB, 4 views)
File Type: msl
2019-01-06_15.00.14.msl (646.5 KB, 5 views)
ravinaziankid is offline  
Old 01-06-2019, 11:26 PM
  #2  
Elite Member
 
Join Date: Apr 2010
Location: Newcastle, Australia
Posts: 2,818
Total Cats: 52
Default

You max idle duty on the closed loop idle settings page is 30, and your cranking duty is much higher, as is your base values table.

Increase your max idle valve duty to start with. Go with 80% to get the full possible range.
nitrodann is offline  
Old 01-06-2019, 11:48 PM
  #3  
Newb
 
Join Date: Feb 2015
Location: Melb, Australia
Posts: 7
Total Cats: 3
Default

Looking at your tune, I would agree with dann, but you should run the IDLE VALVE TEST, and see what your max idle valve duty actually is. (CAN bus/Testmodes - top right of tunerstudio), I find it unlikely that 30% is the actual open limit.

I would also change your crank to run taper, start at 6 and see how it reacts, this should give it a little more time to settle before transitioning to the run position.
Your closed loop initial values don't look to crazy, but your max is 43.1 in the lookup table, higher than your max open setting, this may cause some issues as your limiting the max to 30 which is your 825rpm area according to your initial value table.
pyr0boy is offline  
Old 01-07-2019, 12:17 AM
  #4  
Newb
Thread Starter
 
Join Date: Apr 2014
Posts: 36
Total Cats: 2
Default

Thanks for the info guys, i'll give your suggestions a try. I will try to do the idle valve test, I thought that the tuner I used set it up but I'm not sure if he actually did.
ravinaziankid is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
aaronwalker1974
MEGAsquirt
7
09-15-2017 07:36 PM
ravinaziankid
EcuFlash
0
02-22-2017 03:24 PM
Cross
General Miata Chat
8
12-08-2010 09:12 PM
luiml73
ECUs and Tuning
1
05-27-2010 02:01 PM
norrismiata
Engine Performance
21
10-24-2008 02:39 PM


Thread Tools
Search this Thread
Quick Reply: Cold start idle drops right away for a second


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.