How to calibrate thermistor with MS1?? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MSPNP MSPNP specific Megasquirt related discussion.

Reply
 
 
 
LinkBack Thread Tools
Old 01-03-2015, 12:14 PM   #1
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Oct 2008
Location: Indianapolis
Posts: 613
Total Cats: 12
Default How to calibrate thermistor with MS1??

My CLT gauge will not read under 50 degrees Fahrenheit even when the coolant is actually 30 degrees and AIT reads the same.
I have MS1 and don't have thermistor calibration option in tuner studio.
I am thinking about buying a GM CLT sensor from diyautotune and using it instead.
Does anyone have the firmware to use the GM clt? Or how can I calibrate my CLT? It currently reads properly at higher temps but like I said, it wont read cold temperatures accurately, making cold start a hassle since I can't even tune it properly.
Thanks
btabor is offline   Reply With Quote
Old 01-03-2015, 01:29 PM   #2
Sadfab Union President
iTrader: (3)
 
Join Date: May 2014
Location: Kansas
Posts: 2,690
Total Cats: 113
Default

ExtraEFI.co.uk HOME

I think this is the process, you use the easytherm program to make the proper temperature curves.

I think the default CLT curves in MS are the same as GM CLT settings. If you swap to one of those I don't think you need to touch anything.
deezums is offline   Reply With Quote
Old 01-03-2015, 01:33 PM   #3
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,110
Total Cats: 518
Default

Yeah, you'll wanna download and use easytherm. There's writeups around about how to calibrate for the stock sensor. It's pnp to your stock harness, don't introduce wiring errors and extra costs by using a GM piece.
curly is offline   Reply With Quote
Old 01-05-2015, 12:05 PM   #4
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

If this is an MSPNP Gen 1, the easiest way to do the calibration is to load the provided, pre-calibrated firmware from the MSPNP software package:

MegaSquirtPNP by DIYAutoTune.com
Matt Cramer is offline   Reply With Quote
Old 01-05-2015, 02:18 PM   #5
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Oct 2008
Location: Indianapolis
Posts: 613
Total Cats: 12
Default

I updated the software to the latest version a few months ago. The previous version had the same problem. I ordered a new miata clt sensor so we'll see if that fixes the problem.
btabor is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
MS PNP requires reading and following directions??? satisfied MEGAsquirt 141 10-06-2015 11:44 AM
Software/IT types/Joe P, step inside please z31maniac Insert BS here 13 09-22-2015 03:59 PM
VE values too low? compuw22c MEGAsquirt 4 09-12-2015 08:42 PM
AFR Not showing anything eunosgippa MEGAsquirt 0 09-09-2015 06:19 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:45 PM.