MSPNP MSPNP specific Megasquirt related discussion.
Sponsored by:
Sponsored by:

Mspnp2 (94-95), 99 IAC frequency, idle

 
Old 09-22-2016, 08:55 PM
  #1  
Senior Member
Thread Starter
iTrader: (2)
 
Onyxyth's Avatar
 
Join Date: May 2013
Location: Boyertown, PA
Posts: 729
Total Cats: 62
Default Mspnp2 (94-95), 99 IAC frequency, idle

Hey guys, I'm running a mspnp2 94-95 with a 99-00 head/intake/TB/IAC.

I'm having an issue where a single IAC step results in large swings of rpm, while other steps have no effect at all. I'm using a multiplier of 15 to control the IAC. Closed loop idle.

For instance my idle target is 950 when warm. Step 55 might give me 920 rpm, so closed loop tries one step up, 56. This might result in ~1030 rpm, so it drops back down to 55. Repeat forever.

I've also noticed that in test mode, not all steps will change the idle. It's only maybe every 5-7.

This leads me to believe I'm using the wrong frequency to control the IAC.

99-00 should be 500 MHz, yeah? Which would be x16? But tunerstudio only allows up to x15.

What am I missing?
Onyxyth is offline  
Old 09-23-2016, 09:51 AM
  #2  
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,329
Total Cats: 62
Default

Try the 3.4.2 firmware; it has some improvements to idle control resolution and lets you specify the frequency directly.
__________________
Matt Cramer
www.diyautotune.com
Matt Cramer is offline  
Old 09-23-2016, 12:52 PM
  #3  
Senior Member
Thread Starter
iTrader: (2)
 
Onyxyth's Avatar
 
Join Date: May 2013
Location: Boyertown, PA
Posts: 729
Total Cats: 62
Default

This is the old board. V1.2, is that fine? I'll double check when I get a minute later today.
Onyxyth is offline  
Old 09-23-2016, 06:41 PM
  #4  
Senior Member
Thread Starter
iTrader: (2)
 
Onyxyth's Avatar
 
Join Date: May 2013
Location: Boyertown, PA
Posts: 729
Total Cats: 62
Default

Hey Matt,

I successfully updated the firmware, and after some fiddling with outputs being moved around, got the car to run. However Tunerstudio is reporting it's not in sync.

Can you take a look?
Attached Files
File Type: zip
No_Sync_Logs.zip (60.5 KB, 3 views)
Onyxyth is offline  
Old 09-23-2016, 07:48 PM
  #5  
Senior Member
Thread Starter
iTrader: (2)
 
Onyxyth's Avatar
 
Join Date: May 2013
Location: Boyertown, PA
Posts: 729
Total Cats: 62
Default

RTFM!

"Not Synced" was changed to "Not RPM Synced" in the newest firmware. So my little red indicator telling me I wasn't in sync was completely wrong. I just had to delete it and make a new "Not RPM Synced" indicator. All is well!

Idle works much better too
Onyxyth is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Arny
MEGAsquirt
56
06-11-2018 04:16 PM
Lawone
ECUs and Tuning
14
09-23-2016 04:28 AM
customfab87
Suspension, Brakes, Drivetrain
5
09-22-2016 03:30 AM
KMiata
Engine Performance
8
09-20-2016 01:31 AM


Thread Tools
Search this Thread
Quick Reply: Mspnp2 (94-95), 99 IAC frequency, idle


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.