Variable TPS installed, now what? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MSPNP MSPNP specific Megasquirt related discussion.

Reply
 
 
 
LinkBack Thread Tools
Old 05-04-2010, 10:18 PM   #1
Junior Member
Thread Starter
 
Join Date: Jan 2008
Location: Toronto, Ontario, Canada
Posts: 74
Total Cats: -4
Default Variable TPS installed, now what?

I've just done the mods req'd inside my MegaSquirtPNP MM9093 & hooked up a variable TPS.
Has anyone done a write-up on what should be done with the software to make it work?
Or is it just Calabrate & go? [not likely, nothing is ever that simple :-) ]
StarGehzer is offline   Reply With Quote
Old 05-05-2010, 12:08 PM   #2
Junior Member
Thread Starter
 
Join Date: Jan 2008
Location: Toronto, Ontario, Canada
Posts: 74
Total Cats: -4
Default

Quote:
Originally Posted by StarGehzer View Post
Or is it just Calabrate & go? [not likely, nothing is ever that simple :-) ]

Well that's what I did & all seems to be fine so far.
StarGehzer is offline   Reply With Quote
Old 05-07-2010, 08:26 PM   #3
Newb
 
Join Date: Apr 2010
Posts: 2
Total Cats: 0
Default

Well i found i had to change the acceleration enrichment settings to tps based acceleration in order to get the best results although still playing around with this, i did use some of the settings from a 94-95 base map.
I also found some other settings that should be changed to take advantage, being that the pnp is setup to virtualy ignore the stock tps.
Probably wrong, first post, noob etc...
Whipit is offline   Reply With Quote
Old 08-08-2010, 12:23 PM   #4
Junior Member
 
Join Date: Aug 2009
Location: Spain
Posts: 73
Total Cats: 0
Default

any other opinion?
I will change mi TPS for a Auto TPS next week.
Any can tell me colour code to join the wires?
Can anybody make a stupid guide to change the configuration in the Megatune?
Thanks.
sanson is offline   Reply With Quote
Old 08-08-2010, 01:11 PM   #5
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

I have a thread somewhere on here where someone broke down the wiring details and how to modify the PCB. I searched and can't find it though.
hustler is offline   Reply With Quote
Old 08-23-2010, 06:40 AM   #6
Junior Member
 
Join Date: Aug 2009
Location: Spain
Posts: 73
Total Cats: 0
Default

Quote:
Originally Posted by Whipit View Post
Well i found i had to change the acceleration enrichment settings to tps based acceleration in order to get the best results although still playing around with this, i did use some of the settings from a 94-95 base map.
I also found some other settings that should be changed to take advantage, being that the pnp is setup to virtualy ignore the stock tps.
Probably wrong, first post, noob etc...
Can you tell step by step after calibration the VTPS what is needed to do?

Last edited by sanson; 08-23-2010 at 10:48 AM.
sanson is offline   Reply With Quote
Old 08-24-2010, 12:14 PM   #7
Junior Member
 
Join Date: Aug 2009
Location: Spain
Posts: 73
Total Cats: 0
Default

i read the Manual 94-95 and there is some steps to do in the case of a VTPS.
Is it ok?

1) Calibrate your TPS
•Key in the on position, car should not be running.
•Connect to your MSPNP with MegaTune, from the Tools menu, choose 'Calibrate TPS'.
•With your foot OFF the throttle, click 'GET CURRENT' for the Closed Throttle ADC Count
•Floor it and hold it there. Click 'GET CURRENT' for the Full Throttle ADC Count
2) Idle Dashpot Settings (prevent stalls when coming to a stop with the AC on)
•From the main MegaTune screen (with the gauges), right click on any of the gauges and choose SWAP TO. Choose tpsADCGauge near the bottom right.
•Look at the TPS ADC gauge you just selected with your foot off the throttle. Add 4 points to this number and remember that new number.
•Open the 'More Settings' Menu and choose 'Idle Control'.
•Near the bottom, set the 'TPS Threshold (ADC)' to the number you just calculated by adding 4 to your closed throttle TPS ADC.
•Click 'BURN TO ECU' and then click 'CLOSE'.
•NOTE-- you will need to know this same number for the next exercise as well.
3) Overrun Fuel Cut (cuts off the injectors when you are decelerating, saves fuel, stops the rich pop, pop, pop sounds)
•Start the car and let it warm up.
•Note the idle MAP reading.
•Rev the car up to maybe 4000-5000rpm and then let off the throttle. Watch the MAP reading while the engine is decelerating. Repeat this a couple times.
•Note the lowest kpa reading you get on the MAP sensor when doing this. Add 3 to this number and remember this number for use in a moment. This is 'decel kpa +3'
•Open the 'More Settings' Menu and choose 'Over Run Settings'.
•Plug the number you just calculated (decel kpa +3) into the 'and KPa lower than (KPa)' field.
•Now use the same number you calculated for the previous exercise (4 points above closed throttle TPS ADC), and plug it into the 'and TPS lower than (Raw ADC)' field.
•Click 'BURN TO ECU' and then click 'CLOSE'.

Thanks
sanson is offline   Reply With Quote
Old 01-20-2011, 07:05 PM   #8
Senior Member
iTrader: (1)
 
Join Date: Apr 2008
Location: Florida
Posts: 774
Total Cats: -5
Default

Hey guys..

I'm reinstalling my MS back in including the VTPS. The VTPS was working before.

After I get the closed and open values and swap a Megatune dashboar gage to tps/ADCGauge everything reads ok. However, the little vertical gage in the AEwizard sub menus and my logs say that my VTPS is only moving like 20%

Any ideas what is going on ?

I verified that the potentiometer is moving full travel.
poobs is offline   Reply With Quote
Old 01-21-2011, 10:27 AM   #9
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

The little vertical gauge in the Acceleration Wizard is not your TPS reading - it is the first derivative of the TPS voltage with respect to time.
Matt Cramer is offline   Reply With Quote
Old 01-21-2011, 11:18 AM   #10
Senior Member
iTrader: (1)
 
Join Date: Apr 2008
Location: Florida
Posts: 774
Total Cats: -5
Thumbs up

Thanks Matt. I got you email after I posted this.

I'm starting a new job and hopefully the now turboed miater will be a daily driver so I'm "Russian" to get things sorted out.

VE table is a little better so far and I'm going to be doing more logging/tuning sessions

The AE has never been my forte - My guess is that aside for pedal feel you look for the A/F trace on the log to recover quickly after AE event.....
poobs is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:54 PM.