aww mannn - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 03-02-2008, 09:06 PM   #1
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Guam (U.S Terr.)
Posts: 786
Total Cats: -2
Default aww mannn

alright so heres an update. sorry i wish i took pics and vids but i forgot my carmera. but my setup is the 1.6 greddy with a aluminum cross over pipe and a knock of blow off valve. so i couldn't get a racing beat exhaust so i had to go get the stock one from a friend so i can shut my car up. i dont know what to call the pipe that connects to the down pipe ill ust call that whole thing the "down pipe". well the exhaust wouldnt just bolt right up and it was being a bitch. so i loosened the down pipe so i can flexx the flange a little... so finally after trial and error i bolted the exhaust on.. so i started it up so i can hear the blow off valve but then when i started the car it WAS STILL LOUD. found out my mani nedds new gaskets the exhaust was shooting out from the top .you can see the carbon
mike_671 is offline   Reply With Quote
Old 03-02-2008, 09:34 PM   #2
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

So it's leaking between the turbo and manifold? Try running it without a gasket. If there is no gasket then there is none to blow out. Keeping your bolts tight will usually keep that from happening.
cjernigan is offline   Reply With Quote
Old 03-02-2008, 10:09 PM   #3
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

hmm...

i had a similar problem.
just a shot in the dark but does a 1.6L motor have those water tube here mounted like this?



if it does, did you happen to accidentally mount the manifold above this? this should bolt after the manifold is placed. for the longest time it drove me nuts cause everything fit in place and looked fine, but that caused lots of problems til i realized the mistake.

hell, is the carbon coming from the manifold to the head or from the mani to the turbo?
Marc D is offline   Reply With Quote
Old 03-02-2008, 11:11 PM   #4
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Guam (U.S Terr.)
Posts: 786
Total Cats: -2
Default

oh **** i didnt mention where it was leaking sorry...its from the mani to the block not the turbo
mike_671 is offline   Reply With Quote
Old 03-02-2008, 11:13 PM   #5
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Guam (U.S Terr.)
Posts: 786
Total Cats: -2
Default

Quote:
Originally Posted by badboy88000 View Post
hmm...

i had a similar problem.
just a shot in the dark but does a 1.6L motor have those water tube here mounted like this?



if it does, did you happen to accidentally mount the manifold above this? this should bolt after the manifold is placed. for the longest time it drove me nuts cause everything fit in place and looked fine, but that caused lots of problems til i realized the mistake.

hell, is the carbon coming from the manifold to the head or from the mani to the turbo?
ohhhh..i put the mani on top of that bracket.. so its suppose to go above the mani not under it
mike_671 is offline   Reply With Quote
Old 03-02-2008, 11:49 PM   #6
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

yup! that should solve your problem
Marc D is offline   Reply With Quote
Old 03-03-2008, 08:01 AM   #7
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Guam (U.S Terr.)
Posts: 786
Total Cats: -2
Default

Quote:
Originally Posted by badboy88000 View Post
yup! that should solve your problem
+1 thanks that solved that now my cars quiet and i can hear my blow off valve
mike_671 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Is compressor surge what just killed my turbo? sixshooter DIY Turbo Discussion 17 07-09-2012 10:19 PM
WTB: Bracket for BRP supercharger ecko WTB 1 12-10-2010 04:36 PM
Bro's how do I look? Full_Tilt_Boogie Insert BS here 32 05-06-2010 12:37 AM
A stock Miata is not stable at 95 MPH. oilstain Insert BS here 40 08-16-2008 11:26 AM
Some funny comic strips! teknikscian Insert BS here 0 01-15-2008 05:24 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:01 PM.