FMII and MS3: What fuel economy should I expect? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 12-21-2015, 03:52 PM   #1
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: Redmond, WA
Posts: 130
Total Cats: 0
Default FMII and MS3: What fuel economy should I expect?

As some of you know, I've had an FMII and a Rev-built MS3 installed in my '95 with original engine by a local tuner shop that recommended the MS, and I'd appreciate feedback on what kind of fuel economy I should expect. Would you please share what you're seeing if you have a similar setup?

I had an old JR M45 and a Link before installing the turbo and I typically saw 21-24 mpg combined. From talking with Brandon at FM, he's got the same hardware run by a Link and he's seeing 26-28 in town and 28-30 on the highway driving conservatively. Brandon suggested I should see similar fuel consumption with perhaps a 5-10% bump because of Megasquirt's improved efficiency over the Link.

When I first picked up the car after the installation, I wanted to baseline fuel consumption with the new setup. In particular, I wanted to see how it compared to the JR/Link setup. To that end, I've been driving the car very conservatively - mostly out of boost since an engine is usually running that way - and generally boosting to 7psi or less. I expected a substantial improvement in off-boost consumption because the turbo avoids the parasitic drag from the supercharger.

But instead of an improvement, I'm typically seeing consumption of 15-19 mpg with a fair combination of street and highway driving. The tuner and I are both seeing that the AFR target table appears correct and the VE table is showing mixtures that are hitting the targets. We replaced the WBO2 sensor with a new Innovate unit and that hasn't improved anything. We're also running with sequential fuel and ignition to RC 550 injectors and the FAB9 CoP system.

The car is actually running great and making good power except for the fuel. My tuner is saying everything should be working, he's done about everything he can, and that 15 mpg could be about the best we can get. That doesn't seem right since I was seeing better with the supercharger/Link and the new setup should be *more* efficient when staying out of boost. At the very least, a 1.8L engine in a 2400 pound car shouldn't be getting mid-to-high teens in fuel consumption. That sounds more like a big pickup truck.

My tuner says the next step is to "force" the ECU to burn less fuel by playing with timing and leaning out the mixture. He's the expert so I need to defer to his opinion, but that doesn't feel quite right to me.

Alternatively, he suggested the fuel pressure might be too low to make my RC injectors happy. As part of this build, I had them install a used Vishnu fuel rail that has a fuel pressure regulator attached. Since it's used, I suppose it's possible that the regulator could be bad but that seems unlikely.

Any thoughts about what could be going on?

Last edited by aceswerling; 12-21-2015 at 04:21 PM.
aceswerling is offline   Reply With Quote
Old 12-21-2015, 04:47 PM   #2
Elite Member
iTrader: (17)
 
Join Date: Aug 2007
Location: Fort Myers, FL
Posts: 2,790
Total Cats: 128
Default

When you're cruising at a constant speed what is your wideband showing? With normal driving my gas mileage has been pretty consistent between a turbo and a stock car. You do seem lower than I'd expect it to be.

I usually lean out cruise afr to 15.5:1. That seems to pick up a little bit that gets offset when you get in the throttle. I see people claiming +30mph pretty regularly but that hasn't been my experience. I typically get 21-24mpg on 93 octane, my record tank was 29mpg. Even on E85 I get 17-20mpg.
pdexta is offline   Reply With Quote
Old 12-21-2015, 04:55 PM   #3
Elite Member
 
Chiburbian's Avatar
 
Join Date: Feb 2008
Location: Gilberts, IL
Posts: 2,158
Total Cats: 131
Default

Another thing to look at could be overly aggressive accel enrichment. This is the time when you should be posting logs (and pictures of logs) of different run states.
Chiburbian is offline   Reply With Quote
Old 12-21-2015, 05:14 PM   #4
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,353
Total Cats: 1,319
Default

I typically see 19-20mpg with my EFR6258 + Basic MS3. My old MS1'd NA was less - typically 16-17 in town. I saw as low as 12.5mpg on two separate tanks (one 100% town tank, one 100% highway tank at entirely unmentionable speeds), and as high as 30mpg (65mpg, some hills, no boost, 100% highway).

IOW, it depends almost entirely on how you drive. If you beat it like a rented mule, it will return mid to high teens. If you drive it like your grandmother is riding shotgun, it will return mid to high 20s.
Savington is offline   Reply With Quote
Old 12-21-2015, 05:19 PM   #5
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,990
Total Cats: 1,457
Default

I get over 30 on the highway.

Post your tune and logs. We can't help you without them.
aidandj is offline   Reply With Quote
Old 12-21-2015, 05:23 PM   #6
Elite Member
iTrader: (1)
 
Join Date: Jun 2014
Location: Austin, TX
Posts: 2,842
Total Cats: 271
Default

I drive mostly off boost... 20-24mpg when I ran RC injectors, I average almost 28-30mpg on newer five-o 460cc ev14

Stock ecu with begi reflash + xede though. Cruising AFR bounces between 14.7-15.3
Girz0r is offline   Reply With Quote
Old 12-21-2015, 05:26 PM   #7
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: Redmond, WA
Posts: 130
Total Cats: 0
Default

Thanks for the responses, guys.

@pdexta, I'm seeing 14.7 at cruise, which is what the Rev's base AFR target table is set to.

@chiburbian, I'm happy to post logs if you all are willing to look at them. I'd sure appreciate the help. Is there anything in particular I should be logging?

@savington, I'm driving it like my grandmother is riding shotgun in an attempt to optimize my baseline fuel consumption. I'd be happy with low to mid 20s since that's what I was getting with the supercharger/Link.
aceswerling is offline   Reply With Quote
Old 12-21-2015, 05:28 PM   #8
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,990
Total Cats: 1,457
Default

Log all sorts of different driving conditions.
aidandj is offline   Reply With Quote
Old 12-21-2015, 05:29 PM   #9
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: Redmond, WA
Posts: 130
Total Cats: 0
Default

@aidandj, my tuner doesn't want me to post the tune because he considers that his intellectual property. I appreciate that he's left it unlocked so I'd like to respect his request, even if it's inconvenient. I can look into any settings that you suggest though.

@girz0r, my tuner suggested the RC 500s may also be a problem because of an inefficient spray pattern. I'm open to getting other injectors if they'll improve efficiency.
aceswerling is offline   Reply With Quote
Old 12-21-2015, 05:29 PM   #10
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: Redmond, WA
Posts: 130
Total Cats: 0
Default

OK, I'll go for a drive and post the logs when I come back. Sure appreciate the help. Thanks, guys.
aceswerling is offline   Reply With Quote
Old 12-21-2015, 05:30 PM   #11
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,990
Total Cats: 1,457
Default

We probably can't help you then. Talk to your tuner then, sounds like its his problem.
aidandj is offline   Reply With Quote
Old 12-21-2015, 05:31 PM   #12
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: Redmond, WA
Posts: 130
Total Cats: 0
Default

Yes, it's his problem to fix. I'm trying to understand what the heck is going on. Hard for the engineer in me to keep out of this, especially since we've been wrestling with it for a couple months.

I thought of an additional bit of information to share. Up until recently, the shop has been unable to duplicate the same poor fuel consumption that I've been seeing. We talked about it in greater detail and realized that they've been driving the car really hard with a lot of boost, in comparison with the grandmotherly way that I've been driving it. So whereas I've been seeing 15-19, they've been seeing 19-24. So it seems like the problem is in the non-boosted areas of the tune.

I'll go log a drive and get back to you. Thanks again.

Last edited by aceswerling; 12-21-2015 at 05:42 PM.
aceswerling is offline   Reply With Quote
Old 12-21-2015, 07:16 PM   #13
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: Redmond, WA
Posts: 130
Total Cats: 0
Default

OK, folks. I drove around for some errands and took a log file. I'd say this is a fair representation of the kind of driving I've been doing. I'd sure appreciate it if you could see if anything looks out of the ordinary.
Attached Files
File Type: zip 2015-12-21_13.48.43.zip (2.03 MB, 5 views)
aceswerling is offline   Reply With Quote
Old 12-21-2015, 07:19 PM   #14
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,990
Total Cats: 1,457
Default

That looks like a composite log. Not a datalog.
aidandj is offline   Reply With Quote
Old 12-21-2015, 07:40 PM   #15
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,775
Total Cats: 1,106
Default

Back in 2007-2010 I could easily get 32mpg on the interstate with a Begi S1, rx7 440cc injectors, and MS1 as long as I did not floor it to much. I would try to cruise around 15.5-16.0:1.
shuiend is offline   Reply With Quote
Old 12-21-2015, 08:08 PM   #16
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: Redmond, WA
Posts: 130
Total Cats: 0
Default

Oh, I suppose it is a composite log. I didn't know there were different kinds of logs since this is all new to me.

I don't see an option for "data log" on the logging tab in TunerStudio. I searched around online and in the help file and I can't find anything there either. Would you please clue me in on how to get you a log you can use?
aceswerling is offline   Reply With Quote
Old 12-21-2015, 08:14 PM   #17
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: Redmond, WA
Posts: 130
Total Cats: 0
Default

Oh, I think I see it now. It's under the Data Logging menu instead of the Diagnostics & High Speed Loggers tab. Is that the one?
aceswerling is offline   Reply With Quote
Old 12-21-2015, 08:15 PM   #18
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,775
Total Cats: 1,106
Default

Quote:
Originally Posted by aceswerling View Post
Oh, I think I see it now. It's under the Data Logging menu instead of the Diagnostics & High Speed Loggers tab. Is that the one?
Yeah, click the dropdown menu and hit start log. Go drive, then hit stop log before you turn off the car.
shuiend is offline   Reply With Quote
Old 12-21-2015, 08:51 PM   #19
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: Redmond, WA
Posts: 130
Total Cats: 0
Default

OK, I got a datalog this time. Would you all please take a look and let me know what you think?
Attached Files
File Type: zip 2015-12-21_16.19.17.zip (1.59 MB, 20 views)
aceswerling is offline   Reply With Quote
Old 12-21-2015, 11:12 PM   #20
Elite Member
iTrader: (4)
 
Join Date: Sep 2006
Location: Charlotte, NC
Posts: 3,048
Total Cats: 4
Default

I don't think it's necessarily the root of your problem, but you should definitely investigate getting better injectors. The RCs are pretty junky compared to the current batch of affordable Bosch ev14 injectors.

Flowforce, Injector Dynamics, etc
Efini~FC3S is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
FS: Fab9 COPS for sequential setups $150 psyber_0ptix Miata parts for sale/trade 12 11-19-2015 12:13 PM
AFR gauge reading for wideband in Tuner Studio Windows95 MEGAsquirt 6 11-18-2015 02:51 PM
FS: Fab9 COP kit with latest module Mazdaspeeder Miata parts for sale/trade 2 11-07-2015 08:53 PM
More fail cyl 2 and 4 dont seem to matter 90 Turbo MEGAsquirt 5 10-29-2015 02:24 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:24 AM.