it glows at 7psi - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 03-21-2009, 01:10 AM   #1
I'm Miserable!
Thread Starter
iTrader: (2)
 
Join Date: Apr 2008
Location: monroe CT
Posts: 463
Total Cats: 0
Default it glows at 7psi

just got done building my motor and for same reason my turbo will just glow after driving down the highway not even beating on it no leaks any were and im on the stock flyin miata tune. the car is getting tuned on a dyno tomorrow

99 miata
fm1 kit with gt2560r
fm duals and one high flow cat
link piggy back for now
built motor

so if any one can think of any thing of why it would glow at 7psi.
1990miata1.6 is offline   Reply With Quote
Old 03-21-2009, 01:15 AM   #2
Junior Member
iTrader: (1)
 
Join Date: Mar 2007
Location: South Florida
Posts: 491
Total Cats: -1
Default

Lean to the max.
mrtonyg is offline   Reply With Quote
Old 03-21-2009, 01:15 AM   #3
Antisaint
iTrader: (17)
 
Vashthestampede's Avatar
 
Join Date: Feb 2007
Location: Danbury, CT
Posts: 4,659
Total Cats: 54
Default



There was a thread recently with a discussion about turbo glow. I've had my manifold glow before on my old setup. Pretty sure its normal, although in that thread someone mention something aboot a tune. Pretty sure Corky's post said it was perfectly fine.
Vashthestampede is offline   Reply With Quote
Old 03-21-2009, 01:20 AM   #4
Junior Member
iTrader: (1)
 
Join Date: Mar 2007
Location: South Florida
Posts: 491
Total Cats: -1
Default

Quote:
Originally Posted by Vashthestampede View Post


There was a thread recently with a discussion about turbo glow. I've had my manifold glow before on my old setup. Pretty sure its normal, although in that thread someone mention something aboot a tune. Pretty sure Corky's post said it was perfectly fine.
Did you read that it was glowing without even getting on the throttle hard. That is not normal.

To the OP, you should invest in a EGT gauge.
mrtonyg is offline   Reply With Quote
Old 03-21-2009, 01:20 AM   #5
I'm Miserable!
Thread Starter
iTrader: (2)
 
Join Date: Apr 2008
Location: monroe CT
Posts: 463
Total Cats: 0
Default

i dont think its running lean i have the fuel up made high to were it is just starting to make it kill power and you can smell it run crazy rich. the glow i dont think is normal for only 7psi and just rollin at 60mph.
1990miata1.6 is offline   Reply With Quote
Old 03-21-2009, 01:22 AM   #6
I'm Miserable!
Thread Starter
iTrader: (2)
 
Join Date: Apr 2008
Location: monroe CT
Posts: 463
Total Cats: 0
Default

if i beat on it, it will glow really bad to were it looks like it will melt.
1990miata1.6 is offline   Reply With Quote
Old 03-21-2009, 01:25 AM   #7
Junior Member
iTrader: (1)
 
Join Date: Mar 2007
Location: South Florida
Posts: 491
Total Cats: -1
Default

Get a WBO2 and EGT gauge.
mrtonyg is offline   Reply With Quote
Old 03-21-2009, 01:25 AM   #8
Antisaint
iTrader: (17)
 
Vashthestampede's Avatar
 
Join Date: Feb 2007
Location: Danbury, CT
Posts: 4,659
Total Cats: 54
Default

Quote:
Originally Posted by 1990miata1.6 View Post
the glow i dont think is normal for only 7psi and just rollin at 60mph.
lol.....yea that doesn't sound normal.

I figured being nick his not beating on it was not thrashing it. Didn't think he was talking about neutral bombing it.
Vashthestampede is offline   Reply With Quote
Old 03-21-2009, 01:26 AM   #9
I'm Miserable!
Thread Starter
iTrader: (2)
 
Join Date: Apr 2008
Location: monroe CT
Posts: 463
Total Cats: 0
Default

Quote:
Originally Posted by mrtonyg View Post
Get a WBO2 and EGT gauge.

thats next on my list once i get my tune
1990miata1.6 is offline   Reply With Quote
Old 03-21-2009, 01:34 AM   #10
I'm Miserable!
Thread Starter
iTrader: (2)
 
Join Date: Apr 2008
Location: monroe CT
Posts: 463
Total Cats: 0
Default

shots of the engine setup
Attached Images
File Type: jpg Photo0320.jpg (158.6 KB, 347 views)
File Type: jpg Photo0319.jpg (131.8 KB, 348 views)
1990miata1.6 is offline   Reply With Quote
Old 03-21-2009, 11:04 AM   #11
Elite Member
iTrader: (5)
 
m2cupcar's Avatar
 
Join Date: Jan 2005
Location: Atlanta
Posts: 7,236
Total Cats: 288
Default

Actually extremely rich will make it glow. It's a lot like the flame you see in an open exhaust when unburnt fuel combusts in the exhaust. But yours is happening in the manifold. Also check ign. Too much retard will put the tail end of the combustion in the exhaust manifold too. Lots of other things can cause this... exhaust restriction (bad cat), cam timing...
m2cupcar is offline   Reply With Quote
Old 03-22-2009, 01:45 PM   #12
Newb
 
Join Date: Mar 2009
Location: Gnarkansas
Posts: 22
Total Cats: 0
Default

Like m2cupcar said. Check the timing as well. Lots of retard with get you the glowy rally style manifold at part throttle.

jeff
Swordfish is offline   Reply With Quote
Old 03-22-2009, 04:39 PM   #13
Elite Member
iTrader: (17)
 
Join Date: May 2007
Location: NY
Posts: 1,614
Total Cats: 2
Default

^this was my problem

In fact I keep adding fuel thinking it was too lean, found out my timing was way off.

Mine was glowing like crazy too, and also at 6psi...


Word of advice, don't beat on the thing if you think its not setup right...

And you invested all that money into your build, but no wb02??
TonyV is offline   Reply With Quote
Old 03-22-2009, 09:42 PM   #14
I'm Miserable!
Thread Starter
iTrader: (2)
 
Join Date: Apr 2008
Location: monroe CT
Posts: 463
Total Cats: 0
Default

went to the dyno and made 100whp and 85wtq on 6psi and on 20psi i made 85whp and 70wtq they said my crank pulley is bad i put a wideband in too and fix the crazy rich problem
1990miata1.6 is offline   Reply With Quote
Old 03-22-2009, 09:48 PM   #15
Junior Member
 
Join Date: Feb 2009
Location: Southside, VA
Posts: 60
Total Cats: 0
Default

your posts confuse me, and are extremely hard to read.
jarrett2k is offline   Reply With Quote
Old 03-22-2009, 09:57 PM   #16
I'm Miserable!
Thread Starter
iTrader: (2)
 
Join Date: Apr 2008
Location: monroe CT
Posts: 463
Total Cats: 0
Default

sorry im using my phone to post
1990miata1.6 is offline   Reply With Quote
Old 03-22-2009, 10:37 PM   #17
Moderator
iTrader: (11)
 
sixshooter's Avatar
 
Join Date: Nov 2008
Location: Tampa, Florida
Posts: 15,653
Total Cats: 1,559
Default

You ran 20 psi? That's got to be a typo. If your crank pulley is messed up, that's probably why your timing is so screwed up. The little timing mark on your pulley has moved. You should re-index the pulley if it isn't messed up in some other way.

BTW, your car should make ~90 hp without the turbo.

And stop driving it before you screw it up permanently. Get the timing right and get the wideband installed, then check/adjust fueling, then drive it around.
sixshooter is offline   Reply With Quote
Old 03-22-2009, 10:44 PM   #18
I'm Miserable!
Thread Starter
iTrader: (2)
 
Join Date: Apr 2008
Location: monroe CT
Posts: 463
Total Cats: 0
Default

Quote:
Originally Posted by sixshooter View Post
You ran 20 psi? That's got to be a typo. If your crank pulley is messed up, that's probably why your timing is so screwed up. The little timing mark on your pulley has moved. You should re-index the pulley if it isn't messed up in some other way.

BTW, your car should make ~90 hp without the turbo.

And stop driving it before you screw it up permanently. Get the timing right and get the wideband installed, then check/adjust fueling, then drive it around.
20psi is not a typo but i have dropped it down to wastegate. I have ordered a new crank pullry and the wideband is installed. I was running crazy rich so I leaned it out and it got a lot better. the car is parked till I get the new pulley in. I dont want to blow my new motor.

Last edited by 1990miata1.6; 03-22-2009 at 10:58 PM.
1990miata1.6 is offline   Reply With Quote
Old 03-23-2009, 09:28 PM   #19
I'm Miserable!
Thread Starter
iTrader: (2)
 
Join Date: Apr 2008
Location: monroe CT
Posts: 463
Total Cats: 0
Default

well ripped every thing off today and found my boss pulley wich holds the crank pulley on the crank was bad and the intake cam was off one tooth. so it should be good once my parts come in.
1990miata1.6 is offline   Reply With Quote
Old 03-23-2009, 11:22 PM   #20
Moderator
iTrader: (11)
 
sixshooter's Avatar
 
Join Date: Nov 2008
Location: Tampa, Florida
Posts: 15,653
Total Cats: 1,559
Default

Sounds like you found something useful in your search. Cams being off can screw your exhaust temps and power also.

If you ran 20 psi you probably made bad power for all of the above reasons plus something else. Your intake air temperature would have been through the roof due to the overexertion of your compressor trying to cram air into the engine, and the inability of your exhaust to let it all out fast enough. I hope your engine didn't get hurt too badly. That is a classic way that engines are blown. You had high intake air temps, spark timing off, cam timing off, fueling off (but maybe rich). Best case scenario spark was very retarded and fueling was rich and you are ok.

Good luck.
sixshooter is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
NA 1.6: glowing manifold and turbo railz DIY Turbo Discussion 23 12-02-2009 09:38 PM
Glowing turbo and 3psi? Ole Prefabbed Turbo Kits 76 08-22-2007 09:30 AM
Glowing!! BrokeEnthusiast Prefabbed Turbo Kits 13 08-21-2006 11:48 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:38 PM.