IT WORKS!..kinda - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 09-03-2006, 11:59 PM   #1
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default IT WORKS!..kinda

Well the good news is the kit is in! I turned the key and first try it ran...like ****. It idles fairly good and I'm showing 17-20 on the vacuum and 40-50ish psi of oil pressure on a cold start. So YAY! no nicked oil pickup! I have fought this stupid kit every single step of the way!
My biggest problem is the stock exhaust will not line up with the downpipe. I couldn't get the bolts loose from the manifold so I took it off at the mid pipe. I bolted the downpipe to the midpipe and reinstalled. Now I can't bolt the downpipe to the turbo! It sits too far back and too far to the left (when looking from the front of the car). I think it has something to do with that bracket holding it to the trans, seems like its holding it back from coming all the way up where I want it.
I started it up without the downpipe connected and it runs, will rev but is very stumbly and my boost gauge shows no boost. Also my BOV didn't open. I'm assuming this is because of the wastegate not being sealed and the o2 sensor not being in the right way. Am I right?
My second problem is my jackson racing s/c (EVIL!!!) air filter is friggen HUGE and wont let the intake tuck in the corner, so I had to leave it too high and now my hood wont close.
All in all, I'm happy as hell its in and will run. The whole 30 seconds I had it running made me smile as I heard the turbo spool up. But I'm still in trouble, so hopefully you guys can help me out. Thanks.
miataspeed1point6 is offline   Reply With Quote
Old 09-04-2006, 01:41 AM   #2
Senior Member
iTrader: (2)
 
Join Date: Aug 2005
Location: Granbury, TX
Posts: 567
Total Cats: 1
Default

You wont build much boost if any at all just sittin there revving, and your BOV wont go off either, you car may be running bad because you dont have the o2 sensor hooked up to the exhaust stream but i expect its something else.
greenday3437 is offline   Reply With Quote
Old 09-04-2006, 01:54 AM   #3
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

well the car ran perfectly fine before I put the turbo in. I will wait to judge until I get the downpipe on the turbo tho, I need to drive it to work tuesday so hopefully all goes well.
miataspeed1point6 is offline   Reply With Quote
Old 09-04-2006, 05:02 PM   #4
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

Well I took it for a drive....HELL YEAH! its REALLY loud with just a down pipe, but from the gauges and noises it made I didnt hear anything ill sounding. I only went to 3 p.s.i. so I wouldnt hurt anything. And thanks to my crappy jrsc air filter the AFM wont fit, so I had to take the hood off.
One thing that does sound strange is the turbo spools up, but I dont enter boost, and sounds like it slowly winds down after I let off the gas. Should the BOV open so it doesnt do that or is this normal? It is a smooth wind down, not like a turkey gobble (but I have never heard that noise before).
And I painted my manifold with high temp paint when I first got it some 4 months ago to keep the rust down, and yeah it just burned right off lol. Good thing it wasn't intended to stay, but I do regret it as now it smokes like crazy. So with all hope it will make it to work tommorow and I can install my 1.8 injectors and get working on the emanage. Only thing holding me up with that is the dumb support tool. Winrar isnt working right so I need to locate it somewhere else.
miataspeed1point6 is offline   Reply With Quote
Old 09-04-2006, 05:10 PM   #5
Senior Member
 
Join Date: Jan 2005
Posts: 737
Total Cats: 0
Default

thats the exhaust turbine that you hear, since you are open exhaust youll hear that.
F20turbo is offline   Reply With Quote
Old 09-04-2006, 07:14 PM   #6
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

Well I have a new big problem. Once again the jrsc has screwed it up. The throttle body has that funky anti freeze coupling on the bottom. Under boost the bottom of it leaks. My question is how should I fix it? I'm pretty sure there is still some gasket material on the throttle body, I tried to sand it off but aparently I didnt do a good enough job. On the stock TB is there a gasket for this setup or is it all machined surfaces? And on a side note...why the hell does the antifreeze go over there?! So now my car has no hood, a raised intake and leaks antifreeze...but it also has turbo powah!

Should add, the jrsc relocates the TB to the drivers side and puts a dummy TB is put in the stock location. The person who installed the jrsc used a supplied gasket which hardened and when I tried to remove it broke apart.
miataspeed1point6 is offline   Reply With Quote
Old 09-04-2006, 10:24 PM   #7
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

Well after a close inspection I somehow missed that there is a gasket between them. Checking the dummy TB I found the gasket, which was hidden under a jackson racing orange gasket. Fingers crossed for the drive to work tommorow
miataspeed1point6 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
Need help - Stock Balancer and Fastforward overlay pulleys Frank_and_Beans Supercharger Discussion 13 09-12-2016 09:17 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:14 PM.