WTB: o2 Simulator - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


WTB Wanted to buy ads. Designated trademarks and brands are the property of their respective owners. forum cannot be held responsible for the outcome of any transactions.

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 04-26-2011, 11:32 AM   #1
Elite Member
Thread Starter
iTrader: (33)
 
RotorNutFD3S's Avatar
 
Join Date: Jan 2007
Location: Newnan, GA
Posts: 2,539
Total Cats: 29
Default WTB: o2 Simulator

I'm helping with a friend's car and we're looking for the o2sim sold by o2simulator.com, however, they're backlogged with orders and aren't taking new ones at the moment. Checking in the off chance someone on here has one they no longer need. Open to others as well as long as they work.

RotorNutFD3S is offline   Reply With Quote
Old 04-26-2011, 11:37 AM   #2
Senior Member
iTrader: (19)
 
Join Date: Oct 2007
Location: MoCo, MD
Posts: 703
Total Cats: 0
Default

After my brother's catalytic converted was stolen from his truck we used one very similar to this to get him through emissions before we could replace the cat.

http://cgi.ebay.com/Universal-Oxygen...item2a10066fad

They're a little more than o2sim.com, but are in stock.
pschmidt is offline   Reply With Quote
Old 04-26-2011, 02:29 PM   #3
Elite Member
Thread Starter
iTrader: (33)
 
RotorNutFD3S's Avatar
 
Join Date: Jan 2007
Location: Newnan, GA
Posts: 2,539
Total Cats: 29
Default

Thanks for the lead! I'll pass it on.
RotorNutFD3S is offline   Reply With Quote
Old 04-26-2011, 08:19 PM   #4
Junior Member
iTrader: (3)
 
Join Date: Mar 2008
Location: Murphy, Tx
Posts: 182
Total Cats: 6
Default

There is a cheaper easier way.
http://forums.evolutionm.net/evo-how...cel-light.html
I didn't think it's work but used it on my jeep and it worked great. I didn't have enough space to run two so I just did one, my cell has yet to return.
Fidgitk is offline   Reply With Quote
Old 04-26-2011, 10:36 PM   #5
Elite Member
Thread Starter
iTrader: (33)
 
RotorNutFD3S's Avatar
 
Join Date: Jan 2007
Location: Newnan, GA
Posts: 2,539
Total Cats: 29
Default

Tried that and it didn't work. I take that back, it worked for about 40 miles, which was not enough to let everything get back into the ready state, and then the CEL came back on. That was also with 2 in place. The o2 sim is install and forget. Thanks though!
RotorNutFD3S is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:37 PM.