99 MK Turbo beta test - Page 9 - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Build Threads Building a motor? Post the progress here.

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 05-12-2016, 09:18 AM   #161
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 12,214
Total Cats: 750
Default

Quote:
Originally Posted by Colipto View Post
How can i get this turbo :O or one similar that will fit mk turbo?
I sent you an email.
shuiend is offline   Reply With Quote
Old 05-12-2016, 10:14 AM   #162
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 33,169
Total Cats: 1,990
Default

there is something seriously wrong with that plot. it should not be dipping that bad up top, and your afr looks like it just flatlined, like it wasn't really reading
18psi is offline   Reply With Quote
Old 05-12-2016, 08:36 PM   #163
Junior Member
 
Join Date: Aug 2015
Location: Mass
Posts: 124
Total Cats: 4
Default

Quote:
Originally Posted by sonofthehill View Post
I bet I'll get some grief for this, but try playing with your wastegate can adjustment some. I was able to maintain over 200kpa to about 6500 with the smaller turbo. I run EBC too so I was at 14 or 15psi by around 3k IIRC.

When I switch back eventually, I plan to increase the wastegate preload another 1/2 turn.
Quote:
Originally Posted by sonofthehill View Post
Ignore my previous ramblings. You are referencing boost for your wastegate can post IC right?
Are you running EBC?
If yes and yes, then perhaps consider my previous post and retune EBC to match.
Yes and yes - Currently running ebc - adjusted the arm a few times and started retuning ebc - I now have less inconsistent boost so that was clearly needed - I'm thinking i might have to go farther with the arm but I'll know for sure tonight on my lunch break.

Quote:
Originally Posted by shuiend View Post
I sent you an email.
Thanks received - Might suit me for the future i have a feeling for more powa

Quote:
Originally Posted by 18psi View Post
there is something seriously wrong with that plot. it should not be dipping that bad up top, and your afr looks like it just flatlined, like it wasn't really reading
I'll have another plot sometime tonight - it really was pegged at 11 AFR during those pulls - i pulled up the log and verified
Colipto is offline   Reply With Quote
Old 05-12-2016, 09:42 PM   #164
Boosting since 1984
iTrader: (1)
 
stefanst's Avatar
 
Join Date: Sep 2011
Location: Levittown
Posts: 994
Total Cats: 38
Default

No way that AFR plot is real. Is 11 maybe the minimum your WB can read? If so, you may actually be running extremely rich up top. Would also explain why you're not making power up there.
stefanst is offline   Reply With Quote
Old 05-12-2016, 10:31 PM   #165
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 33,169
Total Cats: 1,990
Default

ya there is no way it would be so flawless as not to even deviate by .01 in boost

stefan might be right
18psi is offline   Reply With Quote
Old 05-13-2016, 12:56 AM   #166
Junior Member
 
Join Date: Aug 2015
Location: Mass
Posts: 124
Total Cats: 4
Default

Yeah you guys are right for sure... Something is up.

my afr table is targeting 11.8 however i am indeed running super rich.. might also explain why im filling up WAY more often since my turbo install - i feel like im driving a gas guzzler

I have an AEM wideband.. btw which i believe is working okay. when doing pulls my gauge reads 10.0 which is the lowest it reads i believe.

I'm just going to attach this log of a recent run

I didn't tune this fyi but if i am reading logs correctly i am dumping a helluva wayy too much fuel - my VE table is 220 across in the 250kpa range and seems to go down 20 points every kpa load below 200 180 160 140 120 etc non interpolated..( req fuel 4.8)

Very interested to hear feedback on this..
Attached Files
File Type: msl 2016-05-12_21.17.31.msl (356.5 KB, 26 views)

Last edited by Colipto; 05-13-2016 at 01:26 AM. Reason: added gauge afr info
Colipto is offline   Reply With Quote
Old 05-13-2016, 11:16 AM   #167
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 33,169
Total Cats: 1,990
Default

the feedback is that you need to actually tune your car.
and you probably have a limit set at 11afr lower reading, so really you could be flooding/washing the engine with fuel and didn't even know it.

really need to fix all those issues before you break something
18psi is offline   Reply With Quote
Old 05-13-2016, 01:12 PM   #168
Senior Member
 
Join Date: Oct 2013
Location: NorthWest NJ
Posts: 754
Total Cats: 28
Default

Yeah, you will have tonnnnns of gas in your oil if you are not careful! Check and see if it smells? Thatbwpuld give you an indication if you are running really, really rich.

Btw, these cars will run (at least at low boos, 5-6ish psi) happily at 9.3afr if you let them. My friends car would beltch smoke, but otherwise was normal doing that...
x_25 is offline   Reply With Quote
Old 05-17-2016, 09:51 PM   #169
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 684
Total Cats: 86
Default

For those who aren't watching my dyno/timeslip thread, here are the results.


Very little difference overall besides the spool difference. Red is the original smaller turbo blue is the larger .60 a/r compressor side.
Attached Thumbnails
99 MK Turbo beta test-80-dynoturbocomparison01_8613bb50eb297cf03284bc30490986ec89ecb9bf.jpg  
sonofthehill is online now   Reply With Quote
Old 05-17-2016, 09:53 PM   #170
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 684
Total Cats: 86
Default

Pretty sure there is something wrong with their WB O2 sensor as it doesn't jive with mine.
sonofthehill is online now   Reply With Quote
Old 05-17-2016, 09:55 PM   #171
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 684
Total Cats: 86
Default

Pretty sure there is something wrong with their WB O2 sensor as it doesn't jive with mine.
Also something with their "new software" shows my old dyno at over 8000 rpm, my plot is correct, never been past 7000.
sonofthehill is online now   Reply With Quote
Old 05-17-2016, 10:02 PM   #172
Junior Member
 
Join Date: Aug 2015
Location: Mass
Posts: 124
Total Cats: 4
Default

Yep.. currently in the middle of replacing my WB02 pretty sure thats it thanks for the help.

reviewed some old logs and my afr's were on point

sensor lasted what like 2 months ?.. FML..

Colipto is offline   Reply With Quote
Old 05-17-2016, 10:12 PM   #173
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 684
Total Cats: 86
Default

Oops, sorry I meant the dyno shop's WB O2 sensor. They have me reading like 15:1 at 180 ft/lbs, my logs show much closer to 11.8:1 and no real ping was logged so....
sonofthehill is online now   Reply With Quote
Old 05-19-2016, 01:16 PM   #174
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 684
Total Cats: 86
Default

Still chugging along.
Attached Thumbnails
99 MK Turbo beta test-80-img_20160518_200858661_hdr_dbf5bd976a612fa5b685b736bab161db2eef02f5.jpg  
sonofthehill is online now   Reply With Quote
Old 05-22-2016, 03:44 PM   #175
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 684
Total Cats: 86
Default

Been wanting to do this for a while now, my wife finally agreed and gave me some time to play with my car this weekend.


Because I needed to fix this anyway.


Now that I know they will let me run 12's with my hardtop back on.
Attached Thumbnails
99 MK Turbo beta test-80-img_20160522_111521527_hdr_02ddc32dfcdfeadc5a1f78db90b82c8ed365244d.jpg   99 MK Turbo beta test-80-img_20160522_111612639_d8f2f02e61bfc8606de3b70b87f957206c323a7f.jpg  
sonofthehill is online now   Reply With Quote
Old 05-29-2016, 03:15 PM   #176
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 684
Total Cats: 86
Default

Here is the hooptie mount I made to hold my cell phone for passenger perspective videos like the one on my dyno's and time sheets thread. My silicone case allows too much vibration to get a solid video, but it works okay.
Attached Thumbnails
99 MK Turbo beta test-80-img_20160529_103601781_f780ed8d9784bad9f9b14dc7f47e5779d8e8c244.jpg  
sonofthehill is online now   Reply With Quote
Old 05-29-2016, 03:32 PM   #177
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 684
Total Cats: 86
Default

Managed to score this nice manifold today. It looks almost like a replica of my MK Turbo manifold, I bet the downpipe would fit no problem.


Attached Thumbnails
99 MK Turbo beta test-80-img_20160529_103457523_985360ec64942808ee9fdacf8376186d24ffcb44.jpg   99 MK Turbo beta test-80-img_20160529_103342591_61d42119ceee919e355938494aeeec7e9820aa53.jpg  
sonofthehill is online now   Reply With Quote
Old 05-29-2016, 07:22 PM   #178
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 12,214
Total Cats: 750
Default

Quote:
Originally Posted by sonofthehill View Post
Managed to score this nice manifold today. It looks almost like a replica of my MK Turbo manifold, I bet the downpipe would fit no problem.


Looks pretty close. Just picked it up for ***** and giggles?
shuiend is offline   Reply With Quote
Old 05-29-2016, 09:03 PM   #179
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 684
Total Cats: 86
Default

Quote:
Originally Posted by shuiend View Post
Looks pretty close. Just picked it up for ***** and giggles?
Basically, it was local and I just couldn't pass it up.
Need I state the reasons I think your kit is so good again. I really think that the placement of the turbo is ideal for log style ps/ac setups.
I always think about getting another Mazda, so who knows. Not to mention what a high demand there is for your manifolds, I hear they go for $1500.
sonofthehill is online now   Reply With Quote
Old 05-31-2016, 01:13 PM   #180
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 684
Total Cats: 86
Default

My best timeslips, so far on CA 91
Now at 11,000 miles on the kit, odometer turned 238,000 at the track yesterday. Granted I am running a different turbo now but the original one is bagged and boxed in great shape with no shaft play when I pulled it out full of oil.
Attached Thumbnails
99 MK Turbo beta test-80-img_20160530_235608571_e717070783916c981c9088ed5cd88f52d705525e.jpg  
sonofthehill is online now   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Another Cast Manifold Corky Bell Prefabbed Turbo Kits 18 11-22-2016 10:01 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:05 PM.