ITT: Your opinion on if I should use this block - Page 2 - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

Engine Performance This section is for discussion on all engine building related questions. KMiata

LinkBack Thread Tools Search this Thread
Old 09-09-2011, 03:20 AM   #21
Elite Member
iTrader: (1)
NA6C-Guy's Avatar
Join Date: Feb 2008
Location: Birmingham Alabama
Posts: 8,038
Total Cats: 39

With the combination of all of the things that went wrong with this engine, I would say get a new block. Considering blocks are dirt cheap. You obviously lost the oil pump, and I guess somehow continued to run dry until the cam seized. So long as you slap in some new bearings, it's maybe OK to run that block, but as I said, for the price I would want to wash my hands of that disaster and start over with a new block.
NA6C-Guy is offline   Reply With Quote
Old 09-09-2011, 12:42 PM   #22
Elite Member
Thread Starter
iTrader: (4)
MartinezA92's Avatar
Join Date: Aug 2009
Location: Sunnyvale, CA
Posts: 1,572
Total Cats: 9

I found myself a head and took it to a machine shop to check if its good to use. They said it was. Slap it on the block and pump air into it and its leaking enough to make the turbo spin and there is air coming out of the cylinder next to it. 30 psi of compression. I know I installed the head gasket correctly and I torqued the head to the right numbers in sequence. I got fucked.

I decided to find myself a running '94 longblock and drop it in. Because I'm tired of riding my bike everywhere and school starts soon, I ended up overpaying for it. Its the only one I could really find. Should be dropping that in this weekend. Oh well.

Will probably fix this head on the cheap and sell it with another block and a spare 6 speed I have laying around to try to recoup my losses. Forged internals are in my future. **** not driving the Miata for this long.
MartinezA92 is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
300hp from a 1.6, your recipe Pepino DIY Turbo Discussion 61 02-02-2016 01:38 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 02:44 PM
wiring wideband ground to battery terminal btabor ECUs and Tuning 10 09-28-2015 05:33 PM
Headphones PaperMate Insert BS here 32 09-25-2015 08:22 AM
Twitchy car (tail happy problem) bigben Race Prep 16 09-11-2015 03:41 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 01:10 AM.