Aggravating electrical problem - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

General Miata Chat A place to talk about anything Miata

LinkBack Thread Tools
Old 04-26-2008, 02:30 AM   #1
Senior Member
Thread Starter
iTrader: (10)
Join Date: Feb 2007
Location: South Eastern Wisconsin
Posts: 1,282
Total Cats: 0
Default Aggravating electrical problem

So I am having a bitch of a time trying to figure out this one. My headlights will not go down. They go up just fine, and the lights turn on and off, but they will not go back down after turning my headlights off. The dash retractor switch doesn't do anything either. I know for a fact that the switch is good (as I tried 3 other known good switches), and that the connector going to the switch is good. I checked all fuses and relays, pulled the dash and checked all the wiring, it appears to be OK. I am left with the "retractor relay unit" under the dash/steering column, which apparently isn't in the same spot on a 90 (only other Miata in the shop right now). It just seems to be a module with a few relays inside it. When the headlights go up, I can feel it click so I know that that part of it works. Can't find a wiring diagram for the internals of it though.

Here is the weird part.. Yesterday, while trouble shooting no interior lights, the headlights and the retractor switch worked fine. Even after figuring out why my interior lights didn't work and correcting that (Accidentally plugged the wrong connector into the dimmer switch, apparently the fog connector fits too lol), they still worked. I didn't really do anything that could cause them to not work after that so at this point I am completely stumped. I am going to try to find a different relay module thingy to see if that is it..

This probably doesn't make any sense, I am half asleep, but if anyone has any ideas feel free to share them..
ApexOnYou is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 12:25 PM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 12:45 AM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 01:42 PM
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 4 09-28-2015 10:10 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:45 PM.