Bad oil pump? - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

General Miata Chat A place to talk about anything Miata

LinkBack Thread Tools
Old 09-01-2007, 03:16 AM   #1
Junior Member
Thread Starter
Join Date: Aug 2007
Location: Issaquah, WA
Posts: 166
Total Cats: 0
Default Bad oil pump?

I am getting a very light knocking/tapping noise. It will only happen when the motor is very cold and the temperature is very cold out and I first start the car. It will knock for a second then be perfect. I also notice it when im about 4k-4500 rpms and I let off the throttle so that there is almost 0 load on the car. The 3 rd area I hear it is sometimes when I let off to shift. And its never for long just a split second. Is the oil pump's pressure directly correlated to whether or not the motor is accelerating? It seems like the oil isn't getting somewhere in the motor just for a split second when I let off the gas. Any ideas?
piratetim is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 03:00 PM
Moroso Air Oil Separator Catch Can Aroundcorner Miata parts for sale/trade 2 10-01-2015 03:20 PM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 09:17 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 10:28 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:05 PM.