Fog Light Indicator Always On - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

General Miata Chat A place to talk about anything Miata

LinkBack Thread Tools
Old 04-07-2014, 11:11 AM   #1
Senior Member
Thread Starter
iTrader: (5)
Join Date: Nov 2013
Location: Wisconsin
Posts: 659
Total Cats: 66
Default Fog Light Indicator Always On

My 99 doesn't have foglights. Recently I've noticed that my fog light indicator on my dash is always on.

I have ebay reverse glow gauges installed, and also did a fuse tap to power my boost/oil pressure/WBO2 gauges--I have a feeling the issue is related to one of these.

I'm going to tear everything apart again here and see if I can find a crossed wire somewhere.. but assuming that I can't, does anyone see a problem with me just pulling the bulb? Or is there something else that I can check out first if all the wiring seems to be okay behind the dash?


Edit: I also found this.

But no mention of fog light indicator so I'm not sure which pin it is...

copied from BarbyCar in the LED gauge cluster thread....
Here is the pinout for the 2000 if that helps.

They are in the wiring diagram section C-a and C-b but for those without diagrams, here they are:
There are three connectors 1, 2 and 3. From the driver's seat 1 is on the left, 3 in the middle and 2 on the right. Each connector pinout starts at "a" and the blue circuit is labelled with an appropriately placed "a".

1a= BR/B - Fuel System (ECU and fuel gauge sender)
1b= BR/Y - Cruise Light (from cruise module)
1c= B/Y +12v Switched (from meter fuse)
1d= No wire or P/B - If applicable, ABS light (from ABS module)
1e= No wire or R/W - If applicable, Automatic O/D light (from transmission control module)
1f= L/R +12v Unswitched from Room fuse
1g= Not used
1h= W - DRL module (high beam light) - No wire if no DRL
1i= R/Y - Headlight relay (via LH headlight fuse) - note R if no DRL
1j= not used
1k= not used
1L= W/R - Door switch (interior lights)
1m= Y - Speed sensor for manual. No wire for automatic
1n= B/L - Ground
1o= not used
1p= V - Start signal - from ign switch on manual. B/R from transmission control module if auto

2a= V/W - Water temp (from temp sensor)
2b= L/W Seat belt (seat belt switch - driver's side reel)
2c thru 2j not used
2k= G/O - ECU (and data link connector - also transmission control module if auto)
2L= W/B - ECU and cruise control module
2m= O - Speed sensor for manual. B/W from transmission control module for auto
2n= not used - goes to empty lamp socket
2o= W/L - ECU - controls CEL
2p= not used

3a= G/B - Left turn signal
3b= BR/R - ECU
3c= L/Y - Brake fluid light (and DRL control module. If no DRL then also to parking brake switch)
3d= BR - Air Bag module (and data link connector)
3e= Y/R - Oil Pressure "gauge" switch
3f= L/O - Key reminder switch
3g= R/B - Instrument lights +12v from TNS relay
3h= GY/R - Instrument lights dimmer control to ground
3i= G/W - Right turn signal
3j= B - Ground (connects internally in cluster to high beam light if no DRL)

L=Blue, B=Black, BR=Brown, G=Green, GY=Grey, O=Orange, R=Red, W=White, Y=Yellow & V=Violet
Attached Thumbnails
Fog Light Indicator Always On-imag0455_rx0ncdr5ol.jpg  

Last edited by mlev; 04-07-2014 at 11:24 AM.
mlev is offline   Reply With Quote
Old 04-07-2014, 12:31 PM   #2
Senior Member
Thread Starter
iTrader: (5)
Join Date: Nov 2013
Location: Wisconsin
Posts: 659
Total Cats: 66

Well, turns out it was actually my CEL. I deleted my EGR while I had everything torn apart for my clutch/coolant reroute (and also forgot to hook up the MAF and IAT connectors before firing it back up...heh...)

Which is weird, because I'm pretty sure there's a spot for the CEL between the tach and speedo on that little cluster.

Oh well, problem solved I suppose.

Attached Thumbnails
Fog Light Indicator Always On-imag0456_x17nwmgdkq.jpg  
mlev is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 52 08-28-2016 04:18 AM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 09:39 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 12:45 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 10:28 PM
Another Alternator thread ihiryu General Miata Chat 9 09-28-2015 10:22 AM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:36 PM.