Fuel odor shortly after pump install - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members

General Miata Chat A place to talk about anything Miata

LinkBack Thread Tools
Old 07-22-2010, 02:40 PM   #1
Check out my part outs.
Thread Starter
iTrader: (26)
thirdgen's Avatar
Join Date: Oct 2007
Location: The coal ridden hills of Pennsylvania
Posts: 5,454
Total Cats: 116
Default Fuel odor shortly after pump install

So like 2-3 months ago I installed a walbro 255 pump in my 99. Lately when I drive it, I smell a fuel scent that grows as I drive. I see no leaks under the car or near the fuel rail, it smells like it's in the seat area. Think maybe the gasket on the pump plate that had the Phillips screws in it didn't seat right? Any suggestions/ tips to fix?
thirdgen is offline   Reply With Quote
Old 07-22-2010, 03:03 PM   #2
Senior Member
steelrat's Avatar
Join Date: Jul 2005
Posts: 514
Total Cats: 0

Triple check all the connections.... Probably left something a little loose. <G>

steelrat is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 52 08-28-2016 04:18 AM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 03:00 PM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 09:17 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 10:28 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:53 AM.